Virtualbox only showing 32 bit iso options

Hello,
I have installed Virtualbox with linux 149-virtualbox-host-modules as well as virtualbox-guest-iso on a Thinkpad X200s running Manjaro XFCE. It works, but I only have the option to install 32 bit ISOs. After searching online I realized I didn't have VT-x or VT-d enabled. They are now enabled but still nothing.

Possible to fix?

Thank you!

More precise specs:

System:    Host: bird-in-space Kernel: 4.19.59-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           Desktop: Xfce 4.13.5git-58bf69 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 7469A41 v: ThinkPad X200s serial: <filter> 
           Mobo: LENOVO model: 7469A41 serial: <filter> BIOS: LENOVO v: 6DET42WW (2.06 ) 
           date: 03/17/2009 
Battery:   ID-1: BAT0 charge: 24.7 Wh condition: 87.3/94.0 Wh (93%) model: Panasonic 42T4696 
           status: Charging 
CPU:       Topology: Dual Core model: Intel Core2 Duo L9400 bits: 64 type: MCP arch: Penryn 
           rev: 6 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 7450 
           Speed: 1158 MHz min/max: 800/1867 MHz Core speeds (MHz): 1: 827 2: 812 
Graphics:  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Lenovo driver: i915 
           v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting 
           resolution: 1280x800~60Hz 
           OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express v: 2.1 Mesa 19.1.2 
           direct render: Yes 
Audio:     Device-1: Intel 82801I HD Audio vendor: Lenovo ThinkPad T400 driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.59-1-MANJARO 
Network:   Device-1: Intel 82567LM Gigabit Network vendor: Lenovo ThinkPad T400 driver: e1000e 
           v: 3.2.6-k port: 1840 bus ID: 00:19.0 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel Ultimate N WiFi Link 5300 driver: iwlwifi v: kernel port: 1c60 
           bus ID: 03:00.0 
           IF: wls1 state: up mac: <filter> 
Drives:    Local Storage: total: 1.93 TiB used: 31.27 GiB (1.6%) 
           ID-1: /dev/sda vendor: Toshiba model: Q300 size: 111.79 GiB 
           ID-2: /dev/sdb type: USB vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB 
Partition: ID-1: / size: 100.87 GiB used: 31.27 GiB (31.0%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 48.0 C 
           Fan Speeds (RPM): fan-1: 3691 
Info:      Processes: 170 Uptime: 8m Memory: 7.69 GiB used: 1.14 GiB (14.8%) Init: systemd 
           Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 inxi: 3.0.34 

What do you mean? :sweat_smile:

If your VirtualBox only shows 32 bit options then you need to reboot into your firmware

systemctl reboot --firmware-setup

Then enable virtual extensions - VT-d (it has different names but you get the idea)

Once a Virtual Machine is created as 32bit you cannot change it.

Remove and delete it then recreate.

1 Like

When I run that I get:

Cannot indicate to EFI to boot into setup mode: Firmware does not support boot into firmware.

you have to go into bios and enable Intel (R) Virtualization Technology or something similar

Older firmware do not support the reboot --firmware - it is a newer thing driven by security - to make it more difficult to get into the firmware and alter system properties.

As it is a ThinkPad you use F1 to enter the BIOS maybe you have the blue Think button.

The system supports (ark.intel.com) VT-x and from your OP it seems you have enabled it.

  • Bios date 03/17/2009
  • CPU Intel Core2 Duo L9400

https://duckduckgo.com/?q=lenovo+ThinkPad+x200s+7469A41+firmware+download

It seems there is a firmware version 4.2.21.1037 from 201.05.13 but not available from Lenovo anymore.

Are you using libreboot? Your system may be supported

https://libreboot.org/docs/hardware/x200.html

Also the libreboot x200 page indicates that vt-x is flawed on x200

Enable virtualization in BIOS, assuming your CPU supports it.

1 Like

I did that and at first nothing changed but now suddenly I have it working. So I guess it was only the BIOS settings that needed to be changed after all, even though it didn't help immediately for some reason. Thank you everybody for your time!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by