VirtualBox: Problem with GuestAdditions Manjaro XFCE 4.19 Host, Windows Vista Guest

Hi everyone,

I have (re)installed/made the up date of the Guest Additions to its 6.0.8 version within my Windows Vista Pro OS as a guest. The installation seems to have been made correctly. I directly rebooted Vista after it. Since this moment, as soon as I have tried to open a file, save a file or to browse in the folder present around the "Computer" page of Windows Vista, the system of Vista (as guest) breaks and reboots by itself... I do not know if the problem is linked with the fact that I apparently see in pamac that I have two different virtualbox-host-modules installed (since I have two different kernels 4.14 and 4.19, I would say that it is normal to have both installed, but I could try to uninstall the 4.14 one).

Now the Windows Vista system breaks as soon as I start it without doing anything like 1/2 minutes after the boot. The error message is the following:

Nom d’événement de problème: BlueScreen
Version du système: 6.0.6002.2.2.0.256.6
Identificateur de paramètres régionaux: 1036
Informations supplémentaires sur le problème:
BCCode: 19
BCP1: 0000000000000020
BCP2: FFFFFA8002049330
BCP3: FFFFFA80020493A0
BCP4: 000000000C070002
OS Version: 6_6_6002
Service Pack: 2_0
Product: 256_1
Fichiers aidant à décrire le problème:
C:\Windows\Minidump\Mini062919-03.dmp
C:\Users\John\AppData\Local\Temp\WER-67484-0.sysdata.xml
C:\Users\John\AppData\Local\Temp\WER1F89.tmp.version.txt

I do not know if this problem is linked with the fact that my Windows Vista is not authenticated and that I do not remember where I have downloaded the iso of Vista. Nevertheless, before this installation, I have worked everyday with Vista as Guest in the VirtualBox without problems!

I need unfortunately Windows for launching FileMaker Pro.

Does someone have an idea how to solve it?

Thanks a lot in advance !

What version of VirtualBox do you have installed?

Hi @jonathon,

Thanks for your answer. I have installed the version 6.0.8-2 of VirtualBox.
The virtualbox-ext-oracle installed from AUR is the version 6.0.8-1.
The installed virtualbox-guest-iso is the version 6.0.8-1.
The installed linux414-virtualbox-host-modules is the version 6.0.8-6.
The installed linux419-virtualbox-host-modules is the version 6.0.8-6.

Thanks again.

1 Like

Some precisions:

  • the Guest Addition that I have used before was probably 6.0.4 but it apparently did not recognise the CD player for example in Vista.

  • when the Vista system breaks, some red strips appears at the top of the screen.

  • The image of the Welcome message of Vista is the following:

Vista

  • After the boot, this time it has not crashed by itself after maybe 5 minutes and as soon as I try to open something from the share folder I have with my Host machine, it breaks, as it was the case in the beginning (see the description above).

Should I try to reinstall the Guest Addition and if yes, is it possible to do it by clothing the Virtual Box and uninstalling it in Pamac and installing it again in Pamac?

I have uninstalled virtualbox-guest-iso from the community repository in pamac and then reinstalled it and then rebooted. In my Manjaro Host, I have deleted the VBoxGuestAdditions.iso in the VirtualBox configuration and then have readded it but it has not solved the problem.

Just to make it clear: Windows as Guest breaks as soon I want to browse, open, save something in C:\ or browse the "computer" ("ordinateur") menu. It does not break by itself a few seconds after the boot.

Here is the message of error I can see in windows as Guest before it reboots automatically:
DSCN8621

Please could someone help me?

Thanks a lot in advance.

After the Stable Update of the 3rd July, the Windows logo appear now normally in the VirtualBox after the boot but as soon as I am clicking in the start menu to "Computer" (ordinateur), Vista breaks.

@jonathon, sorry for bothering you, but you maybe have an idea?

Thanks in advance.

edit: after this update the versions installed are the following

The installed linux414-virtualbox-host-modules is the version 6.0.8-10.
The installed linux419-virtualbox-host-modules is the version 6.0.8-11.

The other installed packages are still the same as above.

edit 2: if I good remember, before updating the Guest Addition within my guest Vista, the version 6.0.4 was running. Could it be a good idea to try to reinstall it and, if yes, how?

  • After the Stable Update of the 1st August 2019 (note that I have skipped the two last updates),

  • after uninstalling and reinstalling virtualbox-ext-oracle from AUR in order to update it from the version 6.0.8 to 6.0.10-1

  • and after having updating the Guest Additions within Windows Vista by launching something like D:\VBoxWindowsAdditions.exe in order to upgrate the Guest Addition from the version 6.0.8 to 6.0.10-1,

my problem seems to be solved.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by