Virtualbox - USB <no devices available>

Tried every possible fix for this by reading other post etc...
usb devices don't show on windows 10 machine

I just told you I followed every step on that post and it doesnt work

No you did not.

  1. did you build the oracle extension pack?

    pamac build virtualbox-ext-oracle

  2. Did you add your host username to vboxusers group?

    sudo gpasswd -a $USER vboxusers

  3. Did you logoff/login to make group permission effective?

  4. Did you insert the guest iso into the Windows guest and installed the drivers?

yup did all that

Did you remember to reboot your system to make possible kernel updates effective?

yes everything is up to date

But did you reboot?

yup ,

And did you select the appropriate USB (2.0 or 3.0) controller in the VM's settings?

2.0 is selected

Try 3.0 too.

If you USB controller is USB3 - did you set it appropriately in the settings pane of VM

did that doesnt work

Make sure the USB device is NOT mounted on the host.

ok I just unmounted it in the file manager

Then reboot your VM and add the device again.

Well - I don't know then.

I have several Windows VM's both Windows 7, Windows XP and Windows 10 and all can have USB drives attached to them.

Last thing: Stop your VM - not save but shutdown - and clear all USB devices filters you may have added. Verify the controller is correct and start the system again.

A device mounted in the host will automatically be unmounted - at least this is the default behaviour - but if you have a file manager open on the device it will not be possible for VB to unmount the device.


EDIT: I just tested a mounted device with a file manager open on the device and attaching it to a Win 10 vm - immediately results in error in the filemanager

Image

20190619-110002_643x366_screenshot

I think the problem is that OP had the device mounted on the host, in which case the guest cannot recognise it.

ye usb device still not showing u think having windows 10 burned on the iso is a problem? the main goal im trying to do is get my phone recognized on my vm

Forum kindly sponsored by