Virtualbox USB only visible as root

Hello, I have been trying to get VirtualBox see my USB devices.

At the moment this only works for me, if i use it as root.

I am part of the vboxusers group.

This problem is present on my main computer and on my laptop.

I also found https://ulyaoth.com/tutorials/virtualbox-usb-fix-for-non-root-users-in-linux/ website, which seemd to solve my problem, but led to boot errors. My computer booted normally, but there were USB error warnings.

What this website told me is to put this at the end of my fstab file.

none /proc/bus/usb usbfs devgid=$vboxusersGorupId$,devmode=664 0 0

Hopefully some of you might know the answer!

Thanks a lot in advance!

moderator edit - make target link visible

So i managed to solve it.

The Problem seems to be, that when installing VBox and the extention pack through Pamac there are no udev rules created for virtualbox.

Then just by following https://github.com/dnschneid/crouton/wiki/VirtualBox-udev-integration post, and actually creating the missing rules, the system works.

Excuse me for opening an extra post.

moderator - make target visible

There is no need for udev rules - at least I have not had the need.

Just build the virtualbox-ext-oracle

  • add yourself to vboxusers group
  • log off
  • login
  • start your vm
  • use the usb icon in the status bar to list available usb devices
  • select the desired device
  • use it

I actually tried this, but it did not work...
I have no idea why.

Funnily enough my desktop hat a udev rule, that was incomplete and my laptop didn't have any...

Hmm - You made curious if udev rule for vbox exist on my system - complete or not :slight_smile: and I have none - and no problem using USB devices either.

Some time ago - years - I found that the best way of attaching USB devices was on the fly - I was a novice Linux user at that time - so I tried to create rules using the usb page in the vm configuration and I couldn't make it work.

I eventually learned that unless you have very special need - you should ignore that page - and add then on the fly.

Oh - and I have also tried to map a mouse and keyboard - with catastrophic results for the host :grin:


So I wonder - what may have caused your issues

Very interesting and strange...

Well hopefully no one has the same problem. But at least now the solution should be easy to find.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by