Virtulbox - Host W10 / Guest Manjaro KDE - Share Folders

Greetings all,
I have searched on this forum for this problem and couldn't find out quite the same for what I need.
If you don't mind I would like to "create" a tutorial for us newbies on how to share folders between a W10 host and Manjaro KDE guest.
Please don't throw tomatoes at me because I have search and tried many solutions and non of them work for my case :slight_smile:
So here I go :
On Windows 10 (host) I have installed Virtualbox 6.0.4
On the guest - Manjaro 18.3 - KDE - Fresh and all the updates. Kernel in guest : 4.19.28-1
After this if I switch to fullscreen the resolution is still small. Copy/Paste is not working from guest to host and vice versa. There is no Media folder to see the mounted folders from the Host.
So usually after this I do 4 things in Manjaro KDE :
1. Install headers :
image

2. autorun.sh from the mounted Guest Additions CD iso. I get this :
image

3. make sure my user is in the group - vboxsf
image

**4.**After reboot - on the folder media → "Ownership on Active User"
And after this, Voila !!! - the shared folders appear in the folder media and everyone was happy.
But no more Voila since Virtualbox 6.0...
The folder Media :
image

And also everytime when I reboot I get this + 2 minutes of waiting :
image

Until now I did this on every new Manjaro machine (guest) and it worked flawlessly
Does anyone have the patience to explain step by step what should I change ?

Manjaro has binaries for the guest util as a package. You should never have to install these from the guest ISO.

The guest kernel modules should install automatically when you install Manjaro on the guest.

You should - if using Manjaro in the guest - install the package virtualbox-guest-utils from the repo.

I have tried from this and on

but with no change.

the same for this
Only if I install from ISO - i get vboxsf in groups

What would you recommend me to do next step ?

I found a solution ish...
I DID read you post and DID try everything I saw in forums, but I still couldn't find out a solution for everything to work smooth.
My concearn is that I don't know it the problem cand be fixed from my guest or from Virtualbox.
So I followed these steps :

  1. linux419-headers 4.19.28-1 and linux419-virtualbox-guest-modules 6.0.4-10
  2. Insert Guest Additions CD Image… → "autorun.sh"
  3. User Accounts → vboxsf
  4. Restart
  5. media → "Ownership on Active User&rdquo"
  6. Insert Guest Additions CD Image… → "autorun.sh"
    After this, 99% work fine, except I get the 2 minutes waiting time when restarting the machine :
    image
    If I "sudo systemctl disable vboxadd" - sharing it's ok, except except full screen does not work anymore - can't change the resolution or make it fullscreen.

PS.
if I change the resolution (in Guest), after 1 second it changes back to 800x600

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by