VLC, a solid media player... BUT on Manjaro?

I don't use VLC anymore, but the biggest problem for me was the video output set to auto which didn't work well. Better set the right output for your system.

2 Likes

Using it here on KDE,I get no issues whatsoever
VLC 3.0.8-6
Kernel 5.3.1-1
Nvidia 440

@cscs

It worked for me. I couldn't get VLC to quit and I had to reboot to play another video.
I am not a GNU/Linux expert. I use the terminal sometimes.
I am trying to learn what I can about GNU/Linux.

Update. Installed smplayer, pretty slick.

1 Like

I wonder what was the change?

I have the same issue with VLC not exiting properly to the point I must reboot to play another file later on. However, I'm running AMD (Radeon HD 7660D) and have libva-mesa-driver and libva-vdpau-driver installed. Reading thru @cscs link, I can verify the proper configs as well.

1 Like

Also make sure to check VLC configs - such as output etc.

image

image

(also - for example, on some chromebook I forced linux on, I had to set it to X11 to get decent playback because of drivers and blah ... but if you have everything working properly, and set the configs properly .. VLC should work.... like I said, it just seems more 'finnicky' than I remember from years ago)

4 Likes

My settings were on automatic. After setting it to the VDPAU options as shown; it seems vlc is exiting properly and launching again just fine. Seems like 'finnicky' is a good descriptor ¯_(ツ)_/¯

1 Like

Same here. After changing it to @cscs 's suggestion I noticed that my video playback stopped flickering each time I changed the system master volume or switching workspaces.

1 Like

Another vote for smplayer. I simply keep VLC installed as a backup. For those complaining about VLC not shutting down properly, this is a known bug with VLC.

This issue been posted about on the forum quite frequently. The last time I recall reading about this there was still no fix, but there may have been somewhat of a workaround if I recall correctly. Search the forum.

2 Likes

Like you i use smplayer and like it quite well . VLC is the first thing i uninstall when installing fresh . Its UI is absolutely horrid .

2 Likes

VLC crashes for me on every distro.

I have found celluloid/gnome MPV to be incredibly stable. I've never actually had a crash or an out of sync playback on celluloid

Have to agree... lately VLC has been crashing on me or completely immobilizing my PC. Nothing to do with Manjaro, happened in Mint 19.2 also. Shortage of RAM, sure, but it seems to be getting worse. I'll look at Celluloid and SMPlayer and find out if they support HEVC x.265 as well. That format is saving me gigabytes in videolibraries :wink: Synchronization of subtitles is supported already I saw. And I have been using VLC for soooo many years. Sorry to see it go...

Once you try smplayer you will not miss VLC. Be sure to install the themes to improve its appeance.

3 Likes

Thanks for the heads-up, will do so tonight straight-away :nerd_face:!

So true. Last month, I moved over to SMPlayer, and after using it for a little while, I removed VLC from my system. It is sad to see a once beloved "Swiss-Army Knife" of a video player decline as much as it has.

1 Like

I am following this thread since quite some time and have no issues with vlc. Running chromium-vaapi, I might already have a good setup for hw-acceleration. Only ticked vaapi in vlc settings, that was all. When mpv and parole using 12-15% cpu, vlc uses 7-8%. Xfce, testing.

yes me too.
my problem with VLC is when after playing video from external hard disk. my external hard drive cannot be ejected. I have to shutdown my PC first.

Weird. Is the vlc process not properly terminating and still running - thus preventing a umount?

yes last time I use, vlc process cannot be closed, even with (right click) (exit) option in vlc systray doesn't work.
I try reproduce today, the problem does not exist anymore, maybe because of the last update.:sweat_smile::sweat_smile:

In that case try terminating all vlc processes to at least umount an external drive without the need to reboot.

$ killall vlc

and if this wasn't enough to "convince" the hanging process to terminate, follow up with:

$ killall -9 vlc
2 Likes

Forum kindly sponsored by