VLC quits to tray, can't open a new video and can't close from tray.

It has been a long pending issue w.r.t. VLC.

After I play a video, when I close VLC (after playing few videos), it quits to tray (I'm using Manjaro KDE). But, I cannot open a new video and I cannot even quit VLC from tray. I'm not sure if this is an issue with VLC or Manjaro.

I have already read similar threads on various forums including Manjaro, the best answer I found is to Edit VLC application and change the command to "vlc". It worked for some time, but, today, I updated Manjaro and the command went back to default. Of course, when I edit the command back to "vlc" it is working fine. But, I felt this is not a permanent solution to this issue.

Why is this bug still exists after years? I have seen this issue an year before and today too. Any idea what's stopping this bug from being fixed?

Try the search there's a few threads on this.

1 Like

Did you read my post actually?

I did. Since "similar threads on various forums" leaves me with no idea what you have or haven't read I linked you to the point in a thread wherein I received help that solved the exact issue you're describing. I haven't dealt with said issue since that post. :man_shrugging:

I have mentioned "similar threads on various forums including Manjaro".

That is not the default behavior tho, not on my installs anyway. When i close from X is simply closes vlc all together, same as Ctrl+Q. No tray and no ghost process. My default look and feel settings.


Quit vlc and remove or backup first the ~/.config/vlc/ then remove the folder, and start vlc again.

1 Like

This was one of the first bummers I faced upon installing Manjaro. Try disabling "Allow only one instance" and "Use only one instance when started from file manager" options under "Playlist and Instances".

In general, it closes properly. But after I play one or two videos (to be honest there is no exact number to repeat the issue), VLC closes to tray and can't quit it either with X or Ctrl+Q. That's the issue.

~~ I've done deleting vlc in config, but still the issue remains as it is.

I have the same VLC not quitting problem, as far as I know the behaviour started almost one year or so ago...
Started with version 3.xx ...

Most of the times with I pinpoint it to filepath or filename containing spaces...

The only mode to exit it, is by issuing a full "kill -9" on its PID via terminal ....

1 Like

The above linked thread solved this issue for me and it has not returned. Have y'all tried that solution?

Having this problem with both Allow only one instance and Use only one instance when started from file manager disabled or active ...

Tested with both options ( ON and OFF) , same bad behaviour ...
Confirm that the issue appears if the filename contains spaces ...

For now only a kill -9 VLC PID solves this ...

1 Like

The above lnk shows setting the output setting correctly, which has solved yhe issue for me. I have never touched the mentioned settings.

It's probably an issue not for you, may be. To be frank, I have tried all the available solutions on the internet (as far as I believe, of course this includes Manjaro forum's solutions) and none are actually 'fixes' to the issues, but 'tricks' to bypass the issue. My original post mentions about the fix that I use. But that's not a solution for the issue.

The issue remains with VLC, unresolved, till date. I watch a lot of videos and I'm facing this issue a lot. In fact, my new-linux friends asked me many times regarding the same issue. I've tried alternatives like mpv, smplayer, but they doesn't suite my taste & needs.

I can confirm this issue still persists even with the above mentioned solutions. I have tried the linked post changing the output and input, I have tried changing the command to vlc, and changing my settings on allowing only one instance. The only work around that works is to press CTRL+Q or stopping the media with S before pressing the X button. Interesting enough, it also works when the media is paused. If you press the X while VLC is playing a file, it will cause this behavior and you have to kill the process. This is happening on the XFCE desktop for me. Is it possible its another setting in changing those settings linked above and we just have to find the correct one for us, or is it an issue VLC needs to fix.....

1 Like

If you can easily reproduce this issue you may want to report it to VLC.


I used to have this issue but after I switched from AMD (crappy Navi drivers) to Nvidia I haven't had it yet, so maybe mine was a video driver issue.

I've also had this problem (using XFCE). This solution (changing video output to XCB) solved it for me:

1 Like

Which one? XCB XVideo output or XCB X11 video output?

For me both of them work...

1 Like

Yup this solved the issue for me. Changing the output to XCB fixed it and closes properly while the media is playing when the X is pressed. It also fixed a problem I was having with some media not playing. Is that the codec that was changed that is uses to display video? It could be a driver issue like someone else mentioned as I'm using the AMD open source driver and it just doesn't play well with specific codecs on XFCE? Regardless thank you it fixed it for me.

Just to reiterate for when other's find this thread:

You need the proper settings for your setup.

To solve this you need to go to VLC settings and find the proper video output and codecs decoding options.

It may be VDPAU or XCB or others, there is an entire list of available options.

1 Like

Forum kindly sponsored by