VMWare - Can't change screen resolution

I installed 18.0.4 in VMWare 15, installed all updates, etc. Yesterday I was able to just manually drag the window to the size I wanted. Today when booting up, it will only stay at 800 X 600. I can't drag to to a different size or manually change the resolution any longer.

I had this problem once yesterday and just rebooted the VM. Today that isn't working.

That is pretty strange. Manjaro support for vmare generally, "Just works".

Can we see inxi -Fxxxz and systemctl status vmtoolsd.service from inside the VM

System:
  Host: MJ18KDE Kernel: 4.19.45-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.3.0 Desktop: KDE Plasma 5.15.5 tk: Qt 5.12.3 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Vmware System: VMware product: VMware Virtual Platform v: N/A 
  serial: <filter> Chassis: No Enclosure type: 1 serial: <filter> 
  Mobo: Intel model: 440BX Desktop Reference Platform serial: <filter> 
  BIOS: Phoenix v: 6.00 date: 04/13/2018 
CPU:
  Topology: 2x Single Core model: Intel Core i7-7700HQ bits: 64 type: SMP 
  arch: Kaby Lake rev: 9 L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 
  bogomips: 11236 
  Speed: 2808 MHz min/max: N/A Core speeds (MHz): 1: 2808 2: 2808 
Graphics:
  Device-1: VMware SVGA II Adapter driver: vmwgfx v: 2.15.0.0 
  bus ID: 00:0f.0 chip ID: 15ad:0405 
  Display: x11 server: X.Org 1.20.4 driver: vmware compositor: kwin_x11 
  resolution: 800x600~60Hz 
  OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits) v: 3.3 Mesa 19.0.4 
  compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: Ensoniq ES1371/ES1373 / Creative Labs CT2518 
  driver: snd_ens1371 v: kernel bus ID: 02:02.0 chip ID: 1274:1371 
  Sound Server: ALSA v: k4.19.45-1-MANJARO 
Network:
  Device-1: Intel 82371AB/EB/MB PIIX4 ACPI vendor: VMware Virtual Machine 
  type: network bridge driver: N/A port: 1060 bus ID: 00:07.3 
  chip ID: 8086:7113 
  Device-2: Intel 82545EM Gigabit Ethernet 
  vendor: VMware PRO/1000 MT Single Port driver: e1000 v: 7.3.21-k8-NAPI 
  port: 2000 bus ID: 02:01.0 chip ID: 8086:100f 
  IF: ens33 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 75.00 GiB used: 7.77 GiB (10.4%) 
  ID-1: /dev/sda vendor: VMware model: Virtual S size: 75.00 GiB 
  serial: N/A rev: 1.0 scheme: MBR 
Partition:
  ID-1: / size: 73.32 GiB used: 7.77 GiB (10.6%) fs: ext4 dev: /dev/sda1 
Sensors:
  Message: No sensors data was found. Is sensors configured? 
Info:
  Processes: 171 Uptime: 32m Memory: 3.83 GiB used: 537.9 MiB (13.7%) 
  Init: systemd v: 242 Compilers: gcc: 8.3.0 Shell: bash v: 5.0.7 
  running in: konsole inxi: 3.0.34

[rick@MJ18KDE ~]$ systemctl status vmtoolsd.service 
● vmtoolsd.service - Open Virtual Machine Tools (VMware Tools)
   Loaded: loaded (/usr/lib/systemd/system/vmtoolsd.service; enabled; vendor>
   Active: active (running) since Mon 2019-05-27 08:10:34 PDT; 33min ago
 Main PID: 306 (vmtoolsd)
    Tasks: 2 (limit: 4684)
   Memory: 10.1M
   CGroup: /system.slice/vmtoolsd.service
           └─306 /usr/bin/vmtoolsd

May 27 08:10:34 MJ18KDE systemd[1]: Started Open Virtual Machine Tools (VMwa>
lines 1-10/10 (END)

Can you please edit those outputs to be preformatting text by highlighting the text and selecting the </> button? This will make them much easier to read.

In the meantime, I will try to compare your outputs to mine.

1 Like

added

Check these autofit settings in the vmware View menu

image

I'm running vmware in Windows 10, so don't have a view menu that I can see. This is file -> preferences.

VM-Display

I've tried full screen mode, but that still won't let me change it from 800 X 600.

1 Like

I used to run in Windows 10, there was definitely a view menu somewhere.

Below is a screenshot that shows the view menu on Windows. If your VM is full-screen it is probably tucked away in the bar at the top.

image

Here's what my window looks like. I tried under the 'player' menu, but nothing about displays.

VM

That is vmware player. I am less familiar with that.

Off the top of my head there are a few things that play into this:

  • The open-vm-tools have to be installed and running - They are installed by default and appear to be running from the above output you provided
  • You need to be using video-vmware - Your inxi shows that this is the case
  • In vmware you need to be auto-fitting guests - Not clear how to check that in vmware player
  • The display settings for the vm to be set. It is interesting that Accelerate 3D graphics is greyed out but that should be needed in vmware. At least it isn't in workstation pro.

Accelerate 3D is grayed out because the VM is running. I shut it down and tried enabling it, no change.

I tried the other option in there to 'specify monitor settings' and changed that to 1280 X 1024. I can now make the VM window wider, but it won't let me resize horizontally.

One other setting that might matter:

There's a setting for the type of Linux. I have 'Other Linux 4.x or later kernel 64-bit'. There's no option for Manjaro or Arch.

I believe that is used when you create the VM to set defaults, I don't think it matters much on a running VM.

Have you tried making sure the guest is fully up-to-date and rebooting? It is strange that it did work and then stopped.

I found instructions to convert a Vmware image to Virtualbox. I'm running that right now, will try it in Virtualbox.

Yes, I ran all the updates before I started using the VM.

I did try updating the video drivers on the host (new NVidia drivers out today) and rebooted. No help.

Make sure you use the VGA Adaptor(not svga) and enable 3D acceleration.

Once you get into the system you may need to use mhwd to install the proper drivers.

After that follow these instructions:
https://wiki.manjaro.org/index.php?title=VirtualBox#Running_Manjaro_under_VirtualBox

1 Like

Already set to VboxVGA. I turned on 3D acceleration, now it will boot to a menu where I can select Manjaro 18 (or something similar), but then boots to a black screen. I'll look at that page you referenced later. Assuming I'll need to boot to command line and install the driver.

1 Like

So the install in VMware definitely seemed to be glitchy. Sometimes I could re-size the window, but most of the time I couldn't.

I ended up doing a clean install using Virtualbox and choose the accelerate 3D and VboxVGA. It's been working flawlessly.

Virtualbox seems to have more, useful settings. Makes VMware Workstation seem like a stripped down version.

1 Like

That is because VMWare Workstation Player is a stripped down version. :smile:

1 Like

Forum kindly sponsored by