Wakeup networking issue

the problem:
-upon wakeup the network interface says "cable disconnected" (it is not)
and there is no more network communication.
-Physically the Gigabit switch, has a yellow light indicating a 100Mbps link (which is expected) and the powerlines are fine as well (all green lights)
-rebooting fixes the problem until next sleep

So I'm pretty sure it's a software issue.

Me: I can take terminal commands, but I'm a manjaro newbie, (not a complete computer newbie). I already fixed some manjaro pacman issues with the help of the wiki for example.

I don't really know where to start that troubleshooting
I tried searching but none of what I found seemed similar enough (but maybe I searched badly) or involved deep modifications I wasn't really comfortable with.

Thanks for any help

  Host: ManjaroLaptop Kernel: 5.4.22-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.1 Desktop: Xfce 4.14.2 Distro: Manjaro Linux 
  Type: Portable System: Dell product: Inspiron 1750 v: N/A serial: <filter> 
  Mobo: Dell model: 0655KV serial: <filter> BIOS: Dell v: A03 
  date: 08/27/2009 
  ID-1: BAT0 charge: 39.4 Wh condition: 39.4/48.6 Wh (81%) 
  model: Sanyo DELL G558N9 status: Full 
  Topology: Dual Core model: Pentium T4300 bits: 64 type: MCP arch: Penryn 
  rev: A L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 8383 
  Speed: 1197 MHz min/max: 1200/2100 MHz Core speeds (MHz): 1: 1197 2: 1197 
  Device-1: AMD RV710/M92 [Mobility Radeon HD 4330/4350/4550] vendor: Dell 
  driver: radeon v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.7 driver: ati,radeon unloaded: modesetting 
  resolution: 1600x900~60Hz 
  OpenGL: renderer: AMD RV710 (DRM 2.50.0 / 5.4.22-1-MANJARO LLVM 9.0.1) 
  v: 3.3 Mesa 19.3.4 direct render: Yes 
  Device-1: Intel 82801I HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.4.22-1-MANJARO 
  Device-1: Marvell 88E8040 PCI-E Fast Ethernet vendor: Dell driver: sky2 
  v: 1.30 port: ce00 bus ID: 09:00.0 
  IF: enp9s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM4312 802.11b/g LP-PHY 
  vendor: Dell Wireless 1397 WLAN Mini-Card driver: wl v: kernel port: ce00 
  bus ID: 0c:00.0 
  IF: wlp12s0 state: down mac: <filter> 
  Local Storage: total: 4.09 TiB used: 21.85 GiB (0.5%) 
  ID-1: /dev/sda vendor: Western Digital model: WD5000BEVT-60ZAT1 
  size: 465.76 GiB 
  ID-2: /dev/sdc type: USB vendor: Seagate model: BUP Portable 
  size: 3.64 TiB 
  ID-1: / size: 201.26 GiB used: 21.85 GiB (10.9%) fs: ext4 dev: /dev/sda4 
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: radeon temp: 53 C 
  Fan Speeds (RPM): cpu: 2800 
  Processes: 176 Uptime: 18m Memory: 3.84 GiB used: 1.81 GiB (47.1%) 
  Init: systemd Compilers: gcc: 9.2.1 Shell: bash v: 5.0.16 inxi: 3.0.37 

:+1: Welcome to Manjaro! :+1:

Concerning this:

  1. could you elaborate on the bold text below?

  2. Are you a Windows power user or a Linux user? (I.E. have you tried restarting the NetworkManager instead of rebooting? If not: try that and what does that do?) because of this:

    (No offence intended, just trying to find out how detailed I need to be in my responses)

:wink: :+1: :innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...

First no offence taken, I understand perfectly
so yeah kind of a windows poweruser
heck I have worked as a windows helpdesk for a while so I know the drill...

  1. On my network I have a router which is connected to internet, from this router a powerline is connected which converts the network signal to make it transit through regular house power cables, then another powerline, then a switch, then this laptop.
    In any case, I'm not sure why I started talking about that since it doesn't really matter.
    if a powerline is down, it wouldn't show "cable disconnected", but instead "cable connected but no internet connection" or something akin to that. (because of the switch in between the two)

  2. I tried systemctl restart NetworkManager.service which AFAIK should do what you asked. no changes.
    I'm not sure if there should be log files, but at least the command terminal shows nothing.
    it still says the network cable is disconnected (which again is not)

1 Like
  1. Thanks. Some people are more susceptible to perceived insults than others. :innocent: :stuck_out_tongue_winking_eye: :crazy_face:
  2. That's exactly what I wanted to know: Thank you and that explains 100Mb, because 1Gb over power-line adapters is unfeasible.
  3. Drat! Not what I expected. :angry:
  4. I don't know if XFCE has an "airplane mode" (I'm on KDE) but what happens if you turn that on and off?

Why all these stupid questions?

Well, if we find a way of turning the network connection back on again without rebooting, we can script it and put it in the wake-up script and then your problems are gone...

:zzz: :bed: :zzz:

100Mb is actually the max link speed of this network adapter of this crap laptop I currently use (due to a motherboard failure on main system but that's another story)

It's just the link speed to the switch, it could be 1Gb even if powerlines couldn't handle that amount of data throughput afterward. (there's another 2 computers on this switch)
And to be complete on this matter, my powerlines actually do have a Gb link to whatever they are connected to as well. (D-Link DHP-P600AV)
the actual speed on the powerlines depends on the quality of the connection between all the powerlines though.And it doesn't max out the 1Gb link for sure

Anyways, I can't find any airplane modes,
I do have options to disable/enable network
and option to disable/enable wifi network
none of these do anything.

Just an idea, maybe if there was a way to restart the network card driver ?

I found this thread which sounds interesting but is aimed at another network card, so the solutions outlined seem to not apply to me. Not to mention complicated...

In the script here, instead of enp2s0 use:

and instead of r8169, use:

(check your own inxi output to know why)

And don't worry about the blacklist note at the end: That doesn't apply to you (as you have different hardware and no conflict between different versions of the same adaptor)


cc @tbg Yet another issue (probably) solved by your genius!

:stuck_out_tongue_winking_eye: :crazy_face:

Soooo unfortunately .... it didn't work

I'll verify that I didn't make any mistakes while editing a bit later.
Pretty sure I didn't but you never know...

Thanks for the help anyway

doesn't help us help you... :stuck_out_tongue_winking_eye:

Please post your script, the relevant dmesg output, systemctl --list-unit-files, ...

and try this to see whether it provokes the same issue as going to sleep and coming back:

nmcli r all off; sleep 5; nmcli r all on

(also from the same thread)

so just a quick update
I haven't done all you asked because I ran into level of competence issues ....
still searching how to output terminal to file (and yeah I used to know that but I forgot, I'm ashamed of myself)
and honestly I am a bit busy these days...
however I tried this : No Ethernet Network Connection after Resume; very recent problem
and didn't even need to sleep/resume in between
So what it looks like so far :
0. Just waked up laptop, network connection is "unplugged"

  1. sudo systemctl stop NetworkManager.service
  2. sudo ip link set enp9s0 down
  3. sudo modprobe -r sky2
  4. Wait 5"
  5. sudo modprobe sky2
  6. sudo ip link set enp9s0 up
  7. sudo systemctl start NetworkManager.service
  8. Dance & whoop in joy as i see my network come back.
  9. I don't know why though, it created a new connection that had IPv4 disabled
    no matter I just enabled IPv4 and it worked fine
    after comparing characteristics of the two wired connections (same MAC address & stuff, only graphical interface name was different, the new one having the name of the device "enp9s0")
    I just deleted the original wired connection (e.g. not the newly created one)

Posting this, so I don't lose this text but I will come back and post more, I have a lot more diagnosis/testing to do yet

That's good! So add commands 1-7 above to the script here and then your computer will wake up with a network connection automatically!


so two problems so far :

  1. each time I do it manually it does create a brand new connection with IPv4 disabled
  2. the services fail to execute properly
● network-suspend.service - Stop network components prior to suspending
   Loaded: loaded (/etc/systemd/system/network-suspend.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2020-03-04 12:12:41 CET; 8min ago
  Process: 1863 ExecStart=/bin/systemctl stop NetworkManager.service; ip link set enp9s0 down; modprobe -r sky2 (c>
 Main PID: 1863 (code=exited, status=5)

mars 04 12:12:41 ManjaroLaptop systemctl[1863]: Failed to stop ip.service: Unit ip.service not loaded.
mars 04 12:12:41 ManjaroLaptop systemctl[1863]: Failed to stop link.service: Unit link.service not loaded.
mars 04 12:12:41 ManjaroLaptop systemctl[1863]: Failed to stop set.service: Unit set.service not loaded.
mars 04 12:12:41 ManjaroLaptop systemctl[1863]: Failed to stop enp9s0.service: Unit enp9s0.service not loaded.
mars 04 12:12:41 ManjaroLaptop systemctl[1863]: Failed to stop down\x3b.service: Unit down\x3b.service not loaded.
mars 04 12:12:41 ManjaroLaptop systemctl[1863]: Failed to stop modprobe.service: Unit modprobe.service not loaded.
mars 04 12:12:41 ManjaroLaptop systemctl[1863]: Failed to stop sky2.service: Unit sky2.service not loaded.
mars 04 12:12:41 ManjaroLaptop systemd[1]: network-suspend.service: Main process exited, code=exited, status=5/NOT>
mars 04 12:12:41 ManjaroLaptop systemd[1]: network-suspend.service: Failed with result 'exit-code'.
mars 04 12:12:41 ManjaroLaptop systemd[1]: Failed to start Stop network components prior to suspending.
● network-resume.service
   Loaded: loaded (/etc/systemd/system/network-resume.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2020-03-04 12:13:00 CET; 7min ago
  Process: 1864 ExecStartPre=/bin/sleep 15s (code=exited, status=0/SUCCESS)
  Process: 2276 ExecStart=/bin/modprobe sky2; ip link set enp9s0 up; systemctl start NetworkManager>
 Main PID: 2276 (code=exited, status=1/FAILURE)

mars 04 12:12:41 ManjaroLaptop systemd[1]: Starting network-resume.service...
mars 04 12:13:00 ManjaroLaptop modprobe[2276]: modprobe: FATAL: Module sky2; not found in directory>
mars 04 12:13:00 ManjaroLaptop systemd[1]: network-resume.service: Main process exited, code=exited>
mars 04 12:13:00 ManjaroLaptop systemd[1]: network-resume.service: Failed with result 'exit-code'.
mars 04 12:13:00 ManjaroLaptop systemd[1]: Failed to start network-resume.service.

Weird... What are the contents of your NetworkManager.service? Something is :fish: there...

EDIT2: I was incorrect in here

and there were some updates that just came up ...

[2020-03-04T12:36:40+0100] [ALPM] upgraded wpa_supplicant (2:2.9-5 -> 2:2.9-7)
[2020-03-04T12:36:37+0100] [ALPM] upgraded wine (5.2-1 -> 5.3-1)
[2020-03-04T12:36:21+0100] [ALPM] upgraded python-importlib-metadata (1.4.0-1 -> 1.5.0-1)
[2020-03-04T12:36:20+0100] [ALPM] upgraded perl-http-message (6.18-3 -> 6.22-1)
[2020-03-04T12:36:20+0100] [ALPM] upgraded pciutils (3.6.2-2 -> 3.6.4-1)
[2020-03-04T12:36:20+0100] [ALPM] upgraded opera-ffmpeg-codecs (79.0.3945.130-2 -> 80.0.3987.100-1)
[2020-03-04T12:36:20+0100] [ALPM] upgraded manjaro-release (19.0.1-1 -> 19.0.2-1)
[2020-03-04T12:36:20+0100] [ALPM] upgraded manjaro-application-utility (1.2.2-2 -> 1.3.1-1)
[2020-03-04T12:36:20+0100] [ALPM] upgraded pacman-mirrors (4.16.2-3.1 -> 4.16.4-1)
[2020-03-04T12:36:20+0100] [ALPM] upgraded python-urllib3 (1.25.8-1 -> 1.25.8-2)
[2020-03-04T12:36:20+0100] [ALPM] upgraded man-db (2.9.0-1 -> 2.9.1-1)
[2020-03-04T12:36:09+0100] [ALPM] upgraded linux54-broadcom-wl ( ->
[2020-03-04T12:36:09+0100] [ALPM] upgraded linux54 (5.4.22-1 -> 5.4.23-1)
[2020-03-04T12:36:05+0100] [ALPM] upgraded libqmi (1.24.4-1 -> 1.24.6-1)
[2020-03-04T12:36:05+0100] [ALPM] upgraded libnotify (0.7.8-1 -> 0.7.9-1)
[2020-03-04T12:36:05+0100] [ALPM] upgraded libgphoto2 (2.5.23-1 -> 2.5.24-1)
[2020-03-04T12:36:05+0100] [ALPM] upgraded lib32-libglvnd (1.3.0-2 -> 1.3.1-1)
[2020-03-04T12:36:05+0100] [ALPM] upgraded lib32-libcap (2.29-1 -> 2.32-1)
[2020-03-04T12:36:05+0100] [ALPM] upgraded lib32-freetype2 (2.10.1-1 -> 2.10.1-2)
[2020-03-04T12:36:05+0100] [ALPM] upgraded engrampa (1.24.0-0.1 -> 1.24.0-1)
[2020-03-04T12:36:05+0100] [ALPM] upgraded libsoup (2.68.3-1 -> 2.68.4-1)
[2020-03-04T12:36:05+0100] [ALPM] upgraded libglvnd (1.3.0-2 -> 1.3.1-1)
[2020-03-04T12:36:04+0100] [ALPM] upgraded wayland-protocols (1.18-1 -> 1.20-1)
[2020-03-04T12:36:04+0100] [ALPM] upgraded cups-filters (1.27.1-1 -> 1.27.2-1)
[2020-03-04T12:36:04+0100] [ALPM] upgraded util-linux (2.35.1-1 -> 2.35.1-1.1)
[2020-03-04T12:36:03+0100] [ALPM] upgraded libseccomp (2.4.1-3 -> 2.4.2-1)
[2020-03-04T12:36:03+0100] [ALPM] upgraded imagemagick ( ->
[2020-03-04T12:36:03+0100] [ALPM] upgraded freetype2 (2.10.1-1 -> 2.10.1-2)
[2020-03-04T12:36:03+0100] [ALPM] upgraded at-spi2-atk (2.34.1-1 -> 2.34.2-1)
[2020-03-04T12:36:02+0100] [ALPM] upgraded icu (65.1-2 -> 65.1-3)
[2020-03-04T12:36:02+0100] [ALPM] upgraded libxcb (1.13.1-1 -> 1.14-1)
[2020-03-04T12:36:01+0100] [ALPM] upgraded xcb-proto (1.13-4 -> 1.14-1)
[2020-03-04T12:36:01+0100] [ALPM] upgraded libcap (2.31-1 -> 2.32-1)
[2020-03-04T12:36:01+0100] [ALPM] upgraded iana-etc (20200117-1 -> 20200224-1)
[2020-03-04T12:36:01+0100] [ALPM] upgraded libutil-linux (2.35.1-1 -> 2.35.1-1.1)
[2020-03-04T12:36:01+0100] [ALPM] upgraded alsa-topology-conf (1.2.2-1 -> 1.2.2-2)
[2020-03-04T12:34:00+0100] [ALPM] removed caffeine-ng (3.4.2-2.3)

and it seems to have solved my initial issue,
I'll reboot again (already did) and retry sleep again

I believe it may be the kernel upgrade : [2020-03-04T12:36:09+0100] [ALPM] upgraded linux54 (5.4.22-1 -> 5.4.23-1)

EDIT: I did these: sudo systemctl disable network-resume.service and sudo systemctl disable network-suspend.service

I'm at a loss here: Did the upgrades solve your issue? or are you still having the issue? Or something else entirely?

alright so I was sightly wrong

  1. the update came up
  2. reboot
  3. problem fixed (sleep, resume, network connection working)
  4. disable the two services (that we created) and reboot
  5. problem is back
  6. re-enable the two services and reboot
  7. problem fixed (sleep, resume, network connection working)

so the update (or one of the updates) seems to have fixed the errors I was getting with the services execution ? honestly I am a bit at a loss as well
additionally I'm not getting any new network connections creations so far.

Good, so your original problem is fixed by the scripts. I'll mark that as a solution. Please open a new question for the new issue because this conversation is getting too long and everyone is going to be confused. :upside_down_face: :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by