War Thunder is freezing in fullscreen mode

As title says, whe I run War Thunder in full screen mode 1920x1080, whole system is freezing. I can jump to tty and reboot it only. When I run the game in windowed mode, no matter the resolution, it runs ok. I've read on official Gajin forum that I should switch to fullscreen after game is on but it doesn't work. Game still crashes. It happens only on Arch based distros. Other work fine.

➜  ~ inxi -SxGx
System:    Host: zenbook Kernel: 5.0.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: Gnome 3.32.0 wm: gnome-shell dm: GDM Distro: Manjaro Linux 
Graphics:  Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:5916 
           Display: x11 server: X.Org 1.20.4 driver: i915 compositor: gnome-shell 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 19.0.1 
           compat-v: 3.0 direct render: Yes 

Edit: I've found this but it doesn't say anything new...

Can you provide some logs ?

Of course. Let me know which one would you like

OK - let´s begin with dmesg (time index, when the computer freezes).

Ok, I found workaround on Gaijin forum:
Put this in launch options:
env LD_PRELOAD="" %command%
It disables Steam overlay but game works as should

2 Likes

Hi. In what Launch Options do I type this in? In the War Thunder Loader?

Steam launch options

Forum kindly sponsored by