WARNING: after latest update [23/01/2019] my computer won't start anymore!

  1. I got the new ISO; 2 openend the termina; 3 typed sudo pacman -Syyuu 4 computer started a procedure; 5 started computer again; 6 the same faillure. What's wrong?

I'm not able to use my computer at the moment. Only boot from the USB. What's wrong?

You didn't do tha chroot part. You just upgraded the Live-USB environment

1 Like

Yes indeed! This is the missing part. Followed other instruction (EXIT). And computer works again. THANKS! Super :slight_smile:

3 Likes

mad

2 Likes

Now that everything works again, may be time for some tips:

  • 1 - ALWAYS read announcements for the update. This will save you some headache. It is price to pay, to have the latest shiniest/rolling distro. You will have to be a little bit active with Manjaro. If you want less involvement, (but not the latest software) check out also MX Linux.

  • 2 - DONT RUSH with the updates. Wait a day, let other first test the update for you, wait until some 100 users vote for the update. Check the update pool, (it is in first update post) and look at percentage of problems / no problems. If there are more problems than usually, wait longer with updating your system. And read what other users experienced and what was solution. Learn from other members problems, let others troubleshoot for you. I still didn't update. I'm first reading what happened. In this case, you troubleshoot this update for me, which I'm grateful for and thank you for :wink: In future you may want to be in my shoes, instead of leading the update research :slight_smile: Oh and more there are problems, more is in your interest that you make some kind of a backup before the update. Just to be on a safe side. A month or so ago, I could not recover my system and I had to restore it from backup I created with clonezilla.

  • 3 - In one of the earlier posts @papajoke posted the link to my guide, how to try to access the system when you can't boot properly into it. You now know how to access it from live USB, congratulations! Sometimes you may have a problem with graphical interface (GUI) but your system will otherwise boot OK. In that case you don't need to access to your system through live media, all you would need is simple switch top TTY. My suggestion is, that you are now getting ready for future potential problems that my happen. Check that link I mentioned and try step one few times and also step two. That way you will be ready for potential problem in the future. (step 3 you already mastered today) You really want to be familiar with first 3 steps.

Ah, and stop being angry, life is too short for this :rofl: :stuck_out_tongue_winking_eye:

6 Likes

@stephane Already told you.

  1. Prepare a bootable USB stick

  2. Boot from the USB stick

  3. Connect to the internet

  4. Launch a terminal

  5. Type into the terminal manjaro-chroot -a

  6. Type into terminal Sudo pacman -Syyuu

  7. Type into terminal exit

  8. Reboot system, and you should have your install back!

6 posts were split to a new topic: Update: cannot retrieve file

Also check that your /etc/resolv.conf is okay. It sounds you are not connected to the Internet

I think I am, but what should I check exactly ?

Try:

sudo pacman-mirrors -f 10 
sudo pacman -Syy
sudo pacman -Syyuu

ah indeed, I get ::INFO Internet connection appears to be down But still I can browse on the internet, and use ssh from the terminal.. Should I do something with this resolv.conf ?

cat /etc/resolv.conf

did we forget to connect to wifi? :crazy_face:

edit: my bad, didnt see that post when i replied

Hi guys/gals,

Same issue as most in this thread it seems.
I tried the solution that involves booting into Manjaro live.

After typing
manjaro-chroot -a

I get: ERROR: You can’t mount 0!

My Manjaro partition is encrypted using LUKS which I decrypted by double clicking on the Device in question.

How do I go about this situation?

Thank you

I managed to get it going!
I first had to mount my main encrypted partition to /mnt
Then manjaro-chroot /mnt which got me into my encrypted partition, followed by the pacman update

Cheers,

Same problem. I installed afresh :smirk:

why? its a simple fix.

I had a same problem and resolved it by the solution as you, but from boot menu of GRUB I cannot find Windows which I dual-booted. Do you have any idea to revive my windows ? (I'm not good at English, so please inform me if I don't make any sense...)

Try running the command sudo update-grub in the terminal on your manjaro installation ,

2 Likes

Thank you very much. It solved the problem.

Forum kindly sponsored by