Watchdog0 and fwupd fail to stop at reboot

After the latest stable upgrade (never happened before), every time at reboot I got those two error messages for a split of a second, which I then recalled with journalctl

  • watchdog0 did not stop
  • fwupd failed to stop, exit status 2

Journalctl is not much more help
Anybody else?

watchdog you can deal with it how you want.
I generally kill it a few ways .. though not as tenaciously as I do bluetooth :wink:

fwupd is firmware update .. I am not sure why it is complaining. But see here for more info:

I believe fwupd runs as a service. I forget it's name, probably fwupd.service. I don't currently have it installed.

It would seem to me that fwupd does not need to be run continuously and could be run on a systemd timer instead (perhaps weekly or monthly). You could also simply disable the service and run it periodically to check for updates.

ok, I'm trying to do some proper debug.
That's the real journalctl output:

kernel: watchdog: watchdog0: watchdog did not stop!
systemd[1]: Set hardware watchdog to 10min.
systemd[1]: Hardware watchdog 'iTCO_wdt', version 0

It might not be the service. There is an fwupd shutdown script which is executed by systemd on every shutdown.

7# cat /usr/lib/systemd/system-shutdown/fwupd.shutdown

# no history database exists
[ -f /var/lib/fwupd/pending.db ] || exit 0

# activate firmware when we have a read-only filesysten
/usr/lib/fwupd/fwupdtool activate

I had an issue with that script because /usr/lib/fwupd/fwupdtool does not exist and the script is throwing an error. I created a symlink to fix it:

/usr/lib/fwupd/fwupdtool -> /usr/bin/fwupdtool


the log is about fwupd.shutdown

thank you mbod, I fixed the issue related to fwupd.shutdown by issuing:

sudo ln -s /usr/bin/fwupdtool /usr/lib/fwupd/fwupdtool

watchdog0 error however persists.


Have you tried to permanently disable the watchdog?

I would prefer the grub method.


done. Worked out. Thank you

Should this bug report be upstreamed? I am also getting this error.

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by