Weak, Low volume, Tinny sound under Manjaro compared to Windows

  1. Under Manjaro 18.1.5 the sound has been "tinny" compared to the Windows experience and I have to crank up the volume much louder to get a good sound experience.

  2. I have a laptop with built-in Front Left & Right speakers and a subwoofer speaker on the bottom.

  3. In another post, I've seen that the aplay --list-pcmscommand lists the possible Pulse Code Modulation devices:

    null
        Discard all samples (playback) or generate zero samples (capture)
    jack
        JACK Audio Connection Kit
    default
        Default ALSA Output (currently PulseAudio Sound Server)
    sysdefault:CARD=PCH
        HDA Intel PCH, ALC255 Analog
        Default Audio Device
    front:CARD=PCH,DEV=0
        HDA Intel PCH, ALC255 Analog
        Front speakers
    surround21:CARD=PCH,DEV=0
        HDA Intel PCH, ALC255 Analog
        2.1 Surround output to Front and Subwoofer speakers
    ...

    (some irrelevant HDMI stuff deleted)

  4. using speaker-test it looks like I'm only using the front speakers:

    speaker-test --device=front --channels=2 --nloops=1 --test=sine
    

The question is: How do I change the default from the first bold item to the second bold item? (Front Left&Right speakers to 2.1 surround)?


Some more info:

  1. The 5.1 surround system that I deleted from the above output seems to be linked to the nVidia HDMI ports, not to the internal speakers...

  2. The inxi --audio output is:

    Audio:
      Device-1: Intel CM238 HD Audio driver: snd_hda_intel 
      Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel 
      Sound Server: ALSA v: k5.4.17-1-MANJARO 
    
  3. I Can't find anything in Audio settings in the GUI:
    Audio Devices
    Audio Advanced

  4. the HDMI surround can be seen in the alsamixer devices, but the surround2.1 cannot:

    ┌────────────────────────────── AlsaMixer v1.2.1 ──────────────────────────────┐
    │ Card: HDA Intel PCH                                  F1:  Help               │
    │ Chip: Realtek ALC255                                 F2:  System information │
    │ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
    │ Item: Master [dB gain: -18.00]                       Esc: Exit               │
    │                                                                              │
    │     ┌──┐     ┌──┐  ┌─────── /proc/asound/devices ───────┐          ┌──┐      │
    │     │  │     │  │  │  2: [ 0- 0]: digital audio playback│          │  │      │
    │     │  │     │  │  │  3: [ 0- 0]: digital audio capture │          │  │      │
    │     │  │     │  │  │  4: [ 0- 0]: hardware dependent    │          │  │      →
    │     │  │     │  │  │  5: [ 0]   : control               │          │  │      →
    │     │  │     │  │  │  6: [ 1- 3]: digital audio playback│          │  │      →
    │     │  │     │  │  │  7: [ 1- 7]: digital audio playback│          │  │      →
    │     │▒▒│     │  │  │  8: [ 1- 8]: digital audio playback│          │  │      →
    │     │▒▒│     │  │  │  9: [ 1- 0]: hardware dependent    │          │  │      →
    │     │▒▒│     │  │  │ 10: [ 1]   : control               │          │  │      →
    │     │▒▒│     │  │  │ 33:        : timer                 │          │  │      │
    │     │▒▒│     │  │  └────────────────────────────────────┘          │  │      │
    │     ├──┤     ├──┤     ├──┤     └──┘     ├──┤     └──┘   Enabled    └──┘      │
    │     │OO│     │MM│     │OO│              │MM│                                 │
    │     └──┘     └──┘     └──┘              └──┘                                 │
    │      46      0<>0   100<>100 100<>100   2<>2     0<>0              0<>0      │
    │  < Master >Headphon Speaker    PCM      Mic    Mic Boos Auto-Mut Internal    │
    └──────────────────────────────────────────────────────────────────────────────┘
    

Have you been through these yet?
https://wiki.archlinux.org/index.php/PulseAudio
https://wiki.archlinux.org/index.php/PulseAudio/Examples

1 Like

this will get all 5 speakers working

but might need to make some changes to Pulseaudio configuration to get 4.1 surround sound
working and better sound quality

if so, post data from pulseaudio --dump-conf

1 Like

running into some dependency hell performing a pamac install alsa-tools

could not satisfy dependencies:
installing nvidia-440xx-utils (440.59-1) breaks dependency 'nvidia-440xx-utils=440.44' required by linux53-nvidia-440xx

Will get back to you later today, after I've fixed that...

be careful - just seen a stable update announcement

1 Like

Yeah, already reported with a workaround...

:innocent:

OK, back to pamac install alsa-tools now...

So after the excellent advice by @nikgnomic I ended up doing the following:

  • Ensure you're logged in as an admin user
  • Install the alsa-tools package which contains the hdajackretask program:
    pamac install alsa-tools
    
  • Launch sudo hdajackretask from the command line
  • Choose the correct "codec" in the upper part of the window.
    (in my case Realtec ALC255, not Nvidia GPU 32 HDMI/DP as that is the audio output for the HDMI port, not the internal speakers)
  • Tick Show unconnected pins in the upper right corner
  • Tick one of the unconnected pin IDs
  • Take all the speaker not currently connected and connect them one by one to unused pins.
    (in my case Internal speaker (LFE) and internal speaker (Back) )¹
  • So that your screen looks something like this:
    Screenshot_20200207_002324
  • Then click the Apply button to test².
  • Play some classical music: something with cannons to really test the bass. :grin:
  • Click the Install boot override button to make changes permanent

Note 1: On my hardware, the Internal speaker (Back) and Internal speaker (LFE) are the same piece of hardware, but the LFE (Low Frequency effects) channel delivers bass-only information(<120 Hz), so its purpose is to supplement the overall bass content of the program. (Better cannons! :grin: )

Note 2: If you get an error that the resource is busy, go straight to the Install boot override step and reboot to be able to test.

Extra tip: If you would have two microphones on your system or any other audio device in the hdajackretask screen you don't use, hdajackretask even allows you to override one of the microphones as an extra line-out for some extra pair of (external) speakers for extra "Oumph" while listening to classical music playing games!

Suck on that Windows! Try making Windows do that!

:innocent: :grin:

1 Like

you should post amixer -c1 to show the 'viewers at home' the new level controls for rear speakers and sub-woofer

is the sub-woofer working ok ?
if not, may need some changes to pulseaudio configuration

Yeah, sound sounds full now. output of amixer --card=0 is:

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 56 [64%] [-23.25dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [off]
  Front Right: Playback [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 61 [97%] [28.50dB] [on]
  Front Right: Capture 61 [97%] [28.50dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'

my mistake, should be amixer -c 0 inxi can't count from zero

1 Like

In case you missed it, I edited the answer above your last question to include amixer --card=0 instead of 1...

:innocent: :wink:

1 Like

I don't know if you resolved the volume issue also, but I had the same problem on Linux getting volume very low even at 100% level. I resolved installing pulseeffects and creating a preset that should be similar to loudness equalization on Windows.

Pick it from here if you're interested.

1 Like

is low volume an issue for Acer Predator laptops after the channels are added?

i would usually look at alsa-info.sh data for codec pin configurations before going to hdajackretask
but for this hardware, pin configurations had already been posted elsewhere

if you or OP want to start a new topic and post alsa-info.sh there might be another pin connection or something accessible via 'advanced override' settings that may help with audio level

I DM'ed @digitalone that it was not: solution stands though PulseEffects is a dream come true for any audiophile (which I'm not)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by