Welcome to GRUB! - black screen

Trying to install Manjaro XFCE 17.1.11 from USB to a Teclast X80 Plus.
It's a tablet with Intel Atom x5-Z8350, 2GB RAM and 32GB ROM.
The USB is made with Rufus (DD mode) or Etcher.
The "Welcome to GRUB!" appears and then I get a black screen and nothing else.
I already tried the blind method (down, down, enter) but it doesn't work.
I would really like to install Manjaro on this thing :smiley:
Thanks in advance for the support

Start from here

I have Windows 10 installed at the moment and it works fine.
I get “Welcome to GRUB!” when I try to boot from the USB with Manjaro.
I tried pressing c at the black screen but nothing happens.

then this might help because it has also windows ...

Oh, wait, it took like 15 minutes to get to the boot menu.
Now I've set the divers to nonfree and I think that I have to wait for another 15 minutes.

Installed Manjaro succesfully.
It's only very slow when installing in the boot menus.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by