What is the appropriate way to update Nvidia driver while using Optimus Manager?

I have a laptop with hybrid graphics and i use Optimus Manager (installed using this guide) for that. Yesterday an update for Manjaro was released which extended driver support for 430xx and 435xx, i currently have 390xx. I have messed up the system with video drivers in previous installs so i want to know the best way to do this, any help is apreciated!

inxi -Fxz:

System:
  Host: lucas-pc Kernel: 4.19.69-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
  Desktop: KDE Plasma 5.16.4 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: Inspiron 5557 v: N/A serial: <filter> 
  Mobo: Dell model: 0WT51R v: A00 serial: <filter> UEFI: Dell v: 1.3.2 
  date: 12/08/2017 
Battery:
  ID-1: BAT0 charge: 33.7 Wh condition: 33.7/45.1 Wh (75%) model: SMP DELL 7P3X953 
  status: Full 
CPU:
  Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP arch: Skylake 
  rev: 3 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20744 
  Speed: 800 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 
  4: 801 
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: NVIDIA GM108M [GeForce 930M] vendor: Dell driver: nvidia v: 390.129 
  bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.5 driver: modesetting,nvidia 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: GeForce 930M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.129 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.19.69-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell 
  driver: ath10k_pci v: kernel port: e000 bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 
  v: kernel port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: down mac: <filter> 
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-8:5 
Drives:
  Local Storage: total: 931.51 GiB used: 192.86 GiB (20.7%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
Partition:
  ID-1: / size: 906.94 GiB used: 192.86 GiB (21.3%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: 38.0 C sodimm: 42.0 C gpu: nvidia 
  temp: 47 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 178 Uptime: 11m Memory: 7.68 GiB used: 1.72 GiB (22.4%) Init: systemd 
  Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 inxi: 3.0.36

Hardware settings screenshot:

Screenshot_20190906_101746

nvidia recommends a 430 version driver for your card. Screenshot_20190906_125218

If you are happy with bumblebee and how it works, you should be able to right click on the 390 driver, uninstall. After that completes, right click on the bumblebee 430 driver, choose install. Wait for it to complete, then reboot.

If something goes wrong, you can always revert to the 390 driver from tty2 using the mhwd CLI.

NOTE: And of course, you can always just stay where you are at if it's working fine for your needs.

2 Likes

That's the thing, i want to still be using Optimus Manager after the update, I've had problems with Bumblebee.

Yeah, that's a new problem. Previously people usually had installed invidia driver which was always the newest one so that was no brainer changing the GPU setup. Now with all the changes this is puzzling.

I haven't tried it myself (I use optimus-manager but my driver was changed to 430 series so I don't need to change it) but I see two solutions:

  • use mhwd to switch to bumblebee-nvidia-430 one
    It is possible, that this install will create a new mwhd configs and if bumblebee was uninstalled, it may install it again. In such case, disable mhwd or any additional video drivers, plus disable bumblebee daemon (if it started running). So basically the same what you did during optimus-manager setup. The same optimus-manager configs should work for all driver series.

  • the other way is to manually install nvidia-430xx-utils and lib-nvidia-430xx-utils. It will add automatically dependent packages like kernel modules for it (it it won't happen, add them manually, they need to be installed, otherwise system won't boot to graphical session). Then check if there was no a new nvidia config to disable, so again, a partially what you did during the optimus-manager setup.

Of course, create a system backup with timeshift before doing anything in case something went wrong.

1 Like

I figured it out:
I removed the 390xx driver and then installed the 430xx with mhwd. After that i disabled the bumblebee daemon and re-rename a config file at /etc/X11/xorg.conf.d/, as in the cited guide. Last, i rebooted and everything seems to be working fine.
Anyway, thanks for the help people!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by