What os the status of HDCP support?

I know that this has been asked on this forum before but all the questions I found are old. What are the latest updates on this issue? I'm currently unable to play HD content in Amazon Prime Video or Netflix my computer despite having compatible hardware (works if I dual boot Windows). I read in the old threads that kernel updates might fix it. Is it fixed yet? Am I missing something?

inxi -Fxxcz

  Host: sintan-pc Kernel: 5.3.6-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: KDE Plasma 5.16.5 tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Pavilion Laptop 14-bf1xx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: HP model: 83CE v: 59.38 serial: <filter> UEFI: Insyde v: F.31 
  date: 10/30/2017 
  ID-1: BAT1 charge: 20.2 Wh condition: 24.8/42.1 Wh (59%) volts: 13.2/11.6 
  model: Hewlett-Packard PABAS0241231 serial: <filter> status: Charging 
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 32012 
  Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Hewlett-Packard 
  driver: nvidia v: 430.40 bus ID: 01:00.0 chip ID: 10de:134d 
  Display: x11 server: X.Org 1.20.5 driver: intel compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 19.2.1 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.3.6-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8168 v: 8.047.04-NAPI port: 3000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3000 
  bus ID: 03:00.0 chip ID: 8086:095a 
  IF: wlo1 state: up mac: <filter> 
  Local Storage: total: 1.03 TiB used: 593.80 GiB (56.5%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-2: /dev/sdb vendor: SanDisk model: SD8SN8U-128G-1006 size: 119.24 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-1: / size: 48.72 GiB used: 25.00 GiB (51.3%) fs: ext4 dev: /dev/sdb5 
  ID-2: /home size: 59.67 GiB used: 19.28 GiB (32.3%) fs: ext4 
  dev: /dev/sdb2 
  ID-3: swap-1 size: 8.10 GiB used: 634.5 MiB (7.6%) fs: swap dev: /dev/sdb3 
  System Temperatures: cpu: 48.0 C mobo: 29.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 325 Uptime: 6d 56m Memory: 7.70 GiB used: 3.04 GiB (39.5%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: fish v: 3.0.2 
  running in: fish inxi: 3.0.36 

I am a little confused on the HDCP support - can't say I am familiar with the term.

If you are referring to playing HD content - it is entirely - at least to my knowledge - up to the provider.

Is a DRM that is used in the HDMI standard to prevent playback on unapproved devices.

To playback this content, you need to have the "Widevine" libraries installed. Widevine is used by both Amazon Prime and Netflix as a Digital Rights Management tool when it comes to playback. Without these libraries installed, you are limited to SD playback. Unfortunately, these are not installed by default in Linux. Here is a good tutorial on how to do this.

Ah - I see - then building and installing e.g. - if I remember correct - chromium-widevine - obviously for Chromium could do the trick?

Yes, that is what he talks about in the linked thread. The first post gives the complete steps needed.

None of the solutions provided in that thread work anymore. I have chromium-widevine installed but still only SD playback is supported.

I tried several solutions, and none of them worked. It seems that Netflix has disabled 1080p playback on Linux again. I even tried using the Kodi plugin for Netflix, and it would only return an error. So in answer to your initial question. At this time, 1080p playback of Netflix on Linux is not possible.

Well, that's a shame.

Well, the TV shows do play in HD if I run Chrome/Edge using wine. But the Movies still are in SD. Weird.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by