What to choose in manjaro architect (default bootloader)

During architect installation I have this information:

I'm note sure what to choose.
I tried once to go with YES but there was an error on the next window. Don't remember error message but it was something with some directory missing.
I checked and in /mnt/boot/efi/EFI there is a folder manjaro
I've been thinking that maybe I should create boot folder by myself but it's a guess.

Can you help me?

/var/log/m-a.log will contain the error message.

Click <yes>

I started the installation from the beginning so no log.
Second time I looked for folder /boot/efi/EFI
I found one in /mnt
In this folder there was manjaro folder with grubx64.efi
So I created folder boot (inside /mnt/boot/efi/EFI)
And than I chose
No error this time and I folder boot file bootx64 was created by the installer.
If I'm correct it's the grubx64 copy with different name.

No errors this time but I don't know If my steps were ok.

As I said .
With simple yes (without stress above) there is some kind of error.

I would like to know what happens.
If you can't help me without log I'll reinstall the system and try to recreate situation

Error message should be something like "Boost python error in 'bootloader'.

If still at installation these commands should fix it

sudo cp /mnt/boot/grub/x86_64-efi/core.efi /mnt/boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

2nd command is assuming sda1 is the $esp /boot/efi, otherwise change to correct partition.
If you have rebooted after installation and you cannot boot, there's no need to reinstall. Use this link to fix the bootloader.

ps: Any reason why you you need to use architect to install rather than the 'normal' manjaro iso releases? Just asking. I think that's only useful for some 'customized, minimal, base or special' requirements. Even so... it won't be better than the old 'net-install' iso's and I'd suggest only for very experienced linux users.

I tried m-a sometime ago and I liked it.
It was with simple ext4 installation.
No subvolumes, no bootloaders

And for calamares
uses discard and this is not recommended right now
creates @ and @home but no @cache
doesn't enable fsck by default

I check efi mount point after installing system with calamares
there are:

In boot there is bootx64
in manjaro there is grubx64

With lots of tries and errors I know (I think) what to do with architect

Okay, then I suppose you know what to do to boot it.
Take care.

You should be able to find the log on the installed system under /.m-a.log which is a hidden file on the partititon, to the side of the subvolumes @ and @home, @var.

Not it I was A little angry and formatted drive as soon as possible

I've tried one more time.
No errors during installation but after reboot system didn't start
Well it is booting into the GRUB
Gun grub version...
Minimal BASH-like line editing is supported...

Before that I tried calamares.
Installation was smooth but during the boot there was another error
Sparse file not allowed

Now you can access /.m-a.log

    :: manjaro-architect 0.9.29-1 ::

12/03/19 20:26:15 system: UEFI, init: systemd nw-client: nmtui 
12/03/19 20:26:16 set LANG=en_US.UTF-8
12/03/19 20:26:16 set font ter-116n 
12/03/19 20:26:16 loadkeys us 
12/03/19 20:26:22 refresh database 
12/03/19 20:26:58 --------- [lsblk] ------------
12/03/19 20:26:58 /dev/sda1 300M
12/03/19 20:26:58 /dev/sda2 465.5G
12/03/19 20:26:58 /dev/sdb1 931.5G
12/03/19 20:26:58 /dev/sdc1 1.6G
12/03/19 20:26:58 /dev/sdc2 4M
12/03/19 20:26:58 already mounted: sdc1
12/03/19 20:26:58 ignore crypted: 
12/03/19 20:26:58 in partitions delete item /dev/sdc1 no: 6 / 7
12/03/19 20:26:58 partitions: /dev/sda1 300M /dev/sda2 465.5G /dev/sdb1 931.5G /dev/sdc2 4M
12/03/19 20:27:03 mount /dev/sda2 as mkfs.btrfs -f. 
12/03/19 20:27:03 create mountpoint /mnt 
12/03/19 20:27:05 mount /dev/sda2 compress=lzo,noatime,space_cache,ssd,commit=120
12/03/19 20:27:14 already mounted: sda2
12/03/19 20:27:23 mkfs.vfat -F32 /dev/sda1 
12/03/19 20:27:27 create /mnt/boot/efi 
12/03/19 20:27:27 mount /dev/sda1 /mnt/boot/efi 
12/03/19 20:27:49 edit pacman-mirrors.conf
12/03/19 20:30:44 refresh pacman-keys
12/03/19 20:30:51 clone profiles repo Cloning into '/usr/share/manjaro-architect/profiles'...
12/03/19 20:30:55 selected: "yay + base-devel" linux419 linux53 linux54
12/03/19 20:30:55 modules: KERNEL-headers
12/03/19 20:30:57 selected: [Manjaro-xfce]
12/03/19 20:31:26 filter_packages 
12/03/19 20:31:27 selected 'minimal' profile
12/03/19 20:31:27 packages to install: accountsservice acpi acpid alsa-firmware alsa-utils amd-ucode android-tools android-udev aspell aspell-pl autoconf automake avahi b43-fwcutter base-devel bash bash-completion binutils bison blueman btrfs-progs bzip2 cantarell-fonts catfish coreutils cpupower crda cronie cryptsetup device-mapper dhclient dhcpcd diffutils dmidecode dmraid dnsmasq dosfstools e2fsprogs ecryptfs-utils efibootmgr engrampa exfat-utils exo-gtk3 f2fs-tools fakeroot ffmpeg ffmpegthumbnailer file file-roller filesystem findutils flatpak flex freetype2 garcon-gtk3 gawk gcc gcc-libs gcolor2 gconf gettext glibc gnome-icon-theme gnome-keyring gnome-themes-standard gparted grep gst-libav gst-plugins-bad gst-plugins-base gst-plugins-good gst-plugins-ugly gtk3-classic gtkhash-thunar gufw gvfs gvfs-afc gvfs-gphoto2 gvfs-mtp gvfs-nfs gvfs-smb gzip haveged htop hunspell hunspell-pl inetutils intel-ucode intel-ucode inxi iproute2 iptables iputils ipw2100-fw ipw2200-fw jfsutils less libdvdcss libgsf libopenraw libtool libva-intel-driver libva-mesa-driver libva-vdpau-driver licenses lightdm lightdm-gtk-greeter lightdm-gtk-greeter-settings light-locker linux419 linux53 linux54 linux-firmware logrotate lsb-release lvm2 m4 make man-db manjaro-application-utility manjaro-browser-settings manjaro-documentation-en manjaro-firmware manjaro-hello manjaro-hotfixes manjaro-pulse manjaro-release manjaro-settings-manager manjaro-settings-manager-notifier manjaro-system manjaro-xfce-gtk3-minimal-settings man-pages matcha-gtk-theme mdadm memtest86+ menulibre mesa-demos mhwd mhwd-db midori mkinitcpio-openswap mobile-broadband-provider-info modemmanager mousepad mtpfs mugshot nano networkmanager network-manager-applet networkmanager-openconnect networkmanager-openvpn networkmanager-pptp networkmanager-vpnc nfs-utils nss-mdns ntfs-3g ntp numlockx openresolv openssh orage os-prober p7zip pacman pamac-gtk parole patch pavucontrol pciutils perl perl-file-mimeinfo poppler-glib powertop procps-ng psmisc pulseaudio-bluetooth pulseaudio-ctl pulseaudio-zeroconf qpdfview reiserfsprogs rsync samba screenfetch sed shadow s-nail spectre-meltdown-checker sudo sylpheed sysfsutils systemd-fsck-silent systemd-sysvcompat tar terminus-font texinfo thunar-archive-plugin thunar-gtk3 thunar-media-tags-plugin thunar-volman tlp ttf-bitstream-vera tumbler udiskie udisks2 unace unrar usb_modeswitch usbutils util-linux vi viewnior wget which wpa_supplicant xcursor-simpleandsoft xcursor-vanilla-dmz-aa xdg-su xdg-user-dirs xdg-utils xf86-input-elographics xf86-input-evdev xf86-input-keyboard xf86-input-libinput xf86-input-mouse xf86-input-void xfce4-appfinder-gtk3 xfce4-battery-plugin xfce4-clipman-plugin xfce4-notifyd-gtk3 xfce4-panel-gtk3 xfce4-power-manager-gtk3 xfce4-pulseaudio-plugin xfce4-screenshooter xfce4-session-gtk3 xfce4-settings-gtk3 xfce4-taskmanager xfce4-terminal xfce4-whiskermenu-plugin-gtk3 xfce4-xkb-plugin xfconf-gtk3 xfdesktop-gtk3 xfsprogs xfwm4-gtk3 xorg-server xorg-twm xorg-xinit xorg-xkill yay zsh 
12/03/19 20:42:59 install basepkgs 
12/03/19 20:42:59 configure vconsole
12/03/19 20:42:59 root on btrfs volume. Amend mkinitcpio.
12/03/19 20:43:36 re-run mkinitcpio 
12/03/19 20:43:36 base installed succesfully.
12/03/19 20:43:36 copy overlay 
12/03/19 20:43:36 copy root config 
12/03/19 20:43:36 enable avahi-daemon bluetooth cronie ModemManager NetworkManager tlp tlp-sleep ufw  Created symlink /etc/systemd/system/dbus-org.freedesktop.Avahi.service -> /usr/lib/systemd/system/avahi-daemon.service.
12/03/19 20:43:36 disable pacman-init 
12/03/19 20:43:37 enable lightdm Created symlink /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/lightdm.service.
12/03/19 20:46:03 Auto-install proprietary drivers 
12/03/19 20:47:00 grub-install --target=x86_64-efi warning: efibootmgr-16-1 is up to date -- skipping
12/03/19 20:47:04 Install GRUB 
12/03/19 20:47:33 generate_fstab 
12/03/19 20:48:01 set_hostname 
12/03/19 20:48:10 set_locale 
12/03/19 20:48:16 set_xkbmap pl 
12/03/19 20:48:21 set_timezone Europe/Warsaw 
12/03/19 20:48:22 set_hw_clock 
12/03/19 20:48:27 set_root_password New password: Retype new password: passwd: password updated successfully
12/03/19 20:48:31 default shell: [/bin/bash]
12/03/19 20:48:37 add user to groups 
12/03/19 20:48:37 create user pwd New password: Retype new password: passwd: password updated successfully
12/03/19 20:50:17 exit installer.

I don't know what that means, need to research.
Meanwhile you can repair Grub this way from live USB:

sudo mount -o subvol=@ /dev/sda2 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
manjaro-chroot /mnt
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro  --recheck --debug
1 Like

I have no idea why but:
When installer asks me if I want to install additional packages...

  1. If no than installation is flawless
  2. If yes than I need to do what @eugen-b wrote above to install bootloader.
    My packages are usually: darktable, timeset, timeshift, bash_completion, firefox, aspell-pl, hunspell-pl, libreoffice
    have no idea what is causing the problem with grub
1 Like

@Chrysostomus will need to look into it. I don't know if he would like that you file a bug report or if he can make a note himself. But thanks for finding a potential bug!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by