Why dont i have write access to my mounted windows drive?

And more importantly, what can i do to write to my windows drive from linux?

please and thank you.

Alsothe drive i want to open is an msata drive mounted in a 2 1/2 inch sata adapter and i am told from the file manager that there is no object for the dbus interface

1 Like

Hi,

can you please be a little more specific ? We do need more details to help. A single "It does not work" is not enough. What is interesting is what do you want to achive, what have you tried and what exactly are the problems.

This could relate to a missing restart after kernel update.


You may need to ensure Windows is shut down properly and Windows fastboot / hibernation is disabled.

Tips can be found in the following posts

1 Like

Similarly:

2 Likes

How to fix read/write issues with your NTFS drives:

First off, make sure you have ntfs-3g installed on your system.

In terminal enter:

pacman -Qi ntfs-3g

If you are having read/write problems with an NTFS drive then Windows may be causing this.

In Windows:

Disable hybrid sleep
Disable fast startup
Disable hibernation completely

Even if you have disabled these Windows features in the past you should recheck the current status.

Windows update could possibly have re-enabled these features without your knowledge.

In Windows open an elevated (Administrator) prompt, and run:

powercfg /h off

To fully correct your NTFS read/write issues you may need to mount your drive via /etc/fstab with the correct permissions options.

These are the steps I would recommend to mount an NTFS drive/partition via /etc/fstab.

Create a subdirectory in /media to mount your drive (you can mount to other locations).

As an example, create a mount point named "data":

sudo mkdir -p /media/data

You may name it anything else you prefer, but no white spaces is best practice in Linux.

For best accessability you may want to take ownership of your new mount point:

sudo chown -R $USER:$USER /media/data

Before making any modifications to /etc/fstab, create a back-up:

sudo cp /etc/fstab /etc/fstab.bak

Below is an example of how I would recommend you mount your NTFS drive via fstab:

UUID=YOUR_UUID /media/data ntfs-3g nofail,noatime,rw,user,uid=1000,gid=1000,dmask=022,fmask=133,windows_names,auto 0 0

You must substitute your partitions actual UUID for “YOUR_UUID” in the above fstab load line.

Your UUID should look something similar to this, UUID=0386661234733349.

You can find your drives UUID from the output of "sudo blkid -o list", (or from within your graphical partition manager utility).

You must also substitute your actual drive name and path for “/media/data” in the above fstab load line.

To set the ownership permissions, use the "uid" and "gid" options as in the above fstab load line.

You can find your UID with the command "id -u". To find your GID, use "id -g". These values are both normally 1000.

Reboot after making any modifications to /etc/fstab.

Full disclaimer:

Do not modify your fstab file without researching the proper procedures and making a backup copy first.

Improperly modifying your fstab file can render your computer unbootable.

Using the "nofail" option in any modification to your fstab file should limit the risk of this happening.

Reference:

https://wiki.archlinux.org/index.php/Fstab

http://www.man7.org/linux/man-pages/man5/fstab.5.html

https://wiki.archlinux.org/index.php/NTFS-3G

https://www.tuxera.com/community/ntfs-3g-manual/

If you are still experiencing issues after following these procedures, then:

Please post the output of the following commands.

sudo blkid -o list
cat /etc/fstab
inxi -Fxxxz
7 Likes

Thanks for all these awesome howto's. Much appreciated!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by