Why is Manjaro Kde too slow and buggy?!

I've been using manjaro for a few days.
And I love KDE. But i don't know why it's slowing down regularly everytime after i install a distribution!!!

System:    Kernel: 5.4.23-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=7eb2cd36-204a-4998-ad3b-e32d02c846fc rw 
           quiet apparmor=1 security=apparmor resume=UUID=5093390b-9673-417d-83b3-13e8aed960af 
           udev.log_priority=3 
           Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81DE v: Lenovo ideapad 330-15IKB serial: <filter> Chassis: 
           type: 10 v: Lenovo ideapad 330-15IKB serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO v: 8TCN53WW date: 05/17/2019 
Battery:   ID-1: BAT0 charge: 12.3 Wh condition: 27.8/30.0 Wh (93%) volts: 7.4/7.6 model: LGC L17L2PF1 
           type: Li-poly serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 8E (142) stepping: A (10) microcode: CA L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32012 
           Speed: 801 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 801 
           7: 800 8: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5917 
           Device-2: NVIDIA GP108M [GeForce MX150] vendor: Lenovo driver: N/A bus ID: 01:00.0 chip ID: 10de:1d10 
           Display: x11 server: X.Org 1.20.7 driver: modesetting compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.6 Mesa 19.3.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.4.23-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 
           v: kernel port: 3000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo 
           driver: ath10k_pci v: kernel port: 3000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-7:3 chip ID: 0cf3:e500 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
           IF-ID-2: tun1 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 1.82 TiB used: 108.63 GiB (5.8%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: LDM2 scheme: GPT 
Partition: ID-1: / raw size: 1.80 TiB size: 1.77 TiB (98.38%) used: 108.63 GiB (6.0%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 17.11 GiB used: 0 KiB (0.0%) fs: swap swappiness: 10 (default 60) 
           cache pressure: 100 (default) dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 52.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 248 Uptime: 19m Memory: 15.55 GiB used: 2.81 GiB (18.1%) Init: systemd v: 242 Compilers: 
           gcc: 9.2.1 clang: 9.0.1 Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37 

Please read.

3 Likes

It is usually baloo file, it needs sometimes a bit longer to index all files. Then it should be fine.

1 Like

thanks for help. But it's getting slower every time i boot my laptop up. I'm confused what the problem is.

Try to run htop in the terminal.

1 Like

Screenshot_20200309_171952
My cpu usage increases out of nowhere!!!
And my kde environment is too buggy
i clicked 5times on the button OK to upload the image :confused:

you see baloo_file_extractor is consuming 69%. Try to search what you can do about that, but don't try all recommendations at once or you will break your system worse.

1 Like

when it comes to baloo .. you can disable it ..
or simply wait. it is indexing your files. it will quiet down when it is done.

1 Like

Thanks all of you:)
I wait for several minutes but nothing happens

Umm can you help me figure this out?

You have 2 TB .. it will take a minute
(again you can search other threads .. you can disable it .. you can tame it .. you can wait .. up to you)

2 Likes

Yes and this is as weird to me as it is to you
Why should it take this much time and so buggy when i have 2tb of hard?
Can someone please help me to make it right?

Let it index your files, you will then get good search results. Every modern system has this feature.

1 Like

Larger space means longer time to scan.
Is that what you mean by explain ?

1 Like

It is scanning your files then when you will search anything it will give you almost constant result.

1 Like

Yes i know but how long should i wait?
It's been 10 minutes

It isn't ''buggy'' just because you don't understand it. If you have a lot of files, it is more a matter of hours than minutes, from what I understand. Baloo can also be disabled, check the Arch Wiki. Give it some more time before you conclude that you have a problem.

1 Like

It can take hours, why that rush?

1 Like

Simple solution. Disable baloo if you don't need it. Enable it when you do.

balooctl disable

Some of us have had to completely disable baloo cause it's constantly indexing. I suggest disabling it and installing either Carfush or AngrySearch or both. Here's my thread on it, and there are other post. I know in one of the testing update threads there are a few mentions about it.

3 Likes

Forum kindly sponsored by