Why is Manjaro not using NVIDIA as main GPU on my AIO PC?

Hi everyone,

I'm having some problems with a fresh new installed Manjaro on my AIO Lenovo that has both Intel and Nvidia GT 940MX GPU.
I've tried a lot but I'm not sure I've done all in the right way. I've tried: video-hybrid-intel-nvidia-440xx-prime, video-nvidia-440xx, and bumblebee. None of those didn't work for me.

Graphics:  Device-1: Intel HD Graphics 530 driver: i915 v: kernel 
           Device-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 440.64 
           Display: x11 server: X.Org 1.20.7 driver: modesetting FAILED: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) v: 4.6 Mesa 19.3.5 

How do I set the nvidia to be the main GPU?
Thanks in advance :slight_smile:

Check the FAQ for Ncidia options, it's all there

Found nothing that could help me, that's why I'm asking here.

Have you looked into switch or manager?

Doesn't work for me.

Double negation is not helpful for us either ...

When using that you need to run an application with:
prime-run application

But does the laptop work with one of those options?
Have you tested all of the available options


Did you also checked if you laptop require some custom kernel boot parameters as described bellow?

1 Like

Bogdan,
I've mentioned that i'm not having laptop. AIO is All-In-One PC.

what you have is a laptop without a keyboard that needs to be plugged in to work. treat it as an optimus laptop and ask a @moderators to close one of your threads. take your pick or they will for you

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by