Why isn't some software the very latest version?

There are a couple of elements to this question.

Firstly, software which has just been released by the upstream project needs time to be packaged and built so there will always be some time before it becomes available in a packaged format. If a package has patches then more time will be needed to check whether the patches are still needed, and if so, re-written to apply against the new version. Compiling software from its source code can take a long time.

Secondly, most Manjaro packages are taken from Arch stable, and Arch packages also have to go through a process from being built, to entering their staging repo, then moved to testing, then finally to stable. Once it reaches Arch stable the package will enter Manjaro unstable, and so on through the Manjaro branches until it finally reaches Manjaro stable.

For more information about how the Manjaro repos work, read this post:

Some important packages will be rebuilt outside of this process. These are generally #security updates but still require time to build. For example, Chromium will take around six hours to compile (if it succeeds on the first attempt).

18 Likes
Why is Manjaro postponing updates that fix critical security flaws?
KDE Plasma 5.15 released!
Why a package update is not available in manjaro repo - how to detect and help?
Does anyone have a timeline for the fixed version of Firefox Developer Edition coming down the pipes?
[SOLVED] Libreoffice - Just a general question
Firefox Developer Edition available version is older than current version
linux-latest package for updating latest stable kernel 5.4.x
How to get latest out-of-box apps with upgrade
Trying to configure JavaFX
AUR packages missing.
Make Deadbeef 1.8.2-1 available?
When will Mesa 19.2 be available in the repos?
Outdated software
Flow of packages through Arch and Manjaro
Nvidia Driver out of date
Difference between Manjaro and Arch packages
KeepassXC, Community Repo
How to install virtualbox 6.0.6-1?
(Solved) Polite request to update to Gpodder 3.10.8
nvidia 418 vs 430
Thunderbird 60.7.0 ?
nvidia 430.14
KDE Animation lags
Minitube 3.0 stops working: Minitube 3.1 fix the problem
AMD FreeSync & Vulkan
Question to Devs about packages
Linux 5.3 is officially out
Firefox (Dev Ed) version in repos (ewhile updating) older than what I can see on Arch website.
I need to install a later version of Arduino
Pacman isn't installing latest eclipse
New CUDA version via pacman
New CUDA version via pacman
Wine update to v5.11
Trying to update R
VirtualBox 6.1?
Manjaro syncthing package?
How do you update your software to fix CVEs?
KDE Plasma 5.19 when?
When are important updates made available?
KDE Plasma 5.18
Package management
sorry for my ignorance, but what do i need to do to have firefox updated?
[SOLVED] No updates after Manjaro upgrade
Firefox 76
Need version 0.24.1 of bazel but only 0.22 available in the repo
[Solved] Version Mismatch between Virtualbox On Manjaro Repos and Virtualbox Oracle Extensions On AUR
Kube Issue - How to track this?
Help installing specific version of Elixir.
Is it possible to use Gnome 3.34 now?
pacman refuses to install/acknowledge latest neovim update
Switch only specific packages to "Testing" branch

Forum kindly sponsored by