Wi-Fi connection effectively unusable at 100% signal strength

I installed manjaro a couple of days ago. Starting yesterday, my Wi-fi connection has become unusable. I can connect to my wifi, the signal strength is reported as 90-100% and I can use Synergy perfectly. I can open up a website, rarely and usually partially. But it is entirely unusable otherwise.

I think this picture describes my problem well:

Loading webpages usually hangs at TLS Handshake.

Tried to set fixed DNS servers with no success. Someone suggested I put this:


Into my NetworkManager.conf. Didn't do anything.

Ethernet connection is fine. I haven't used a linux system in a while so I'm a bit rusty but if you tell me the commands to run I can supply logs and such.

ip link output:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s25: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 3c:97:0e:e8:35:86 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether e0:9d:31:2e:7a:d4 brd ff:ff:ff:ff:ff:ff

       description: Wireless interface
       product: Centrino Advanced-N 6205 [Taylor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 34
       serial: e0:9d:31:2e:7a:d4
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.19.36-1-MANJARO firmware= ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:28 memory:f1c00000-f1c01fff

Kernel: 4.19.36-1-MANJARO
DE: Xfce

Thanks in advance

and maybe here some hints

Run the set of commands below to see if your connection can be properly initiated.

Please do not cut and paste all the commands together at once.

Enter and run each command separately with a few seconds between each command.

Please post all inputs, and all outputs of that sequence of commands once they are finished being run.

Please do not give me a summary, such as "there were no outputs".

It is very important that you post each input and output for troubleshooting purposes.

nmcli networking off

sudo systemctl stop NetworkManager

sudo ip link set wlp3s0 down

sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod

sudo rfkill unblock wifi

sudo modprobe iwlwifi 11n_disable=1 swcrypto=1

sudo ip link set wlp3s0 mode default

sudo ip link set wlp3s0 up

sudo systemctl start NetworkManager

nmcli networking on

nmcli r wifi on

nmcli r wifi on

I would also suggest installing and testing 2 older and 2 newer kernels. Install kernels through Manjaro Settings Manager, and always have at least two kernels installed at all times for safety.

1 Like

I have an older router that's only capable of 2.4GHz. The Wi-Fi connection is indeed fine on a live USB.

I ran every command separately. I allowed a couple of seconds between commands. I will give you a summary of "there were no outputs".

You will lose the changes made by the above commands when you reboot.

Unless there is absolutely no alternative please do not post terminal output as a pic.

Please post all terminal command output as text with code tags.

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks ``` before and after, as shown in this picture:

Also, please read this:

If you only have a 2.4 GHz router then change this line in the above commands:

To this below:

sudo modprobe iwlwifi 11n_disable=8 swcrypto=1

Then run the entire list of commands again.

Have you rebooted your router yet?

Please post:

cat /etc/resolv.conf

Hmmm this is really interesting. You mean Manjaro USB dongle you installed it from? Or other OS/Distro?

Well, things that helped me with the wifi were usually:

  • tinker with my WiFi router settings
  • newer kernel - onboard wifi on my desktop used to hang, while still showing all connecting and a good signal

Hmm hmm, your sentence about USB boot and WiFi working fine doesn't want to leave my mind.

@tbg would it be worth of doing the same set of diagnostic commands you offered on live system and installed system? I mean for comparison?

Yes, you can test those commands on a live system. The adapters designation might be different on a live disk though. Correcting wifi issues on a live disk is often not very successful. I rarely waste much time trying to get wifi working on a live boot as it's just not worth the effort.

I've clearly demonstrated my ability to use code blocks in the OP, you dont need to refer me to a tutorial on how to do them, just tell me to use them.

The commands didn't help, so it's rather irrelevant if I lose the effects upon reboot. I also wouldn't test the commands on a live system since on a live manjaro system my wifi works. There is no real "output" so I don't see what one could compare with that. And given that wifi works on the live usb I don't see how restarting my router would improve the situation, but I did it anyway, to no avail.

cat /etc/resolv.conf

[22:43:27] [johan@johan-pc ~]$ cat /etc/resolv.conf
# Generated by NetworkManager
search lan

Yes I tried to change the DNS

Turning it on and off again

[01:58:51] [johan@johan-pc ~]$ nmcli networking off
[01:58:55] [johan@johan-pc ~]$ sudo systemctl stop NetworkManager
[sudo] password for johan: 
[01:59:09] [johan@johan-pc ~]$ sudo ip link set wlp3s0 down
[01:59:19] [johan@johan-pc ~]$ sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod
[01:59:26] [johan@johan-pc ~]$ sudo rfkill unblock wifi
[01:59:34] [johan@johan-pc ~]$ sudo modprobe iwlwifi 11n_disable=8 swcrypto=1
[01:59:41] [johan@johan-pc ~]$ sudo ip link set wlp3s0 mode default
[01:59:46] [johan@johan-pc ~]$ sudo ip link set wlp3s0 up
[01:59:53] [johan@johan-pc ~]$ sudo systemctl start NetworkManager
[01:59:58] [johan@johan-pc ~]$ nmcli networking on
[02:00:05] [johan@johan-pc ~]$ nmcli r wifi on
[02:00:18] [johan@johan-pc ~]$ nmcli r wifi on

Curiously enough this had no effect. Yes, I rebooted the system.

Switching to 4.20.17-1 had no effect.

And yes, I did check whether turning it on and off again had any effect both before and after I rebooted.

Please answer and test all kernels suggested.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by