Wi-fi doesn't detect connections even if it is active

Hi guys, i've been searching a solution through the forum but none of the solution for other users helped me.
I've a desktop computer, an Acer Aspire M1641, i've changed the hdd and installed an ssd so i decided to install a linux distro.
First i installed deepin 15.9.1 and everything worked fine but graphics acceleration didnt' convice me so i found Manjaro that seems more fluid and have a better support so i installed it.
Same here, everything worked fine, then i found Manjaro Deepin so yesterday i've installed it on my pc but idk why wi-fi seems active but doesn't detect connections.
I don't have possibilities to connect it with a LAN cable so i don't know what to do.
If it can help: when i installed manjaro deepin the installation program told me that the computer wasn't fully compatible with my hardware.
There's a solution, i don't think is an hardware problem because with other distros everything worked fine.
Sorry for my english and thank you for the help.

Please post:

inxi -Fxxxz
hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 

Please post all terminal commands as text with code tags, (not as pics).

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by