Wi-Fi keeps to request authentication - can't connect to internet

Hello guys,

I'm using Manjaro and as I said in the title the system keeps asking me the password to log in to WI-FI without connecting at it. With Hotspot mobile phone I have no problem and also no problem with WI-FI and manjaro in the other computer I am using right now. I've already tried to reboot.
What do you think ?

:slightly_smiling_face: @fenerevar, are you using KDE by any chance?

Hello, I am using Xfce4!

:slightly_smiling_face: @fenerevar, I hope this solution works for you:

Manjaro Xfce WiFi Not Working

1 Like

Hello thank you for the link, I've tried but password was already in the box Security WI-FI, I've tried to type it again but nothing changed and prompt is again here

Maybe it is a problem of the application since there is a loop of request authentication whetever I choose "exit" or "connect", last one without success

:neutral_face: Oh, I am truly sorry that it didn't work.

Hopefully someone else will help you rectify things in a timely manner.

Do not give up hope.

2 Likes

Thanks I've really appreciated your help :slight_smile:

1 Like

The best way to get help is to start by posting your system information. You can get it by typing

inxi -Fxzc0

in a terminal.

I've seen the same problem with wifi when there was an issue with the kernel. I'd suggest trying a different kernel, either an older LTS or a newer kernel series if you have a brand new system. It is tempting to always use the newest available kernel series, but if you have older hardware, the newest series might not be the best choice!

If changing kernels doesn't help, one of the wifi experts might have some ideas about trouble shooting your wifi connectivity.

1 Like

Hello thanks for the suggestions and informations

Here is

inxi -Fxzc0

System: Host: amaranth Kernel: 4.9.85-1-MANJARO x86_64 bits: 64 gcc: 7.3.0 Desktop: Xfce 4.12.4 (Gtk 2.24.31)
Distro: Manjaro Linux
Machine: Device: desktop System: Dell product: Inspiron One 2310 serial: N/A
Mobo: Dell model: N/A serial: N/A BIOS: Dell v: A04 date: 11/11/2010
CPU: Dual core Intel Core i3 M 370 (-MT-MCP-) arch: Nehalem rev.5 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9578
clock speeds: max: 2394 MHz 1: 931 MHz 2: 931 MHz 3: 931 MHz 4: 931 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 ) drivers: ati,radeon (unloaded: modesetting)
Resolution: 1920x1080@59.98hz
OpenGL: renderer: AMD CEDAR (DRM 2.49.0 / 4.9.85-1-MANJARO, LLVM 5.0.1)
version: 3.3 Mesa 17.3.6 Direct Render: Yes
Audio: Card Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.9.85-1-MANJARO
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8168 v: 8.045.08-NAPI port: d000 bus-ID: 11:00.0
IF: enp17s0 state: down mac:
Card-2: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter driver: wl bus-ID: 12:00.0
IF: wlp18s0 state: up mac:
Drives: HDD Total Size: 1000.2GB (7.6% used)
ID-1: /dev/sda model: TOSHIBA_DT01ACA1 size: 1000.2GB
Partition: ID-1: / size: 449G used: 67G (16%) fs: ext4 dev: /dev/sda3
ID-2: swap-1 size: 5.35GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
Sensors: System Temperatures: cpu: 40.0C mobo: N/A gpu: 55.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 207 Uptime: 5:22 Memory: 2323.2/3821.3MB Init: systemd Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

you can try this go to network manager then right click on you intended connection select settings when you connection comes up click the gear symbol and click ipv6 tab
selcet disable
try to connect again.
if that does not work , make sure that b43 and ssb are blacklisted if they are installed.

1 Like

Hello thank you for the informations and tips,

I've solved the issue, however I am trying another Kernel. ipv6 tab was already in disable mode.

Thanks to all :slight_smile:

you might tells us what you did to solve the problem so it will be help to others :slight_smile:

1 Like

[Edit - SOLVED] I was connecting using the encrypted password option when I had disabled KDE Wallet. After I changed to all users unencrypted password, wi-fi connected automatically on a reboot.

Yes, I have exactly the same problem. Wi-fi keeps asking for authentication. How did you solve it?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by