Плохо ловит Wi-Fi сигнал на ноутбуке.

Здравствуйте. Месяц назад установил Manjaro KDE на ноутбук и столкнулся с рядом проблем. Например эта: Прямо сейчас сижу возле маршрутизатора а на ноутбуке всего три деления на иконке Wi-Fi, отхожу на несколько метров уже два. В соседней комнате уже не ловит.
Сетевой контроллер: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
Помогите чем сможете.
Заранее спасибо!

похожее тут. по идее пробуй или самое свежее ядро или внешний адаптер.

Изменил ядро, всё сломалось. Пришлось переустанавливать, и всё работает прекрасно (кроме некоторых проблем с памятью). Возможно всё дело в обновлении системы. Можно ли отключить обновления?

конечно же можно. это же Линукс. в Pamac-е просто убрать настройки проверки обновления и вручную не обновляй командой и всё. А ядро моно было и откатить на старое без переустановки. но если полностью переставил то и ладно.

Не получилось, всё равно хочет просунуть мне обновления. Их нельзя как ни будь отменить или перескочить. Или с помощью терминала что ни будь сделать?

убери информирование и не обращай внимание. это не виндовс.тут можно их игнорировать.
возможно это:

Нет, нет, это совсем не то о чём я говорю. Когда я пытаюсь установить приложение то вылезает это:Screenshot_20200808_204511

у тебя при этом во вкладке "обновление" пункты обновлений выделены галочкой или нет? в настройках "проверять обновления" ползунок отключен?

Во вкладке обновления убрал галочки и выключил проверку обновлений, но когда пытаюсь скачать какую ни будь программу то вылезает то что на картинке.

при нажатии в том окне "отмена" оно закрывается и программы из списка устанавливаются/удаляются без проблем?

Пишет "Транзакция отменена"

это похоже окно зависимостей для тех программ, что ты пытаешься установить. сверь окно со списком отключенных галочек обновления системы, и если много отличий, значит это обычное окно зависимости для устанавливаемого. скорей всего программа требует наличия обновленных компонентов, а у тебя они не обновлены, или некоторых из них вовсе нет в системе.

если не хочешь мучиться с зависимостями, подключи репозиторий flatpak галочкой, и ставь только то что в списке поиска подписано "flatpak". там одним "масивом" всё.

Выходит сводка транзакций и снизу опять “к обновлению”

это окно зависимостей программы. ставь её с flatpak
репозиторий flatpak подключил и пробовал ставить ту же программу но с надписью внизу "flatpak", и снова то окно с тем же списком выскакивает?

Да. Только с верху нет списка "К установке".

Можно ли установить другой менеджер пакетов?

так это не обновление всей ос, только "хвосты" программ. если их не одобрить то придется работать с теми программами, которые стоят "по умолчанию". но есть еще один вариант использовать appimage версии программ, но не тестил как с ними в манджаро дела обстоят, и они редко для чего есть и всегда на официальных сайтах. 2020-08-08_193616
в основном "всё в одном" в флатпаках находится и зависимостей загружать не нужно.

они все работают с зависимостями.если программа их требует-все они загружают всё что ей нужно.поэтому не скачаешь-не запустишь

Зависимости то это ладно, они как я понял находятся в списке "к установке". А как сделать так чтобы только "к установке" и устанавливались?

Forum kindly sponsored by