Wider compatibility with SSDs on battery mode

Manjaro is currently very slow with certain SSD models when in battery mode, till the point that the desktop freezes for around 15 seconds constantly.

More info here.

Following the Arch Wiki, I'm writing a script for fixing the issue. But it doesn't seem to stay persistent after reboot, even when it creates the configuration files as told in Arch.

Does anybody know why? Thank you.

Sounds like it could be linked to TLP; there are APM settings available in /etc/default/tlp, though by default this should be set to 254.

Have you altered these settings at all?

1 Like

I haven't. Any guess about what variable it could be?

Thank you.

best comment those APM lines out entirely.

1 Like

No guess needed. Reading the file is all that's needed. :wink:

# Hard disk advanced power management level: 1..254, 255 (max saving, min, off)
# Levels 1..127 may spin down the disk; 255 allowable on most drives.
# Separate values for multiple devices with spaces.
DISK_APM_LEVEL_ON_AC="254 254"
DISK_APM_LEVEL_ON_BAT="254 254"
1 Like

Thanks, but it didn't work.

In the Terminal, if i enter:
sudo hdparm -B /dev/sda

I get:
APM_level = 254

But even then it's slow. I will try other variables and I will let you know. Thank you.

crucial have disable APM in the latest firmware for their MX300 range so the only value applicable would be 255 or commenting the lines out as suggested. version=M0CR060

Release Date: 9/12/2017

  • SMART Attribute 198 was not reset at start of each background scan
  • Improved compatibility with Micron JMB394 RAID controller
  • Improved drive error handling
  • Disable APM
  • General stability improvements
  • Second source enablement

with either value 255 or the lines commented out, I get full device performance with my MX300 525GB drive.

2 Likes

Disabling TLP eliminates the issue. I will now try commenting some lines, as @anon71843593 suggests. So to figure out which is the problematic one.

This bit:

DISK_APM_LEVEL_ON_AC="254 254"
DISK_APM_LEVEL_ON_BAT="254 254"

Set it to 255 for your SSD.

It hasn't worked. I'm trying now with other lines.

from http://linrunner.de/en/tlp/docs/tlp-faq.html

System is excessively slow on battery
Affected hardware: ThinkPad T60 and T420 users reported this.
Solution:
SATA_LINKPWR_ON_BAT=medium_power

min_power – max power saving / minimum performance
medium_power – compromise between power saving and performance
max_performance – minimum power saving / max performance

You can also blacklist device:
SATA_LINKPWR_BLACKLIST="host1"

Exclude listed SATA host devices from link power management. Look into the output of tlp-stat -d, section "SATA Aggressive Link Power Management", to determine valid host identifiers (format: "hostX"). This is intended as a workaround for SATA host devices not bearing power management.
Separate multiple hosts with spaces.

3 Likes

Kernel 4.15 has some improvements regarding ALPM.
Apparently, with older kernels, max power saving with ALPM is not recommended as it can sometimes lead to data loss.

1 Like

Yeah, that's the problematic line. I realised it yesterday before going to bed.

I'm testing now if it works well with medium power. Thank you.

Medium power works well. Likely it would be a better default.

1 Like

mm, nice to know, thx all, as long as the ever-allegiance-changing ssd makers keep in sync, for our sake, also.?

1 Like

Forum kindly sponsored by