Wifi access with Lenovo G580

I've enjoyed running Manjaro on my desktop, but have never been able to use on my 6 yr. old Lenovo G580 laptop.

Is there a program to install that could get the wifi to work?

Please post:

inxi -Fxxxz  && inxi -Fxxxz  | grep -q ANJ || echo check required && ls /usr/share/xsessions/ && head -n1 /var/log/pacman.log | cut -d " " -f1 | cut -c 2-11 && rfkill list

Install kernels 5.0 & 5.1 through Manjaro Settings Manager then test out the broadcom-wl-dkns driver on the newest kernels. You can find instructions for installing the dkms driver here:

If you have been fighting with this adapter as long as your post indicates, perhaps its time to replace the broadcom chip with the Atheros card referenced on this Arch forum post:



I booted from USB and Manjaro Gnome did connect to WIFI for the first time! I did see Atheros so that's good.

So I started to install over MX Linux and after the install and I rebooted the HDD was not seen so I wouldn't boot up even though it was installed. Never seen that happened. Anyway I was able to install Ubuntu 19.04 for now, but I'll reburn Manjaro and try again sometime.

Just tried to install Manjaro deepin version on the G580 and it sees my wifi connection, but it doesn't allow me to log in with my password!
Why does this happen?

Are you by chance using an older deepin install iso. This is a Deepin networking bug that I thought was solved on more recent Deepin iso's.

You have posted none of the outputs I requested.
You also never stated whether you installed alternate kernels as I suggested, or whether you followed my broadcom-wl-dkms driver install guide.

This issue is probably easily resolvable, but those who do not provide proper feedback tend to receive little assistance until they do so. Do not expect much help if you provide no information.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by