Wifi adapter (TL-WN722N)

Can't install driver for a wifi adapter (TL-WN722N), whenever i plug it in, mouse and mice stop working entirely and the system freezes.

██████████████████  ████████     gabri@gabri-battlestation
██████████████████   ███████     OS: Manjaro 19.0.2 Kyria
 ██████████████████  ████████     Kernel: x86_64 Linux 5.4.28-1-MANJARO
 ██████████████████  ████████     Uptime: 10m
 ████████            ████████     Packages: 1200
 ████████  ████████  ████████     Shell: bash 5.0.16
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: KDE 5.68.0 / Plasma 5.18.3
 ████████  ████████  ████████     WM: KWin
 ████████  ████████  ████████     GTK Theme: Breath [GTK2/3]
 ████████  ████████  ████████     Icon Theme: breath2
 ████████  ████████  ████████     Disk: 12G / 691G (2%)
 ████████  ████████  ████████     CPU: AMD FX-8350 Eight-Core @ 8x 4GHz
 ████████  ████████  ████████     GPU: Radeon RX 580 Series (POLARIS10, DRM 3.35.0, 5.4.28-1-MANJARO, LLVM 9.0.1)
                                  RAM: 1941MiB / 16037MiB

I tried using the AUR package, but it says that it cannot find the kernel header.

Start reading from here all the way down

The problem is that i literally can't do anything, once i plug in the adapter.

But do you plug in USB2 or USB3 connector ? Anything in dmesg when you plug it in?

I just tried it on a live linux mint and the problem is even there!

My mouse and keyboard start flashing (rgb) and after a few seconds it freezes completely.

Both usb 2 and 3 give me this problem.

Sorry for the sloppy screen, but i couldn't copypaste it.

Here's the result with dmesg | tail - 30
IMG_20200401_155500

I can't get much from this ... If you fresh boot with all connected, what happens?

Nothing changes, i might retry dmesg

Okay so after messing a bit around in grub.cfg, i set the default cmd line to "quiet splash" and the other one to "iommu=soft" a trick i learned from older ubuntu installs i did.

Now the system won't die, but the adapter straight up doesn't work (it didn't before as well)

EDIT: Nevermind, because neither of the front usb 3.0 port now.
works. Found it out while trying to tether with my phone

Now i can run dmesg at least...

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by