Wifi, Bluetooth not Working/Detected on Zenbook UX433FN

I was running Win10, and decided to switch to Manjaro recently post which Wifi/Bluetooth don't work anymore.

I see that the device is listed and the drivers are installed, but nothing shows up on the panel for either of the features. For instance, the bluetooth panel says "no adapters found", the same goes for WiFi.

I tried some usual fixes listed across the internet to no avail, I noticed that the driver wasn't being detected on linux 57 hence downgraded to 54 and now it shows up. I've kept the OS updated as well.

Currently connected through a cable.

Here are the outputs to some commands I ran that you guys might need:

inxi -Fxxz

System: Host: AlephNaught Kernel: 5.4.44-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Laptop System: ASUSTeK product: ZenBook UX433FN_UX433FN v: 1.0 serial:
Mobo: ASUSTeK model: UX433FN v: 1.0 serial: UEFI: American Megatrends v: UX433FN.310
date: 03/25/2020
Battery: ID-1: BAT0 charge: 46.0 Wh condition: 46.0/50.1 Wh (92%) volts: 11.9/11.9
model: ASUSTeK ASUS Battery serial: status: Not charging
CPU: Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Kaby Lake rev: B
L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808
Speed: 800 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800
7: 800 8: 800
Graphics: Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:3ea0
Device-2: NVIDIA GP108M [GeForce MX150] vendor: ASUSTeK driver: nvidia v: 440.82 bus ID: 02:00.0
chip ID: 10de:1d12
Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa
compositor: kwin_x11 resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.0.7 direct render: Yes
Audio: Device-1: Intel Cannon Point-LP High Definition Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 00:1f.3 chip ID: 8086:9dc8
Sound Server: ALSA v: k5.4.44-1-MANJARO
Network: Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel port: 4000
bus ID: 00:14.3 chip ID: 8086:9df0
Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a bus ID: 2-1:3
chip ID: 0b95:1790
IF: enp0s20f0u1 state: up speed: 100 Mbps duplex: full mac:
Drives: Local Storage: total: 476.94 GiB used: 89.09 GiB (18.7%)
ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 SDAPNUW-512G-1002 size: 476.94 GiB
speed: 15.8 Gb/s lanes: 2 serial:
Partition: ID-1: / size: 468.16 GiB used: 89.09 GiB (19.0%) fs: ext4 dev: /dev/nvme0n1p2
Sensors: System Temperatures: cpu: 50.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2800
Info: Processes: 242 Uptime: 16m Memory: 7.60 GiB used: 1.81 GiB (23.9%) Init: systemd v: 245 Compilers:
gcc: 10.1.0 Shell: bash v: 5.0.17 running in: konsole inxi: 3.0.37

hwinfo --netcard --bluetooth | grep -v "Config S"

12: PCI 14.3: 0280 Network controller
[Created at pci.386]
Unique ID: yX7n.NvSMBLlLMrC
SysFS ID: /devices/pci0000:00/0000:00:14.3
SysFS BusID: 0000:00:14.3
Hardware Class: network
Device Name: "WLAN"
Model: "Intel Cannon Point-LP CNVi [Wireless-AC]"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x9df0 "Cannon Point-LP CNVi [Wireless-AC]"
SubVendor: pci 0x8086 "Intel Corporation"
SubDevice: pci 0x0000
Revision: 0x30
Driver: "iwlwifi"
Driver Modules: "iwlwifi"
Memory Range: 0xb431c000-0xb431ffff (rw,non-prefetchable)
IRQ: 16 (no events)
Module Alias: "pci:v00008086d00009DF0sv00008086sd00000000bc02sc80i00"
Driver Info #0:
Driver Status: iwlwifi is active
Driver Activation Cmd: "modprobe iwlwifi"

29: USB 00.0: 11500 Bluetooth Device
[Created at usb.122]
Unique ID: fHJ1.l3v0gVevrhC
Parent ID: k4bc.2DFUsyrieMD
SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-10/1-10:1.0
SysFS BusID: 1-10:1.0
Hardware Class: bluetooth
Model: "Intel Bluetooth Device"
Hotplug: USB
Vendor: usb 0x8087 "Intel Corp."
Device: usb 0x0aaa
Driver: "btusb"
Driver Modules: "btusb"
Speed: 12 Mbps
Module Alias: "usb:v8087p0AAAd0000dcE0dsc01dp01icE0isc01ip01in00"
Driver Info #0:
Driver Status: btusb is active
Driver Activation Cmd: "modprobe btusb"
Attached to: #35 (Hub)

31: USB 00.0: 0200 Ethernet controller
[Created at usb.122]
Unique ID: FKGF.8YN5_CVPV_0
Parent ID: pBe4.xYNhIwdOaa6
SysFS ID: /devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.0
SysFS BusID: 2-1:1.0
Hardware Class: network
Model: "ASIX Electronics AX88179 Gigabit Ethernet"
Hotplug: USB
Vendor: usb 0x0b95 "ASIX Electronics Corp."
Device: usb 0x1790 "AX88179 Gigabit Ethernet"
Revision: "1.00"
Serial ID: "00000000000001"
Driver: "ax88179_178a"
Driver Modules: "ax88179_178a"
Device File: enp0s20f0u1
HW Address: 00:0e:c6:b4:ca:03
Permanent HW Address: 00:0e:c6:b4:ca:03
Link detected: yes
Module Alias: "usb:v0B95p1790d0100dcFFdscFFdp00icFFiscFFip00in00"
Driver Info #0:
Driver Status: ax88179_178a is active
Driver Activation Cmd: "modprobe ax88179_178a"
Attached to: #37 (Hub)

lsmod | sort

8250_dw 16384 0
ac 16384 0
ac97_bus 16384 1 snd_soc_core
acpi_tad 20480 0
acpi_thermal_rel 16384 1 int3400_thermal
aesni_intel 372736 0
agpgart 53248 3 intel_gtt,ttm,drm
asus_nb_wmi 28672 0
asus_wmi 40960 1 asus_nb_wmi
atkbd 36864 0
ax88179_178a 28672 0
battery 20480 1 asus_wmi
bluetooth 688128 12 btrtl,btintel,btbcm,bnep,btusb
bnep 28672 2
btbcm 16384 1 btusb
btintel 28672 1 btusb
btrtl 24576 1 btusb
btusb 65536 0
cfg80211 851968 3 iwlmvm,iwlwifi,mac80211
coretemp 20480 0
crc16 16384 2 bluetooth,ext4
crc32c_generic 16384 0
crc32c_intel 24576 2
crc32_pclmul 16384 0
crct10dif_pclmul 16384 1
cryptd 24576 2 crypto_simd,ghash_clmulni_intel
crypto_simd 16384 1 aesni_intel
crypto_user 16384 0
drm 520192 18 drm_kms_helper,drm_vram_helper,vboxvideo,nvidia_drm,i915,ttm
drm_kms_helper 221184 3 vboxvideo,nvidia_drm,i915
drm_vram_helper 20480 1 vboxvideo
ecc 32768 1 ecdh_generic
ecdh_generic 16384 1 bluetooth
evdev 28672 18
ext4 786432 1
fat 86016 1 vfat
fb_sys_fops 16384 1 drm_kms_helper
fuse 135168 5
ghash_clmulni_intel 16384 0
glue_helper 16384 1 aesni_intel
hid 139264 4 i2c_hid,usbhid,hid_multitouch,hid_generic
hid_generic 16384 0
hid_multitouch 32768 0
i2c_algo_bit 16384 1 i915
i2c_hid 32768 0
i2c_i801 36864 0
i8042 32768 1 asus_nb_wmi
i915 2392064 40
idma64 20480 0
input_leds 16384 0
int3400_thermal 20480 0
int3403_thermal 16384 0
int340x_thermal_zone 16384 2 int3403_thermal,processor_thermal_device
intel_cstate 16384 0
intel_gtt 24576 1 i915
intel_lpss 16384 1 intel_lpss_pci
intel_lpss_pci 20480 2
intel_pch_thermal 16384 0
intel_powerclamp 20480 0
intel_rapl_common 28672 2 intel_rapl_msr,processor_thermal_device
intel_rapl_msr 20480 0
intel_rapl_perf 16384 0
intel_soc_dts_iosf 20480 1 processor_thermal_device
intel_uncore 147456 0
ipmi_devintf 20480 0
ipmi_msghandler 69632 2 ipmi_devintf,nvidia
ip_tables 36864 0
irqbypass 16384 1 kvm
iTCO_vendor_support 16384 1 iTCO_wdt
iTCO_wdt 16384 0
iwlmvm 450560 0
iwlwifi 380928 1 iwlmvm
jbd2 135168 1 ext4
joydev 28672 0
kvm 798720 1 kvm_intel
kvm_intel 323584 0
ledtrig_audio 16384 2 snd_hda_codec_generic,snd_hda_codec_realtek
libarc4 16384 1 mac80211
libps2 20480 1 atkbd
loop 40960 28
mac80211 995328 1 iwlmvm
mac_hid 16384 0
mbcache 16384 1 ext4
mc 61440 4 videodev,videobuf2_v4l2,uvcvideo,videobuf2_common
mei 118784 3 mei_hdcp,mei_me
mei_hdcp 24576 0
mei_me 45056 1
mii 16384 2 usbnet,ax88179_178a
Module Size Used by
mousedev 24576 0
mxm_wmi 16384 0
nls_cp437 20480 1
nls_iso8859_1 16384 1
nvidia 20508672 75 nvidia_modeset
nvidia_drm 57344 3
nvidia_modeset 1118208 2 nvidia_drm
pcspkr 16384 0
processor_thermal_device 24576 0
rfkill 28672 8 asus_wmi,bluetooth,cfg80211
rng_core 16384 1 tpm
scsi_mod 253952 1 sg
serio 28672 4 serio_raw,atkbd,i8042
serio_raw 20480 0
sg 40960 0
snd 110592 18 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm
snd_compress 28672 1 snd_soc_core
snd_hda_codec 159744 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda
snd_hda_codec_generic 94208 1 snd_hda_codec_realtek
snd_hda_codec_hdmi 73728 1
snd_hda_codec_realtek 135168 1
snd_hda_core 102400 10 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_hda_ext_core 32768 4 snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_hda_intel 53248 2
snd_hrtimer 16384 1
snd_hwdep 16384 1 snd_hda_codec
snd_intel_nhlt 20480 3 snd_hda_intel,snd_sof_intel_hda_common,snd_soc_skl
snd_pcm 143360 9 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_sof,snd_sof_intel_hda_common,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
snd_pcm_dmaengine 16384 1 snd_soc_core
snd_seq 86016 7 snd_seq_dummy
snd_seq_device 16384 1 snd_seq
snd_seq_dummy 16384 0
snd_soc_acpi 16384 3 snd_sof_pci,snd_soc_acpi_intel_match,snd_soc_skl
snd_soc_acpi_intel_match 32768 3 snd_sof_pci,snd_sof_intel_hda_common,snd_soc_skl
snd_soc_core 290816 4 snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl
snd_soc_hdac_hda 24576 1 snd_sof_intel_hda_common
snd_soc_skl 180224 0
snd_soc_sst_dsp 40960 1 snd_soc_skl
snd_soc_sst_ipc 20480 1 snd_soc_skl
snd_sof 122880 4 snd_sof_pci,snd_sof_intel_hda_common,snd_sof_intel_byt,snd_sof_intel_ipc
snd_sof_intel_byt 20480 1 snd_sof_pci
snd_sof_intel_hda 20480 1 snd_sof_intel_hda_common
snd_sof_intel_hda_common 73728 1 snd_sof_pci
snd_sof_intel_ipc 20480 1 snd_sof_intel_byt
snd_sof_pci 20480 0
snd_sof_xtensa_dsp 16384 1 snd_sof_pci
snd_timer 40960 3 snd_seq,snd_hrtimer,snd_pcm
soundcore 16384 1 snd
sparse_keymap 16384 1 asus_wmi
spi_pxa2xx_platform 32768 0
squashfs 69632 14
syscopyarea 16384 1 drm_kms_helper
sysfillrect 16384 1 drm_kms_helper
sysimgblt 16384 1 drm_kms_helper
tpm 77824 3 tpm_tis,tpm_crb,tpm_tis_core
tpm_crb 20480 0
tpm_tis 16384 0
tpm_tis_core 28672 1 tpm_tis
ttm 118784 1 drm_vram_helper
uinput 20480 0
usbhid 65536 0
usbnet 49152 1 ax88179_178a
uvcvideo 114688 0
vboxdrv 503808 2 vboxnetadp,vboxnetflt
vboxguest 45056 1 vboxsf
vboxnetadp 28672 0
vboxnetflt 32768 0
vboxsf 40960 0
vboxvideo 40960 0
vfat 24576 1
videobuf2_common 57344 2 videobuf2_v4l2,uvcvideo
videobuf2_memops 20480 1 videobuf2_vmalloc
videobuf2_v4l2 28672 1 uvcvideo
videobuf2_vmalloc 20480 1 uvcvideo
videodev 249856 3 videobuf2_v4l2,uvcvideo,videobuf2_common
wmi 36864 3 asus_wmi,wmi_bmof,mxm_wmi
wmi_bmof 16384 0
x86_pkg_temp_thermal 20480 0
xhci_hcd 282624 1 xhci_pci
xhci_pci 20480 0
x_tables 49152 1 ip_tables

Apart from this even the microphone and the webcam don't work, but let's keep that aside for now. Something tells me most of the features of the chipset is for some reason not working.

UPDATE/EDIT: The Microphone and Webcam work after changing a few settings. So there's nothing wrong with the laptop. So it's just the wireless stuff that needs troubleshooting.

I am new to this, and I have exams coming up soon so any help would be highly appreacited.

Thank you so much.

Just wanted to also add firmware details:

sudo dmesg | grep firmware

[ 0.198879] Spectre V2 : Enabling Restricted Speculation for firmware calls
[ 2.778236] iwlwifi 0000:00:14.3: loaded firmware version 46.8902351f.0 op_mode iwlmvm
[ 2.965428] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[ 3.123486] iwlwifi 0000:00:14.3: Allocated 0x00400000 bytes for firmware monitor.
[ 4.940967] Bluetooth: hci0: Minimum firmware build 0 week 0 2000
[ 4.941159] bluetooth hci0: Direct firmware load for intel/ibt-17-0-0.sfi failed with error -2
[ 4.941162] Bluetooth: hci0: Failed to load Intel firmware file (-2)

Looks like the wifi driver gets loaded but not the bluetooth.

But then there seems to be errors on running the wifi firmware.

sudo dmesg | grep iwlwifi

[ 2.755056] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[ 2.777778] iwlwifi 0000:00:14.3: Found debug destination: EXTERNAL_DRAM
[ 2.777782] iwlwifi 0000:00:14.3: Found debug configuration: 0
[ 2.778236] iwlwifi 0000:00:14.3: loaded firmware version 46.8902351f.0 op_mode iwlmvm
[ 3.108933] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9460, REV=0x318
[ 3.116501] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[ 3.123486] iwlwifi 0000:00:14.3: Allocated 0x00400000 bytes for firmware monitor.
[ 3.130126] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[ 3.130133] iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
[ 3.130147] iwlwifi 0000:00:14.3: Fseq Registers:
[ 3.130158] iwlwifi 0000:00:14.3: 0xD7F5BA65 | FSEQ_ERROR_CODE
[ 3.130168] iwlwifi 0000:00:14.3: 0x71ADD2F7 | FSEQ_TOP_INIT_VERSION
[ 3.130178] iwlwifi 0000:00:14.3: 0xA339AD7A | FSEQ_CNVIO_INIT_VERSION
[ 3.130188] iwlwifi 0000:00:14.3: 0x1AFDBBED | FSEQ_OTP_VERSION
[ 3.130198] iwlwifi 0000:00:14.3: 0x58015F28 | FSEQ_TOP_CONTENT_VERSION
[ 3.130208] iwlwifi 0000:00:14.3: 0x41480186 | FSEQ_ALIVE_TOKEN
[ 3.130218] iwlwifi 0000:00:14.3: 0xCFBE8D5E | FSEQ_CNVI_ID
[ 3.130228] iwlwifi 0000:00:14.3: 0xCA206499 | FSEQ_CNVR_ID
[ 3.130238] iwlwifi 0000:00:14.3: 0x01000100 | CNVI_AUX_MISC_CHIP
[ 3.130250] iwlwifi 0000:00:14.3: 0x0BADADD7 | CNVR_AUX_MISC_CHIP
[ 3.130263] iwlwifi 0000:00:14.3: 0x0000485B | CNVR_SCU_SD_REGS_SD_REG_DIG_DCDC_VTRIM
[ 3.130306] iwlwifi 0000:00:14.3: 0xA5A5A5A2 | CNVR_SCU_SD_REGS_SD_REG_ACTIVE_VDIG_MIRROR
[ 3.130350] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x23, CPU2 Status: 0x0
[ 3.130354] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
[ 3.130359] iwlwifi 0000:00:14.3: Collecting data: trigger 16 fired.
[ 3.379316] iwlwifi 0000:00:14.3: Firmware not running - cannot dump error
[ 3.391474] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5

This should cover most of the hiccups
https://wiki.archlinux.org/index.php/ASUS_Zenbook_UX430/UX530
In the end, all should work as mentioned there.

Thanks for your reply, but unfortunately these guides make no mention of how to deal with wireless problems :frowning:

What else can I do from the position I am in currently?

I understand they do not specifically deal with wifi issues because, as stated, doing everything as is there should end up with a perfectly working system, except fingerprint and ambient backlight that are only partially working.

Make sure wifi and bluetooth are not hardware disabled.
sudo rfkill unblock all
And also see this

At this point I've reinstalled the OS about 4 times, the only time everything worked smooth was on the first install when I was trying out different distros and I switched to Kali Linux. My Wifi worked for a day on Kali and then stopped. Switching to a fresh install on Manjaro doesn't help now.

rfkill

ID TYPE DEVICE SOFT HARD
0 wlan asus-wlan unblocked unblocked
1 bluetooth asus-bluetooth unblocked unblocked
2 bluetooth hci0 unblocked unblocked
3 wlan phy1 unblocked unblocked

ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlp0s20f0u1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
link/ether 00:1e:a6:99:87:e7 brd ff:ff:ff:ff:ff:ff

I am currently using a WiFi USB Adapter and that seems to work apart from the ethernet. Iplink shows the internal wireless device in an 'unknown' state.

Also looked at your linked topic and I couldn't find a similar listing to blacklist.

I am so tired trying to get this work and at this point just wanna sit down and cry for a while.

Try this:

sudo rmmod asus_nb_wmi && sudo systemctl restart NetworkManager

If that helps then "blacklist asus_nb_wmi"

Tried it, no avail.

I don't think my networks/bluetooth were up during the live boot either prior to the full installation.

Are you dual booting Windows?

No its an absolutely fresh install with the "Erase Disk" option. All files on one disk with an UEFI partition.

Try:

sudo rmmod asus_nb_wmi; sudo modprobe - r btusb; sleep 3 && sudo modprobe btusb; sudo systemctl restart blutooth

Thanks.

This is what I get:

`rmmod: ERROR: Module asus_nb_wmi is not currently loaded
modprobe: FATAL: Module - not found in directory /lib/modules/5.4.44-1-MANJARO
Failed to restart blutooth.service: Unit blutooth.service not found.`

That's because there is a syntax error. I mistyped and missed the letter "e" in bluetooth.

Howsabouts you reboot and run this command one more time:

sudo rmmod asus_nb_wmi; nmcli radio wifi off; sudo systemctl stop bluetooth; sudo modprobe -r btusb; sleep 3; sudo modprobe btusb; sudo systemctl start bluetooth; sudo systemctl daemon-reload; nmcli radio wifi on; systemctl status bluetooth.service 

The phones spellchecker got me again with another systax error, (had to do another edit).

1 Like

So the Bluetooth icon from the notifications panel has now disappeared, but nothing else changed. There are still no Bluetooth Adapters found and internal wireless doesn't work.

Here is the output (driver and service seems loaded though):

bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Mon 2020-06-29 09:12:42 IST; 3s ago
       Docs: man:bluetoothd(8)
   Main PID: 2332 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 9312)
     Memory: 1.0M
     CGroup: /system.slice/bluetooth.service
             └─2332 /usr/lib/bluetooth/bluetoothd

Jun 29 09:12:42  systemd[1]: Starting Bluetooth service...
Jun 29 09:12:42  bluetoothd[2332]: Bluetooth daemon 5.54
Jun 29 09:12:42  systemd[1]: Started Bluetooth service.
Jun 29 09:12:42  bluetoothd[2332]: Starting SDP server
Jun 29 09:12:42  bluetoothd[2332]: Bluetooth management interface 1.14 initialized

Sorry, not sure what to suggest other than to test further kernels and if that doesn't work test some alternate firmware.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by