WiFi connection problems on the older 32-bit laptop

In short:
On the older 32-bit laptop (Packard Bell EasyNote MX ALP-AJAX GN), where initially Windows XP was installed, the computer connects seamlessly using wifi with routers (tested on 2 routers).
Unfortunately, when I run Manjaro on the same laptop (Manjaro32 or older Manjaro..i686) or other Linux (tested 3 other distros) I can not connect using wifi with router / Internet.

Hopefully, you can help me to solve this issue.

In details:
The system correctly shows both the wireless network card and the proper driver for it:

inxi -n
Network: Card-1: Intel PRO/Wireless 3945ABG [Golan] Network Connection
driver: iwl3945
IF: wlp3s0 state: down mac: 02:92:95:62:d0:8b
Card-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
driver: 8139too
IF: enp6s7 state: down mac: 00:18:f3:32:e1:2d

I tried to test different network encryption methods, including the option "open network - no encryption", but always (on 2 different routers) after a dozen seconds of attempting to connect, the message: "Network connection has been disconnected" pops up.
The same happens when I define and initiate a wifi connection using nmtui .

Below iwconfig result:

wlp3s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
lo        no wireless extensions.

enp6s7    no wireless extensions.

I tested the issue on SIM cards of two other ISPs and the problem still occurs.

Based on this article, I tried to disable "iwl3945" hardware scan and installed the wicd package but the problem still occurs.

For testing, I created an open WIFI server: SSID = 'testOpen97'.

  • I did a system restart at 22:29:48,
  • a manual attempt to connect to testOpen97 around 22:31:11,
  • as I guess at 22:31:26 there is a message that the connection failed.

Below is the full log of this 3-minute session:
sudo journalctl -b

And below is a truncated log from this session, showing only events possibly related to the network, wifi and errors:
sudo journalctl -b | grep -iE 'iwl | NetworkManager | wlp3s0 | error'

I hope someone will find something in these logs.

I do not know if this has something to do with my wifi problem, but I see that when the system boots up, an error message appears in the first line, as below:

[FAILED] Failed to start Load Kernel Modules.
See "systemctl status systemd-modules-load.service" for details.

And this command gives the result:

systemctl status systemd-modules-load.service
â—Ź systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2018-12-26 13:28:28 CET; 9min ago
     Docs: man:systemd-modules-load.service(8)
  Process: 493 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 493 (code=exited, status=1/FAILURE)

gru 26 13:28:28 pcl systemd[1]: Starting Load Kernel Modules...
gru 26 13:28:28 pcl systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
gru 26 13:28:28 pcl systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
gru 26 13:28:28 pcl systemd[1]: Failed to start Load Kernel Modules.
sudo ip link set wlp3s0 up

sudo systemctl restart NetworkManager


In all frankness this adapter is so old that it is hardly worth the time or effort involved to try and get it working. A $15 adapter from Amazon or Ebay would be 10x the adapter this will ever be. I would seriously consider buying a replacement.

Excellent job with your logs BTW. I can tell from your post that you are a very competent Linux user. If you can't get this working with your skills, then I think this could be a much longer debugging effort than it's worth for this adapter.

Good luck.

1 Like

Unfortunately, after those commands the result is the same - a pop up message: “Network connection has been disconnected” .

My Linux skills are probably a little bit greater then "newbie" but not enough to do debugging.

Hopefully, someone knows the solution to this issue. Otherwise I will look for an external wifi card (or stay with cable connection).

1 Like

The good news is from your logs it does not appear to be a driver/firmware issue. Unfortunately that leaves a ton of other things on the configuration side that could be hampering connectivity.

ping -c5 localhost 

Is your network hidden?

ping -c5 localhost
PING localhost(localhost (::1)) 56 data bytes
64 bytes from localhost (::1): icmp_seq=1 ttl=64 time=0.356 ms
64 bytes from localhost (::1): icmp_seq=2 ttl=64 time=0.098 ms
64 bytes from localhost (::1): icmp_seq=3 ttl=64 time=0.097 ms
64 bytes from localhost (::1): icmp_seq=4 ttl=64 time=0.097 ms
64 bytes from localhost (::1): icmp_seq=5 ttl=64 time=0.096 ms

--- localhost ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 54ms
rtt min/avg/max/mdev = 0.096/0.148/0.356/0.104 ms

Currently the network is not hidden and is recognized by NetworkManager.
And the issue in Linux occurs always for every kind of network password ( WPA2, WEP and open/no password ).

While in Windows XP the connection is successful even when the network is hidden.

Can you set a static IP address via mac address association in your router. Also disable IPv6 in your router and in Network Managers connection properties. Set IPv6 to ignore in NM.

According to your ping statistics you have internal network connectivity which is good.

I set IPv6 to ignore in NM, but no result.
And to set a static IP address via mac address association in my router is too complicated for me ( I tried to do this and lost a control over router and Internet :frowning: Then I had to restore router to default settings).

You sghould reboot your router and your laptop after making any changes. I think you need to do some research on setting the static IP via mac address association as this could be a big step towards establishing a connection. It is not that difficult and it is knowledge that you really should have for configuring any network.

In my Router (Huawei B315) I have some limited possibility to set DHCP server and MAC address, but I could not find any kind of wiki, where I could find information, written in a way accessible to me, how to set this information so that a static IP between the router and the computer was working.

In addition, this type of solution applies to only one specific home router. And when I'm away, wifi will not work anymore.

That is why it is best to set a static IP at the router level via mac address association and not on the laptop itself. If you set a static IP on your laptop you would have to disable that anytime you wanted to connect to a new network. If you set this on your router it will not affect anything when you attempt to connect to a different network. That is why this is the preferable method with a laptop. On a desktop you can simply set a static IP through Network Manager (as you are not roaming with a desktop).

I can't give you instructions on how to set up your router, as every router is different. As well, I have no idea of what IP range your network is using. You must figure this stuff out on your own.

Again, good luck.

1 Like

There is one more thing you can try.

Disable MAC Address Randomization in NetworkManager.

This is one of the fixes that sometimes helps get a connection.

Try this:

Disabling MAC address randomization may sometimes be required to obtain a connection. MAC address randomization is enabled by default in Network Manager. To disable MAC address randomization we must open, then edit the following configuration file:


Add the following lines to the conf file:


Save the changes and reboot your router and computer.


Unfortunately, disabling MAC address randomization did not helped.

In my router I have 2 tabs in the WIFI area to set the DHCP / IP / MAC. If you were so kind to guide me how to set it up, I would be very grateful.

Tab MAC Filter:

You do not want to use mac address filtering, leave that disabled.

What you are looking for is something like:

Assign an IP by Mac Address

Associate a MAC address

Or something similar to this. Not all routers have this feature, so it possibly is not available on your router.

If you can find a setting for this, assign an IP address that is not used by any other device on your network.

Such as:

How many other devices are successfully connecting via wireless to this router. Have you tested any other networks outside your home to see if you can connect. Is Network Manager showing the full list of detected wifi networks in your area.

Is this router set for 2.4 Ghz band access.

I can not find any settings like "Assign an IP by Mac Address: or "Associate a MAC address".

I was successfully connecting via wireless to this router from an Android smartphone and from this laptop with Windows XP.

I was successfully connecting via wireless from this laptop with Windows XP to Android smartphone set as a router.

Network Manager managers seem to show a full list of detected Wi-Fi networks in my area.

In the router I can select a channel for Wifi to: "Automatic" or from 1 to 13.
I tested every of those options (channels 1 to 13 differ few MHz, all near 2.4 Ghz).
For example, in the log it was: freq=2437 MHz .

Did the wifi work in the live environment.

Please post:

inxi -Fxxxz

I am not sure if I understood you correctly, but for me it was live environment (I could use Internet browser etc.)

inxi -Fxxxz
  Host: pcl Kernel: 4.14.87-1-MANJARO i686 bits: 32 compiler: gcc v: 8.2.1 
  Desktop: N/A wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
  Type: Laptop System: Packard Bell BV product: T12J v: PB63G00048 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Packard Bell BV model: T12J v: 1.0 serial: <filter> 
  BIOS: American Megatrends v: T12JNC.202 date: 07/05/2006 
  ID-1: BAT0 charge: 38.5 Wh condition: 39.1/48.4 Wh (81%) volts: 12.4/11.1 
  model: ASUSTEK T12--22 type: Li-ion serial: <filter> status: Unknown 
  Topology: Dual Core model: Intel T2050 bits: 32 type: MCP arch: M Yonah 
  rev: 8 L2 cache: 2048 KiB 
  flags: nx pae sse sse2 sse3 bogomips: 6386 
  Speed: 798 MHz min/max: 798/1596 MHz Core speeds (MHz): 1: 798 2: 798 
  Device-1: NVIDIA G72M [Quadro NVS 110M/GeForce Go 7300] 
  vendor: Packard Bell B.V. driver: nouveau v: kernel bus ID: 01:00.0 
  chip ID: 10de:01d7 
  Display: x11 server: X.org 1.20.2 driver: nouveau unloaded: modesetting 
  alternate: fbdev,nv,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: NV46 v: 2.1 Mesa 18.2.5 direct render: Yes 
  Device-1: Intel NM10/ICH7 Family High Definition Audio 
  vendor: Packard Bell B.V. driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:27d8 
  Sound Server: ALSA v: k4.14.87-1-MANJARO 
  Device-1: Intel PRO/Wireless 3945ABG [Golan] Network driver: iwl3945 
  v: in-tree:s port: ffa0 bus ID: 03:00.0 chip ID: 8086:4222 
  IF: wlp3s0 state: down mac: <filter> 
  Device-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter 
  vendor: Packard Bell B.V. driver: 8139too v: 0.9.28 port: d800 
  bus ID: 06:07.0 chip ID: 10ec:8139 
  IF: enp6s7 state: down mac: <filter> 
  Local Storage: total: 93.16 GiB used: 6.30 GiB (6.8%) 
  ID-1: /dev/sda vendor: Seagate model: ST9100828A size: 93.16 GiB 
  speed: <unknown> serial: <filter> rev: A scheme: MBR 
  ID-1: / size: 39.16 GiB used: 6.30 GiB (16.1%) fs: ext4 dev: /dev/sda7 
  ID-2: swap-1 size: 1.95 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: nouveau temp: 79 C 
  Fan Speeds (RPM): N/A 
  Processes: 137 Uptime: 2h 25m Memory: 1.97 GiB used: 510.0 MiB (25.3%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: xfce4-terminal inxi: 3.0.28

Login to the terminal as root.

Run the following command:


enter the systems root password.

Then paste in the following commands and execute them:

sudo nmcli networking off
sleep 2
sudo systemctl stop NetworkManager
sleep 2
sudo ip link set wlp3s0 down
sleep 2
sudo modprobe -r iwl3945 
sleep 3
sudo modprobe iwl3945 
sleep 2
sudo ip link set wlp3s0 up
sleep 2
sudo systemctl start NetworkManager
sleep 2 
sudo rfkill unblock all
sleep 2 
sudo nmcli networking on
sleep 2 

Press enter when those commands are completed.

After the commands are finished running post the full input and output even if there is none.

I entered all those commands as root and there was absolutely no output in the terminal after any of those commands.
The only thing what happened was a a pop up message: “Network connection has been disconnected” after the command: sudo systemctl start NetworkManager

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by