Wifi disconnects when closing laptop lid

Or could it be this simple?
I found this somewhere...mentioned a few times.


The WiFi antenna is in the lid so closing the lid changes the antenna performance so much that you see what happens.

It's not a bug, it's not a software setting.

Maybe try lid closed nearest from the wifi source to figure out that !

I've tried this, but the same happened, I don't know how long it takes for the wifi to disconnect, but it does.
When I'm leaving the lid opened, wifi is stable, even for 8 hours or more.

And another thing that might be related, when I'm disconnecting wifi by unticking the 'enable wifi' in the menu-roll down, I'm not able to restore the connection again by ticking the same square.
No signal is found, not mine, none.

I have to reboot or log-out and back in again and all is fine.

Any ideas?

Nobody facing the same issue?

'LLo,

Did you reboot your router/box recently ?

No, haven't touched it for ages.

FWIW, I've tried it with another laptop, with Voyager on it (Xubuntu-like, xfce) and are able to disconnect and reconnect wifi within a blink of an eye.

The problem still persists and there is another remarkable thing I noticed today.
When the laptop awakes from 'sleep' the wifi is also disconnected and not able to reconnect.

I have to reboot to wifi again.
Same cause?

Any ideas?

Your profile says you're running kernel 4.4. Try a newer kernel (i.e 4.6).

Are you sure you are actually disconnected ? Or is the wifi applet just not report activity ? There is a known bug for network-manager-applet after suspend.

Just wondering. Did you partition a swap on your laptop? If not. You could try swap file.
Swap file creation

This seems to be the case, you are right about this.
When I'm disconnecting wifi by unticking en ticking the box in the roll down menu of the applet, the wifi is active but the applet shows no action.

Yesterday it worked fine, but today the same problem occurred.

Is there a work around for the applet bug?

(I have a swap partition..)

I can restart the networkmanager manualy with

sudo systemctl restart NetworkManager

Might be what I thought. See here:

Yep, same thing, so it's a matter of downgrading the applet if you want the problem to be solved.

Only, I don't seem to have the 1.0.12.1 option.

Or use WICD instead?

Your call . Theres nothing wrong with your wifi, just the applet.

That's true, so I'll better wait for an update then.

If the Linux OS is aware of the state change, any useful details will display in 'dmesg' after the network drops. If it's Greek to you, maybe paste it to some sort of pastebin and someone here could make sense of it.

Otherwise, there's not enough information for me to say anything useful. Except maybe personal experience, when I forget to turn off the various "sleep/suspend" options after freshly installing a Linux.

Which is your current version?

Yesterday I was able too untick an tick the box and able to show all routers that are within my range, but today a blank triangle remains and the dropdown menu is short , but wifi works though..

I have 1.2.2-1 installed at the moment.

Then, according to how I read the image posted, you'd want to try backing out to v1.2.0-1, for it's the version released prior to your present version.

Also, if you are not clearing it out, you can possibly find your prior & current versions cached within:

/var/cache/pacman/

As:

ls /var/cache/pacman/network-man*

Oops - Assuming you do want to try the prior version.

Forum kindly sponsored by