Wifi dongle powered off

lsusb shows the wifi dongle, yet the power indicator is off. I installed appropriate dkms driver, it isn't actually loaded though in lsmod or dmesg (rtl8812au-dkms-git).

Bus 002 Device 010: ID 2357:0101 TP-Link RTL8812AU Archer T4U 802.11ac

I would perhaps suggest reinstalling the driver. They need to be rebuilt occasionally.

Follow these steps to Install the rtl8812au-dkms-git driver:

If that doesn't work I would suggest trying different kernels.

Please post:

inxi -Fxxxz

Please post the input/outputs of all requested commands via the terminal as text, (not as pics).

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

1 Like

rfkill is no longer recognized, but I don't suppose you can edit posts on locked threads.

Yes I can edit locked threads.

Did you try rfkill command using sudo.

So reinstalling the driver was all it took to get it working again?

Glad to here it's fixed now.

When I tried it then with sudo it didn't do anything (said that some directories were absent). It does things now that i tried it agian.

I don't know why some users say rfkill doesn't work on their install. I thought it came preinstalled on all Manjaro spins, but perhaps not?

Which Desktop environment are you currently using?

kde, i checked if it was installed and it said linux-tools package or something was installed.

Ya, I don't know why some users say rfkill is not working on their install. It should be present and working on most Manjaro installs, unless perhaps it was a custom Manjaro Architect install with a very minimal base installation.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by