WiFi interface is down and won't enable [solved]

I'm forced to do this on mobile; please forgive any bad formatting and the lack of copy-paste error messages.

My laptop hasn't been able to connect to wireless networks for some time, now; I'm unsure when this started because I use it almost entirely as a desktop replacement, so I can't pin it on a particular event. I would like to fix this, but am unsure of where to begin.

Computer model: ASUS G750 series
Wireless card (lspci): Broadcomm BCM4352
Wireless Driver: wl
"Boot regime": OpenRC
Wireless interface: wlp3s0

In the "old days" (like, 10 years ago), I would just run ifconfig up to bring an interface up (if it was down) and connect from there; eg. with wicd-curses. This computer, however, does not get along with wicd, and thus I'm forced to use NetworkManager. If I type "ifconfig up ", while NetworkManager is running, I get the error "wlp3s0: Host name lookup failure". If I attempt it when NetworkManager is off, it brings the interface up without trouble, but of course I have no way to connect to anything. If I start NM while the wireless interface is up, it brings it down. If I run "ifconfig", the interface doesn't show up. If I run "ifconfig -a", it does. If I try using NM to start it, with "nmcli dev connect wlp3s0", I get the error "Failed to add/activate new connection: A 'wireless' setting is required if no AP path was given.". Frankly, I don't understand this error.
I tried to use the solution given here: I can't connect to wifi because "No Suitable Device Found" , but this has proved unsuccessful, as my NetworkManager.conf file does not accept wlp3s0 as an acceptable [device] (it "must be a key pair or group" or some such shenanigans). Additionally, I cannot see any networks, even when utilizing nmtui, so I do not believe my issue has to do with mac address randomization; I believe there's a problem with the interface itself. Lastly, "rfkill list all" shows my wlan to be soft blocked. Unblocking "works", in the sense that it shows that the soft block had been removed, but does not appear to have an effect on the interface, and I still cannot see other networks in nmtui or any other program.

I suppose I should also mention that the wireless interface doesn't have a "wireless" flag when probed with ifconfig -a, and I wonder if this is the root of the problem?

In any case, thanks in advance. I can't copy/paste in the normal way because I am on very limited internet right now; my modem is out of commission until Friday, and must use my very limited phone data.


I see you're using OpenRC; is your network manager service running? Give the output of rc-status

  • I assume you't tried to use your laptop's wifi elsewhere other than your own broken modem??
  • Physical WIFI switch or keyboard combo (aka airplane mode)? Probably FN-F2 on your machine.
  • Bios Settings?

rc-status (currently plugged into LAN/router):

runlevel-default: dbus, Bluetooth, elogind, NetworkManager, netmount, xdm, alsasound, syslog-ng, acpid, cronie, cupsd, ntpd, local == started; ntp-client == stopped

Dynamic runlevel-hotplugged

Dynamic runlevel-needed/wanted: xdm-setup, modules-load, avahi-daemon == started

Dynamic runlevel-manual

If I unplug it from the LAN, NM changes to inactive, and netmount changes to scheduled.


As for the easy stuff: I've tried all that. FN+F2 doesn't work in Linux on my computer, for some reason (never has), although it is the default key combo for that function. The LED remains on regardless. I have tried to use it to connect at school (it used to work fine), but it can't do anything if the wireless interface (wlp3s0, according to the wl driver) won't even come up. There is no option in the bios settings, and I even pulled the laptop apart to make sure the wireless card was connected to the antenna properly (it is).

My modem is out of commission (roommate decided to factory reset it without telling anybody), but my router is fine.

Okay. Try nmcli radio wifi on

Then ifconfig to see if wlp3so is listed.


Flawless victory. I'll mark this as solved as soon as I figure out how.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by