Wifi is slow after update of plasma(-nm) to 5.17.5

Hey guys,

an older stable update (which thread is now closed) introduced a bug for me which seriously slows down the wifi on my notebook (which got an ath9k card).

Plasma seems to scan continuously for wifi networks, and spams the journal with messages like:

plasmashell[n]: plasma-nm: Wireless scan on "x" failed: "Scanning not allowed while already scanning"

My wifi connection has large dropouts which results in around 20% packetloss and very slow overall performance:

Ping to my wifi router:

rtt min/avg/max/mdev = 1.086/62.088/226.746/71.156 ms

:+1:Welcome to Manjaro!:+1:

Please read this:


and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...

:wink: :+1: :innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...
P.P.S. More specifically: An inxi --full --verbosity=7 --filter would be a helpful start...

1 Like

Why? That's exactly how I quoted the log, to begin with. :confused:

What's going on where? That's the only output plasma-nm generates.

It's a wifi issue... what do my CPU/GPU have to do with my wifi? How exactly is this going to help you determine my issue?

I run the stable branch, up to date of manjaro, since I'm refering to a plasma update I obviously use KDE.

The command you suggested list's a lot of information I consider personal, like my MAC address, private IPv6 addresses, serial numbers of devices etc.

I don't want to publish these informations.

Try this:

inxi -SM; hwinfo --netcard --bluetooth | grep -Ei "(hotplug|speed|model|status|cmd|file|detected|driver:)" | grep -v "Config S" && echo "System install date $(head -n1 /var/log/pacman.log | cut -d " " -f1 | cut -c 2-11)"

Also try locking your connection to a single BSSID in network manager.

Is your network hidden?

2 Likes

Edited. --filter added. Thank you for the feed-back!

:+1: :innocent:

System:    Host: i3 Kernel: 5.4.18-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.17.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Packard Bell product: EasyNote LS11HR v: V1.21 serial: <root required> 
           Mobo: Packard Bell model: SJV70_HR serial: <root required> BIOS: Packard Bell v: 1.21 date: 08/09/2012 
  Model: "Qualcomm Atheros AR93xx Wireless Network Adapter"
  Driver: "ath9k"
  Device File: wlp3s0
  Link detected: yes
    Driver Status: ath9k is active
    Driver Activation Cmd: "modprobe ath9k"
System install date 2018-10-10

Nope. Also, no network setting has been changed. I did install this update mentioned and rebooted.

After the reboot plasma-nm started to continuously spam the journal.

This is already the case. :slight_smile:

iwevent shows also the ongoing scan events:

$ iwevent 
Waiting for Wireless Events from interfaces...
21:52:54.926703   wlp3s0   Scan request completed
21:53:05.919729   wlp3s0   Scan request completed
21:53:16.929626   wlp3s0   Scan request completed
21:53:27.919652   wlp3s0   Scan request completed

I fiddled around with nmcli to enable more debug output and looked at various settings and the issue is now gone.

For the protocol, I had run

nmcli m
nmcli g status
nmcli g permissions
nmcli g logging
nmcli g logging level INFO
sudo nmcli g logging level INFO

As long as this doesn't reappear the issue is fixed for me. Even though I have no idea how.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by