wifi isn't working again in Lenovo g580

Ok before I start this thread I just wanna mention I had this same issue back in June 2017
here is the thread

and again I had this same issue back in June 2018
here is the thread

This problem never got solved, it just start working itself on both time and it took about 50. 131 post. What's really strange is first it occured in June 2017 then it occured in June 2018 I was travelling in June 2019 and now guess what now I'm facing this issue in June 2020 (just wanna put it out there if someone is doing a deep research on broadcom wifi card that in summer it gets worse).

I've got the impression that broadcom sucks but I still wanna keep tryiing becasue

  1. It's my old laptop and I wanna keep it running state
  2. I use it as a server
  3. It's a hybrid card since bluetooth is working I guess there is still chance.

All things are same as mentioned in the above thread except one while running

sudo modprobe -r wl
modprobe: FATAL: Module wl not found.

There was an error in the above command while other gave no error like

sudo modprobe brcmsmac

Network card is BCM4313 802.11bgn

below is the current output

rfkill list all
0: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

uname -r
5.4.44-1-MANJARO

The wl module should automatically load lib80211 or lib80211_crypt_tkip depending on your config.

Try doing:

$ sudo depmod -a

first, then do a new

$ sudo modprobe wl

1 Like
sudo modprobe wl
modprobe: FATAL: Module wl not found in directory /lib/modules/5.4.44-1-MANJARO

Hmm... I think:

Best bet would be to rebuild the broadcom-wl-dkms version of the driver from AUR.
This is the Broadcom 802.11 Linux STA wireless driver.

The DKMS version is kernel / upgrade agnostic, so it will rebuild itself if you update your kernel.
This will of course require that the dkms package is installed, which in turn would require the
linux-headers to be installed, and of course the regular base-devel tools first of all.

Also it conflicts with the regular broadcom-wl so make sure to remove this if you have it present.

1 Like

Sounds like the fix is dead simple. Don't ever use your laptop in the month of June.

Well, that or don't buy Broadcom hardware might be a more satisfactory conclusion I guess. :man_shrugging:

yeah I made up my mind with this , I have another laptop Dell. I just wanna keep it running but I guess it's the never ending loop here

Ya this is fairly common with these adapters. I've gone over 150 posts of, fixed then breaks, fixed then breaks. It gets kind of old as some of these cards are just really flakey that way.

Sorry, but I've been down this road way too many times already. Best to just read a bunch of the old threads on the forum and perhaps you'll find something that may help.

2 Likes

Thank you for your help :hugs:

1 Like

This is the one Hail Mary that might be worth trying:

There is also one other thing that may possibly help. You could try switching from Network Manager to Connman. I have written a tutorial for this so it should e relatively easy.

I would also suggest installing IWD as this helps with some buggy Broadcom adapters. The instructuctions for IWD are included in the Connman tutorial.

I would highly suggest making a timeshift backup before making these major kinds of Network reconfigurations.

If you need to use Bluetooth let me know, as the method I used in the blacklist will prevent bluetooth from being started (even with a manual modprobing).

2 Likes

Or just use the DKMS driver as I mentioned, it will rebuild the needed modules if / when things are updated.
This way you won't experience the WiFi suddenly not being present...

1 Like

yes @cseder I will try this first and then I'll go for installing IWD
but just to make sure broadcom-wl-dkms from AUR not from extra cus there is already broadcom-wl-dkms in extras.
Please my humble apology but what do I have to install and what do I have to remove?

IMO you shouldn't need to use the one in the AUR. I generally refer people to the one in the Manjaro repo.

See here:

yes I avoid that too I once tried already with broadcom-wl from AUR and it was failure.

It didn't work, it's the same problem

Yes I use bluetooth and sometime VPN too but VPN is not that important right now

@tbg I guess to perform this :point_down:

I first have to move back to broadcom-wl because I'm currently in broadcom-wl-dkms

1 Like

Keep stuff separated, don't mix together many possible though not connected causes, shaking it and expecting something useful to come out.

No, this should not be necessary any more, if you use the DKMS driver from AUR.
I will try to explain in a more thorough way in a few hours...

1 Like

Ok I will try that. but the AUR package is out of date it was last update on february 2017 and there was an error while building that

ERROR: Failure while downloading https://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-6_30_223_248.tar.gz
    Aborting...
Failed to build broadcom-wl-dkms-248

Jeez, this is embarrassing AF. My first post on this forum and I don't read through the initial question as good as I should have. I think we're talking about (or I am at least) a different card...

Just to rub it into my own face, what is the device id on that card of yours???

1 Like

BCM4313 802.11bgn

Forum kindly sponsored by