Wifi keeps disconnecting

Disabling MAC address randomization may sometimes be required to obtain a connection. MAC address randomization is enabled by default in Network Manager. It may be disabled by adding the following lines to /etc/NetworkManager/NetworkManager.conf

[device]
wifi.scan-rand-mac-address=no

Save the changes and reboot.

How can I do that.
I tried to type this in Terminal but nothing happened

Are you in you gui desktop. which desktop do you use.

gnome

Open the following file in your text editor.

/etc/NetworkManager/NetworkManager.conf

paste these lines into the open document:

[device]
wifi.scan-rand-mac-address=no

Save the modified file with your sudo password and then reboot.

it's already there
Screenshot%20from%202018-06-21%2017-45-37

Really, that surprises me because your the first one to tell me that. I've suggested it quite often, maybe its become the default again.

please post

rfkill list all

journalctl -p err -b

journalctl -u NetworkManager -b

You might want to post the last one on paste bin.

I had this same issue a year ago as I mentioned in post 11

but back then my newly installed wifi was not working it was working with other wifi's so to solved this problem I installed my old router

so my laptop was working with every wifi it was connecting with every router and hotspot

but this time none of wireless network is showing and sometime wifi icon is not even showing

Are you using the broadcom-wl driver.

I am using wl which is I guess linux414-broadcom-wl

I honestly didn't mark this thread as solved
because when you marked a thread as solved it looks like following screenshot
Screenshot%20from%202018-06-21%2018-18-15

but it looks like as solved Screenshot%20from%202018-06-21%2018-22-00

and Now I am wondering if it is marked as solved should I start it again??

This will test out the driver that comes pre-installed in the kernel. This is only a temporary test, it will only last till you reboot.

Try each of these commands individually, one after the another:

sudo modprobe -r wl
sudo modprobe brcmsmac
sudo systemctl stop NetworkManager; sleep 5; sudo systemctl start NetworkManager 

Those commands will hopefully unload the wl driver, load the built in kernel driver, and restart network manager.
If any command returns an error please post it here.

modprobe -r wl
modprobe: ERROR: could not remove 'wl': Operation not permitted

modprobe brcmsmac
modprobe: ERROR: could not insert 'brcmsmac': Operation not permitted

Network manager command worked but wifi still not showing

sorry I will edit, requires sudo

It wasn't someone edited the title and just put in [Solved], I've removed it.

It was solved , but it only lasted a day. :wink:

Thanks @anon71843593 I didn't know I can do that

Please repeat the commands I posted again, with sudo.

sudo modprobe -r wl
sudo modprobe brcmsmac
sudo systemctl stop NetworkManager; sleep 5; sudo systemctl start NetworkManager 

Do I have to reboot the system
because this time commands gave no error but wifi icon disappeared from Network Manager

Please do not do anything I do not specifically ask you to do

Forum kindly sponsored by