WIFI lost; driver absent?

A bit of background.:
It seems like every few months, a round of updates will wipe out my wifi on 2-3 of my 3 machines (see here for the last round I tried to get help on). I usually just reinstall everything and things move along well for another few months. Last week I experienced the an issue on my desktop and a laptop; NetworkManager was working, I could connect to my usual routers, but I was getting glacial speeds and couldn't ping anything beyond the LAN. I reinstalled everything, but this time opted for i3 instead of Plasma to try out something new, which brings me to the current predicament (none of the above is what I'm trying to troubleshoot now).

On my desktop, everything (which I dual boot with windows; no VPN yet) worked well for a couple of days. As of yesterday, NetworkManager doesn't detect any wifi networks. This is different behavior from what I'm accustomed to; it seems like the driver has been forgotten...

fconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device
System:    Host: whoaeezbeeg Kernel: 5.6.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: i3 4.18.1 info: i3bar 
           dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x serial: <filter> 
           UEFI: American Megatrends v: 1005 date: 08/01/2019 
CPU:       Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 129651 
           Speed: 4047 MHz min/max: 2200/4050 MHz boost: enabled Core speeds (MHz): 1: 4049 2: 4045 3: 4046 4: 4048 5: 4054 
           6: 4048 7: 4049 8: 4052 9: 4050 10: 4049 11: 4049 12: 4051 13: 4045 14: 4051 15: 4051 16: 4048 
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2080 SUPER] vendor: eVga.com. driver: nvidia v: 440.82 bus ID: 0a:00.0 
           chip ID: 10de:1e81 
           Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce RTX 2080 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: NVIDIA TU104 HD Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 0a:00.1 
           chip ID: 10de:10f8 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0c:00.4 chip ID: 1022:1487 
           Sound Server: ALSA v: k5.6.12-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9260 driver: N/A bus ID: 05:00.0 chip ID: 8086:2526 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: f000 
           bus ID: 06:00.0 chip ID: 10ec:8168 
           IF: enp6s0 state: down mac: <filter> 
           IF-ID-1: enp12s0f3u3 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 1.60 TiB used: 36.88 GiB (2.2%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 250GB size: 232.89 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 2B2QEXM7 scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 2B2QEXM7 scheme: GPT 
           ID-3: /dev/sda vendor: Western Digital model: WD10S21X-24R1BT0-SSHD-8GB size: 931.51 GiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: 1A02 scheme: MBR 
           ID-4: /dev/sdb vendor: Crucial model: CT512MX100SSD1 size: 476.94 GiB speed: 6.0 Gb/s serial: <filter> rev: MU01 
           scheme: MBR 
           ID-5: /dev/sdc type: USB vendor: Generic model: Flash Disk size: 1.96 GiB serial: <filter> rev: 8.07 scheme: MBR 
Partition: ID-1: / size: 136.01 GiB used: 9.25 GiB (6.8%) fs: ext4 dev: /dev/nvme1n1p2 
           ID-2: /home size: 778.39 GiB used: 27.63 GiB (3.5%) fs: ext4 dev: /dev/nvme1n1p3 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A gpu: nvidia temp: 43 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 307 Uptime: 40m Memory: 62.79 GiB used: 1.40 GiB (2.2%) Init: systemd v: 245 Compilers: gcc: 9.3.0 
Shell: bash v: 5.0.16 running in: termite inxi: 3.0.37 
hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 
  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  Driver: "r8169"
  Device File: enp6s0
  Link detected: no
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Model: "Intel Wireless-AC 9260"
    Driver Status: iwlwifi is active
    Driver Activation Cmd: "modprobe iwlwifi"
  Model: "MediaTek Cosmo_Communicator"
  Driver: "rndis_host"
  Device File: enp12s0f3u3
  Link detected: yes
    Driver Status: rndis_host is active
    Driver Activation Cmd: "modprobe rndis_host"
  Model: "Intel Bluetooth Device"
  Driver: "btusb"
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"

Thanks for any help you can provide!

Eureka! I tried the power cycling described here and I have WIFI again! I don't understand anything about it, but this seems solved for now. Thanks forum archives and prior contributors, I owe you one.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by