Wifi Network Gone after Suspend [ rt2800usb]

Today waking from suspend Absu had issues. Display wasn't resuming as normal though the system seemed to be working? So I ctrl-alt-f3 blind, login, pass, hoping it worked I typed systemctl reboot. It rebooted, but now I no longer have wifi.
I've restarted NM several times, rebooted. I've also confirmed that the adapter is working in Cinnamon (Dual boot on a second SSD).
The Wifi is getting zero power even though it's seen by Linux and loading the driver.
I've unplugged it and plugged it back in, tried different usb ports as well.

I'm using a Systemd Service unit courtesy of @tbg.
I also have confirmed all my settings in NM are as they should be.
NM just sits there looking stupid. No idea wtf is happening.

Updated inxi -Fxxxza
shaeda@Absu:~$ inxi -Fxxxza
System:    Host: Absu Kernel: 5.3.4-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 root=UUID=a87e8aa0-269b-44b6-9d31-929c645dfd8a rw nowatchdog 
           apparmor=1 security=apparmor udev.log_priority=3 audit=0 
           Desktop: KDE Plasma 5.16.5 tk: Qt 5.13.1 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME B450M-A v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 1820 
           date: 09/12/2019 
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 
           stepping: 2 microcode: 800820D L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 81467 
           Speed: 3041 MHz min/max: 1550/3400 MHz boost: enabled Core speeds (MHz): 1: 3041 2: 1764 3: 3727 4: 1762 5: 3144 
           6: 1755 7: 1620 8: 1389 9: 2635 10: 2160 11: 2597 12: 1449 
           Vulnerabilities: Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: XFX Pine 
           driver: amdgpu v: kernel bus ID: 08:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 2560x1080~60Hz 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.33.0 5.3.4-1-MANJARO LLVM 8.0.1) v: 4.5 Mesa 19.2.0 
           direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: XFX Pine driver: snd_hda_intel 
           v: kernel bus ID: 08:00.1 chip ID: 1002:aaf0 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0a:00.3 chip ID: 1022:1457 
           Sound Server: ALSA v: k5.3.4-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel 
           port: f000 bus ID: 07:00.0 chip ID: 10ec:8168 
           IF: enp7s0 state: down mac: <filter> 
           Device-2: Ralink RT5372 Wireless Adapter type: USB driver: rt2800usb bus ID: 3-2:2 chip ID: 148f:5372 
           IF: wlp9s0f3u2 state: down mac: <filter> 
Drives:    Local Storage: total: 3.41 TiB used: 471.58 GiB (13.5%) 
           ID-1: /dev/sda vendor: Western Digital model: WDS500G2B0A size: 465.76 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 90WD scheme: GPT 
           ID-2: /dev/sdb vendor: Western Digital model: WD20EZAZ-00GGJB0 size: 1.82 TiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0A80 scheme: GPT 
           ID-3: /dev/sdc vendor: Mushkin model: MKNSSDSR250GB size: 232.89 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 2A0 scheme: GPT 
           ID-4: /dev/sdd vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 2J scheme: GPT 
Partition: ID-1: / raw size: 97.75 GiB size: 95.22 GiB (97.41%) used: 35.83 GiB (37.6%) fs: ext4 dev: /dev/sda2 
           ID-2: /home raw size: 367.51 GiB size: 361.24 GiB (98.29%) used: 71.49 GiB (19.8%) fs: ext4 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 36.9 C mobo: N/A gpu: amdgpu temp: 30 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 322 Uptime: 1m Memory: 15.64 GiB used: 1.29 GiB (8.3%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.36 
		   shaeda@Absu:~$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 1b1c:1b2e Corsair Corsair Gaming M65 Pro RGB Mouse
Bus 003 Device 003: ID 1532:0202 Razer USA, Ltd Razer DeathStalker
Bus 003 Device 002: ID 148f:5372 Ralink Technology, Corp. RT5372 Wireless Adapter
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2516:0051 Cooler Master Co., Ltd. AMD SR4 lamplight Control
Bus 001 Device 003: ID 13fe:6300 Kingston Technology Company Inc. Silicon-Power32G
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Network Mangler Status
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
   Active: active (running) since Tue 2019-10-08 11:21:34 CDT; 49min ago
     Docs: man:NetworkManager(8)
 Main PID: 754 (NetworkManager)
    Tasks: 3 (limit: 4915)
   Memory: 17.1M
   CGroup: /system.slice/NetworkManager.service
           └─754 /usr/bin/NetworkManager --no-daemon

Oct 08 11:21:46 Absu NetworkManager[754]: <info>  [1570551706.2458] agent-manager: req[0x5622004088d0, :1.77/org.kde.plasma.networkmanagement/1000]: agent registered
Oct 08 11:53:36 Absu NetworkManager[754]: <info>  [1570553616.4877] radio killswitch /sys/devices/pci0000:00/0000:00:07.1/0000:09:00.3/usb3/3-2/3-2:1.0/ieee80211/phy0/rfkill0 disappeared
Oct 08 11:53:40 Absu NetworkManager[754]: <info>  [1570553620.1566] device (wlan0): driver supports Access Point (AP) mode
Oct 08 11:53:40 Absu NetworkManager[754]: <info>  [1570553620.1571] manager: (wlan0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/4)
Oct 08 11:53:40 Absu NetworkManager[754]: <info>  [1570553620.1936] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:07.1/0000:09:00.3/usb3/3-2/3-2:1.0/ieee80211/phy1/rfkill1) (driver rt2800usb)
Oct 08 11:53:40 Absu NetworkManager[754]: <info>  [1570553620.2138] device (wlan0): interface index 4 renamed iface from 'wlan0' to 'wlp9s0f3u2'
Oct 08 11:54:01 Absu NetworkManager[754]: <error> [1570553641.8595] audit: failed to open auditd socket: Protocol not supported
Oct 08 11:54:01 Absu NetworkManager[754]: <info>  [1570553641.8596] audit: op="radio-control" arg="wireless-enabled" pid=1273 uid=1000 result="success"
Oct 08 11:54:02 Absu NetworkManager[754]: <info>  [1570553642.1332] audit: op="radio-control" arg="wireless-enabled" pid=1273 uid=1000 result="success"
Oct 08 11:54:02 Absu NetworkManager[754]: <info>  [1570553642.3357] audit: op="radio-control" arg="wireless-enabled" pid=1273 uid=1000 result="success"

Seems there is a mismatch as to what you expect and what system says

v[quote="Sinister, post:1, topic:106305"]
found Wi-Fi radio killswitch

Is this indicating your wifi is off? Check with rfkill

Thanks for the reply.
Here's the output.

 1 wlan phy1   unblocked unblocked

Did you change or update your kernel recently? I would suggest switching kernels even if you haven't altered your kernel of late.

1 Like

Yep, there's been a couple kernel updates. Yesterday the update was 5.3.4 I believe.

I'll switch over to Linux52. DERP, sorry, forgot to test another kernel.

1 Like

Also test the status of the service I wrote:

systemctl status network-restart.service

Also any recent linux-firmware or network manager updates.

Here's a good command to narrow down which components that can affect your networking have been updated recently:

cat /var/log/pacman.log | grep -i "d systemd (\|ed linux\|mware\|twork\|dkms ins\|a-nm\|nm-c\|ufw\|dhc\|dns\|wpa\|vnc" | grep -v "head\|nvidia"  | tail -n 30

I'll get you that output in one moment.

I tried all the kernels I have installed. 4.19, 5.2, .5.3. I also just ran my ethernet over and plugged in Absu, NM is just sitting there. Nothing.

brb with the output

Try ConnMan. You might want to downgrade NM or systemd if either have been updated.

 shaeda@Absu:~$ systemctl status network-restart.service
● network-restart.service - Network Suspend/Resume Service
   Loaded: loaded (/etc/systemd/system/network-restart.service; enabled; vendor preset: disabled)
   Active: inactive (dead)

I'm using a thumbdrivve to go back and forth between computers so I'm a bit slow. :rofl:

shaeda@Absu:~$ cat /var/log/pacman.log | grep -i "d systemd (\|ed linux\|mware\|twork\|dkms ins\|a-nm\|nm-c\|ufw\|dhc\|dns\|wpa\|vnc" | grep -v "head\|nvidia"  | tail -n 30
[2019-09-17 05:33] [ALPM] upgraded networkmanager-qt (5.61.0-1 -> 5.62.0-1)
[2019-09-19 17:54] [ALPM] installed linux53 (5.3.0-0)
[2019-09-19 17:54] [ALPM] installed linux53-virtualbox-host-modules (6.0.12-0.10)
[2019-09-20 20:44] [ALPM] upgraded firmware-manager-git (r146.4be086f-2 -> r150.e92478c-1)
[2019-09-23 10:51] [ALPM] removed firmware-manager-git (r150.e92478c-1)
[2019-09-23 10:51] [ALPM] removed gnome-firmware-updater-git (r31.9d823d8-1)
[2019-09-24 08:43] [ALPM] upgraded systemd (242.108-1 -> 242.135-1)
[2019-09-24 08:43] [ALPM] upgraded linux419 (4.19.73-1 -> 4.19.75-1)
[2019-09-24 08:43] [ALPM] upgraded linux419-virtualbox-host-modules (6.0.12-4 -> 6.0.12-5)
[2019-09-24 08:44] [ALPM] upgraded linux52 (5.2.15-1 -> 5.2.17-1)
[2019-09-24 08:44] [ALPM] upgraded linux52-virtualbox-host-modules (6.0.12-4 -> 6.0.12-6)
[2019-09-24 08:44] [ALPM] upgraded linux53 (5.3.0-0 -> 5.3.1-1)
[2019-09-24 08:44] [ALPM] upgraded linux53-virtualbox-host-modules (6.0.12-0.10 -> 6.0.12-1)
[2019-09-30 20:09] [ALPM] installed python2-dnspython (1.16.0-1)
[2019-10-01 12:58] [ALPM] upgraded linux53 (5.3.1-1 -> 5.3.1-2)
[2019-10-01 12:58] [ALPM] upgraded networkmanager (1.20.2-1 -> 1.20.4-1)
[2019-10-02 14:38] [ALPM] upgraded linux-firmware (20190815.07b925b-1 -> 20190926.c0590d8-1)
[2019-10-02 14:38] [ALPM] upgraded linux419 (4.19.75-1 -> 4.19.76-1)
[2019-10-02 14:38] [ALPM] upgraded linux419-virtualbox-host-modules (6.0.12-5 -> 6.0.12-6)
[2019-10-02 14:39] [ALPM] upgraded linux52 (5.2.17-1 -> 5.2.18-1)
[2019-10-02 14:39] [ALPM] upgraded linux52-virtualbox-host-modules (6.0.12-6 -> 6.0.12-7)
[2019-10-02 14:39] [ALPM] upgraded linux53 (5.3.1-2 -> 5.3.2-1)
[2019-10-02 14:39] [ALPM] upgraded linux53-virtualbox-host-modules (6.0.12-1 -> 6.0.12-2)
[2019-10-06 17:15] [ALPM] upgraded glib-networking (2.62.0-1 -> 2.62.1-1)
[2019-10-06 17:15] [ALPM] upgraded linux419 (4.19.76-1 -> 4.19.77-1)
[2019-10-06 17:15] [ALPM] upgraded linux419-virtualbox-host-modules (6.0.12-6 -> 6.0.12-7)
[2019-10-06 17:16] [ALPM] upgraded linux52 (5.2.18-1 -> 5.2.19-1)
[2019-10-06 17:16] [ALPM] upgraded linux52-virtualbox-host-modules (6.0.12-7 -> 6.0.12-8)
[2019-10-06 17:16] [ALPM] upgraded linux53 (5.3.2-1 -> 5.3.4-1)
[2019-10-06 17:16] [ALPM] upgraded linux53-virtualbox-host-modules (6.0.12-2 -> 6.0.12-3)

I've tried Connman on this computer before. It doesn't work to well. Me and my Demon Machines... It's very flaky. Works great on Craptop though.

This bloody computer. About to message an old friend and see if he'd be willing to shoot it with his Barrett.

You upgraded both networkmanager-qt and systemd. Try downgrading them one at a time from your package cache (rebooting after each downgrade). Be sure to reboot your router as well. If still no love, do a factory reset on your router.

Have you tried pinging your network or google etc.

I'm sure you have backups you can restore from, but do not do that unless you've exhausted all your troubleshooting alternatives.

Roger that. Will do.

I actually just did both a couple minutes ago waiting for my fresh cup of coffee.

Yes, there's no connection whatsoever. I'll get a screenshot of what NM is showing me.


No screenshots or I'll have to kill you. :crazy_face: :smile:

I'll do those downgrades now.


1 Like

If you don't get a connection after both downgrades and reboots, I would also try reinstalling the linux-firmware from your package cache (trying older firmware versions). Do not use the kernel you were on when it broke. I would suggest an LTS kernel.

1 Like

Does your bios allow disabling your network adapters. If so toggle it, save, reboot. Toggle it on again.

1 Like

On linux419lts with all suggestions done.

  • downgrade networkmangler-qt, systemd, linux-firmware
  • re-F.reset router, powercycled router (again)
  • disabled LAN in BIOS - reboot
  • re-enabled LAN in BIOS - reboot
  • Didn't post screenshots of any of that.
  • Baseball bat at the ready.

Oh, I also want to mention I disabled my VPN and it's kill switch incase it might have been the issue. It wasn't.

Have you tried to recreate network connections in Network Manager. You could try using nmtui.


I'll try that right now.

Have you tried reinstalling linux-firmware.

Have you tested your USB wifi dongle in your other computer to be sure it hasn't become defective?

Forum kindly sponsored by