Wifi not working anymore

Hey all, so my wifi was working just fine the other day. The only thing I changed was that I downloaded/installed software related to IPython and Jupyter Notebook. When I click on the icon in the bottom right, it doesn't seem to be searching for any hotspots/routers. In fact what I left click it just says

Ethernet Network (in bold)
disconnected (light gray font, faded, cannot click)
VPN Connections > (normal font)

The VPN Connections leads me to one option to add a network. Should I do that? There's a list here... Cisco AnyConnect or openconnect; Juniper Network Connect; Palo Alto Networks GlobalProject; etc. I can also click on create.

If I right click the bottom right icon then there is this list...
Enable Networking (option to check or uncheck this)
Enable Notifications (option to check or uncheck this)
Connection Information (light gray font, faded, cannot click)
Edit Connections...
About

If I check or uncheck the enable things, nothing changes. If I click edit connections a list, "Network Connections" pops up, but I cannot do anything with this page really. I can add or subtract a network, and I can also click a cog icon to edit the highlighted/selected network. In that screen I have tabs: General, Wi-Fi, Wi-Fi Security, Proxy, IPv4 Settings, IPv6 Settings.

Any ideas on this? Thank you! Oh and if you know of a way that I can see all of the software I just recently downloaded, so I can uninstall if, that would be great. I would need to see a date or organize the downloads by date, unless there is another option? Thanks!

Python and python related stuff don't change your network connection

The closest thing to do this is the log

cat /var/log/pacman.log

Or you could just open Add/Remove Software -> click :hamburger: -> View History

1 Like

"Python and python related stuff don't change your network connection"
yeah I know, I'd be a little surprised if it was either of those.

OK I tried that, but I don't see anything in particular that might have changed internet things.

Also, how do you like being a sys admin? Thinking about going down the IT route. Been working on my A+.

Also, if I enter inxi -Nnz I get this...

Network:
Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8168
IF: enol state: down mac:

Does any of that help??

Test out different kernels (at least 4.19 & 5.5).

Please post the output of the following command:

cat /var/log/pacman.log | grep -i "d systemd (\|ed linux\|mware\|twork\|dkms ins\|a-nm\|nm-c\|ufw\|dhc\|dns\|tlp\|wpa\|vnc\|ifplugd\|regdb" | grep -v "head\|nvidia"  | tail -n 30

Okay I'll look into how to upgrade my kernel. I attached the photo of that command. 20200305_190857

So I think I found the spot to change kernels, but they all keep failing. Do I need to stop the current one or remove it or something before I click on "Install", in the Manjaro Settings Manager"?? Thanks.

Sadly I have been dealing with so many Intel networking problems that I forgot about this solution with your same adapter.

Leave the current kernel installed if you are installing a new one, this would install 4.19 from the terminal:

sudo mhwd-kernel -i linux419

I would also test the real time kernels:

sudo mhwd-kernel -i linux54-rt
sudo mhwd-kernel -i linux419-rt

How to switch kernels:

When you reboot if you do not see the grub boot screen press and hold down the ESC, SHIFT or F8 key. This should show the GRUB boot menu if it doesn't appear. As soon as you see the grub boot screen, press the down arrow. Select the "advanced" menu from the choices and press enter. In the next menu you can select the different kernels you have installed to boot from. Select the regular kernel you wish boot into (not the fallback), and then press enter to complete the kernel change.

OK so I tried the rt kernels and got this (maybe it was slightly different somewhere but it looked the same). I also tried to -Syu the 419, but it just says "error: failed retrieving... " or failed to update, for a few. 20200305_193913

You need to use USB phone tethering to start posting your terminal outputs as text. I can not work with pics. I can barely read them.

USB Android phone tethering

https://wiki.archlinux.org/index.php/Android_tethering#USB_tethering

Please format any terminal output with three ``` backticks before and after, as shown in this picture:

Please read this thread on how to post required information properly:

Run:

sudo pacman-mirrors -f 10 && sudo pacman -Syyu

Okay here are some screenshots I've got...
wifiproblems1 wifiproblems2 wifiproblems3 wifiproblems4

I spent my entire last post trying to explain to you how to use phone tethering and post outputs properly and yet you still insisted on posting pics I can not read on my phone.

I do not enjoy dealing with individuals that can not follow directions as it is simply too frustrating.

I hope someone else can assist you.

Good luck resolving your issue,

Yeah sorry I didn't understand it.

Hi, yesterday I decided to try Manjaro for the first time, after install the I couldn't connect to WiFi. Everything that I have found online about this issue did not work for me, it seams that this is a common issue with multiple solutions. After a few hours I found on arch wiki under network configuration that for Intel iwlwifi you can try and add a config file in /etc/modprobe.d/



/etc/modprobe.d/iwlwifi.conf

options iwlwifi 11n_disable=1 swcrypto=1

This was the only thing that worked for my setup, it's an old portage laptop.
After you create the file do a NetworkManager restart

sudo systemctl restart NetworkManager

This is the Arch Wiki link.
And probably is worth mentioning that I am a newbie and this is my second time I write on any forum. Sorry if this is completely stupid but it worked for me.

Welcome to the forum @marius.tcaci and thanks for posting your solution. That is a common iwlwifi fix that I often recommend that works well in many cases.

Unfortunately I don't think that fix will be likely to work in this users case. The main difference being that your driver was not working upon install, and the OP's wifi broke after an update. In this situation it is more likely to be a change in the firmware, kernel, or an important networking component that caused the breakage.

Again, thanks for posting your solution, and welcome to the forum.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by