Wifi not working (Realtek8822be)

After much searching to no avail, I have no idea what is wrong. At first, my wifi kept disconnecting, so I tried changing the drivers to the new AUR rtw88-dkms-git. I worked, but after a reboot, it no longer works. No wifi networks come up in the tray, and it is impossible to check the little wifi button. Ethernet/USB tethering still works.

Here is inxi -Fxxxza --no-host (just noticed the network driver switched from rtw-8822be to rtw-pci, idk when, but it wasn't working in either case)

System:    Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=d6824384-9dfc-4f7d-b68a-8f8b487fda10 rw quiet apparmor=1 
           security=apparmor resume=UUID=24908b5b-e96b-4e3a-acc1-ed049bd1aadf udev.log_priority=3 acpi_osi= 
           Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 wm: kwin_x11 dm: LightDM 1.30.0, SDDM Distro: Manjaro Linux 
Machine:   Type: Convertible System: HP product: HP ENVY x360 Convertible 15-ds0xxx v: N/A serial: <filter> Chassis: type: 31 
           serial: <filter> 
           Mobo: HP model: 85DD v: 40.36 serial: <filter> UEFI: AMI v: F.18 date: 11/07/2019 
Battery:   ID-1: BAT0 charge: 51.2 Wh condition: 54.1/54.1 Wh (100%) volts: 17.4/15.1 model: 333-AC-3E-A SA04055XL 
           type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen+ 
           family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108102 L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33548 
           Speed: 1223 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1259 2: 1367 3: 1235 4: 1272 5: 1330 
           6: 1360 7: 1306 8: 1394 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 04:00.0 
           chip ID: 1002:15d8 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu FAILED: ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.37.0 5.7.9-1-MANJARO LLVM 10.0.0) v: 4.6 Mesa 20.1.3 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 04:00.1 chip ID: 1002:15de 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard 
           driver: N/A bus ID: 04:00.5 chip ID: 1022:15e2 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 04:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.7.9-1-MANJARO 
Network:   Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: Hewlett-Packard driver: rtw_pci v: N/A port: f000 
           bus ID: 02:00.0 chip ID: 10ec:b822 
           IF: wlo1 state: down mac: <filter> 
           IF-ID-1: enp4s0f3u2 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 26.33 GiB (11.0%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB256HAHQ-000H1 size: 238.47 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: EXD70H1Q scheme: GPT 
Partition: ID-1: / raw size: 48.83 GiB size: 47.81 GiB (97.92%) used: 26.33 GiB (55.1%) fs: ext4 dev: /dev/nvme0n1p8 
           ID-2: swap-1 size: 8.01 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/nvme0n1p9 
Sensors:   System Temperatures: cpu: 53.5 C mobo: 43.0 C gpu: amdgpu temp: 53 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 247 Uptime: 3m Memory: 29.34 GiB used: 824.0 MiB (2.7%) Init: systemd v: 245 Compilers: gcc: 10.1.0

Here is rfkill list. When I started this process, only phy0 was showing up. I really have no idea what hp-wifi is, it just showed up at some point.

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hp-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Hi!
Try this
sudo rfkill unblock all
sudo systemctl restart NetworkManager

I must have done that a million times, it doesn't do anything.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by