Wifi not working [wl driver]

I just booted up my old dell vastro with manjaro-xfce , wifi is enabled and rf kill list shows nothing is blocked .

still not being able to connect to my wifi , showing wifi disconnected?

  Host: manickam-pc Kernel: 5.3.11-1-MANJARO x86_64 bits: 64 
  Desktop: Xfce 4.14.1 Distro: Manjaro Linux 
  Type: Portable System: Dell product: Vostro 1550 v: N/A 
  serial: <root required> 
  Mobo: Dell model: 061W4M v: A03 serial: <root required> BIOS: Dell v: A03 
  date: 10/14/2011 
  ID-1: BAT0 charge: 0% condition: N/A 
  Topology: Dual Core model: Intel Core i3-2330M bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 798 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  driver: i915 v: kernel 
  Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 19.2.4 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k5.3.11-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp5s0 state: down mac: 18:03:73:8b:72:c1 
  Device-2: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network 
  driver: wl 
  IF: wlp9s0 state: dormant mac: 8a:8a:60:79:b0:a1 
  IF-ID-1: enp0s26u1u1 state: unknown speed: N/A duplex: N/A 
  mac: 66:56:ea:b0:b5:47 
  Local Storage: total: 298.09 GiB used: 6.77 GiB (2.3%) 
  ID-1: /dev/sda vendor: Western Digital model: WD3200BPVT-75JJ5T0 
  size: 298.09 GiB 
  ID-1: / size: 292.41 GiB used: 6.77 GiB (2.3%) fs: ext4 dev: /dev/sda1 
  System Temperatures: cpu: 49.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2989 
  Processes: 178 Uptime: 19m Memory: 1.79 GiB used: 645.2 MiB (35.3%) 
  Shell: bash inxi: 3.0.36 

Tried rf kill list

rfkill list all
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by