Wifi problem in artix

I installed artix openrc but i have a wifi problem.

It uses wpa supplicant for wifi management. I open wifi in wpa supplicant, then it shows wifis and closes in 5-10 seconds.

I tried installing wifi driver with file(broadcom-wl-dkms) but it didnt fixed it.

I cant find solution.

Please, help me!

Hello,
This is the latest discussion about it


Since you are on artix openrc, maybe this is what you need, but i couldn't confirm

1 Like

What about the artix forum?

1 Like

I find the solution.

This is a wpa supplicant bug. My laptop has bluetooth but when i open wifi wpa supplicant doesnt open bluetooth automatically. When i open bluetooth manually wifi works well.

Please ask the Artix folks for support.

1 Like

I think not.

@bogdancovaciu gave you the solution in the second link he posted about the bug in wpa_supplicant. Why don't you go play your game of silly bug-ger on the Artix forum.

I will mark Bogdan's post as the solution.

2 Likes

Probably the OP never read my links. Anyway, it was your research that got me to it in the first place :slight_smile: :hugs:

1 Like

Ya, both wpa_supplicant and NM are having bugs reported regularly with recent updates.

1 Like

Of all the packages, in all the distros, in all the world (and she walks into mine), NM may be the most frequent problem-child I have ever experienced. Bar none. :frowning:

The thing that's strange is that it always seems to only affect a very small sub set of hardware. Just enough folks ti make it hard to diagnose what the problem is. Then to make it even worse wpa_supplicant bugs out at the same time.

I hate recommending downgrades but next to nobody wants to switch connection managers.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by