Wifi randomly breaks

I am having some troubles with the wifi on my laptop which has Manjaro installed on it.

Right now, the wifi seems to be working well. It connects at a great speed, and works flawlessly. However, at random points, specifically after rebooting, waking the laptop after sleep, logging off and logging back on, etc. the wifi seems to fail.

By fail, I mean that the wifi symbol shows only an Ethernet icon [I'm using KDE on a thinkpad], and wifi seems to be disabled. After enabling it, the wifi indicator on my laptop turns back on, which is a good sign, and the laptop tries to connect to established networks, only for it to be stuck on configuring interface, slowly before saying that the network could not be found from my network interface wlp3s0. I know this isn't a problem with the wifi, because if I reboot, occasionally, it starts working again.

An odd occasion I noticed that could be a wrong assumption on my part is that whenever I tried installing network-manager-applet, the wifi stayed in the same state as mentioned above, without ever connecting to the internet. I might be wrong, but I've rebooted almost 5 times with that application installed, and the wifi never worked during that time.

I do not know which logs to publish, so if logs are needed, please tell me which logs you would like, cause I have no idea what is going on...

Output of inxi -b:

  Host: Kilimanjaro Kernel: 4.14.44-1-MANJARO x86_64 bits: 64 
  Desktop: KDE Plasma 5.12.5 Distro: Manjaro Linux 17.1.10 Hakoila 
  Type: Laptop System: LENOVO product: 4180AJ3 v: ThinkPad T420 serial: N/A 
  Mobo: LENOVO model: 4180AJ3 serial: N/A UEFI: LENOVO v: 83ET63WW (1.33 ) 
  date: 07/29/2011 
  ID-1: BAT0 charge: 49.2 Wh condition: 88.9/94.0 Wh (95%) 
  Dual Core: Intel Core i5-2520M type: MT MCP speed: 1465 MHz 
  min/max: 800/3200 MHz 
  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  driver: i915 v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: intel 
  unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz 
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 18.0.4 
  Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e 
  Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  HDD Total Size: 298.09 GiB used: 21.71 GiB (7.3%) 
  Processes: 174 Uptime: 2h 18m Memory: 7.68 GiB used: 3.12 GiB (40.6%) 
  Shell: zsh inxi: 3.0.08

Now dmesg | grep wifi:

> $ dmesg | grep wifi                                                          
[   10.065654] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[   10.444074] iwlwifi 0000:03:00.0: loaded firmware version op_mode iwldvm
[   10.862651] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   10.862652] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[   10.862653] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   10.862655] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6205 AGN, REV=0xB0
[   11.882735] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
[   22.196811] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   22.486210] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   22.592118] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   22.882684] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   34.932749] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   35.223230] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   68.048540] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   68.339801] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   95.296969] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
[   95.586325] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0

Thank you! Didn't think to look for posting tutorials. Updated post with info.

1 Like

ThinkPads tend to be some of the most Linux-compatible laptops in existence, and I've never had issues with my X61 or X230 (both running MATE). This makes me think it's unlikely to be a kernel or driver issue (though it's always worth trying a different kernel just in case, e.g. 4.16).

Possibly it's a KDE+Network Manager issue, there's a megathread over here:

though many of the issues contained have been solved over time with Network Manager updates.

1 Like

I'm sure you are correct. I was asking just in case. Thanks for redirecting me!

Have a read through, and if nothing seems applicable post back here.

A lot of my posts are pointers rather than plain answers; unless it's a trivial solution, it's almost always better to try to get people to research a little. (This is an old habit of mine which isn't going to go away any time soon...)

That's true. AT least now I know about dmesg and journalctl which showed some errors when this wifi thing happened again. Now to check in that megathread to troubleshoot!

See this post for a solution to wifi not working after coming out of suspend:

Pls send a

dmesg | tail -30

just after the connection is not comming up. U want to look for the link status of wlp3s0.

For what it is worth, I had the same problem after installing Manjaro with the KDE desktop. It looks like I have the same wifi cards, only on an older Dell Latitude E6430 machine.

I installed the XFCE version, and have not lost a wifi connection for several hours this evening. I was reading on the Kubuntu forum, and the wireless manager in KDE may be having an issue with some older machines.

  Host: danny-pc Kernel: 4.17.0-2-MANJARO x86_64 bits: 64 Desktop: N/A 
  Distro: Manjaro Linux 17.1.10 Hakoila 
  Type: Laptop System: Dell product: Latitude E6430 v: 01 
  serial: <root required> 
  Mobo: Dell model: N/A serial: <root required> BIOS: Dell v: A12 
  date: 05/20/2013 
  ID-1: BAT0 charge: 24.8 Wh condition: 24.8/60.0 Wh (41%) 
  Dual Core: Intel Core i5-3340M type: MT MCP speed: 1251 MHz 
  min/max: 1200/3400 MHz 
  Card-1: NVIDIA GF108GLM [NVS 5200M] driver: nvidia v: 390.59 
  Display: x11 server: N/A driver: nvidia resolution: <xdpyinfo missing> 
  OpenGL: renderer: NVS 5200M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.59 
  Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e 
  Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  HDD Total Size: 232.89 GiB used: 9.18 GiB (3.9%) 
  Processes: 170 Uptime: 2h 04m Memory: 15.62 GiB used: 1.10 GiB (7.0%) 
  Shell: bash inxi: 3.
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by