Wifi randomly can't connect once in a while

Hello all, I have this issue where my computer won't connect to the wifi or internet. This problem seems to occur randomly (once a week maybe?), and while I have got it working again each time so far it still occurs. The first time it happened I reconnected to the internet using my phone to provide internet to my computer via usb, and magically the computer decided it could connect through wifi again. The last time it happened I tried the connecting the phone again with no luck, but restarting the router and then the computer seemed to work.

I would just like to fix the cause of this issue if possible. I know it will be probably hard to diagnose since its intermittent, but if you have any advice I would appreciate your input.

I saw reading through google searches people like to see, inxi -Fxxxza:

System:
  Host: micah-ms7c37 Kernel: 5.6.12-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=c498f436-4541-459a-9459-e05237254839 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Micro-Star product: MS-7C37 v: 2.0 serial: <filter> 
  Mobo: Micro-Star model: MPG X570 GAMING PLUS (MS-7C37) v: 2.0 
  serial: <filter> UEFI: American Megatrends v: A.70 date: 01/09/2020 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Full 
CPU:
  Topology: 16-Core (2-Die) model: AMD Ryzen 9 3950X bits: 64 
  type: MT MCP MCM arch: Zen family: 17 (23) model-id: 71 (113) 
  stepping: N/A microcode: 8701013 L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 224124 
  Speed: 3601 MHz min/max: 2200/3500 MHz boost: enabled Core speeds (MHz): 
  1: 3599 2: 2057 3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 3667 
  10: 2057 11: 2036 12: 2058 13: 2054 14: 2200 15: 2199 16: 2200 17: 2201 
  18: 2199 19: 2200 20: 2200 21: 2200 22: 2200 23: 2199 24: 2056 25: 2199 
  26: 2199 27: 2200 28: 2199 29: 2200 30: 2200 31: 2200 32: 2200 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: eVga.com. 
  driver: nvidia v: 440.82 bus ID: 2d:00.0 chip ID: 10de:1e07 
  Display: x11 server: X.Org 1.20.8 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce RTX 2080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 
  direct render: Yes 
Audio:
  Device-1: NVIDIA TU102 High Definition Audio vendor: eVga.com. 
  driver: snd_hda_intel v: kernel bus ID: 2d:00.1 chip ID: 10de:10f7 
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 2f:00.4 chip ID: 1022:1487 
  Device-3: Logitech HD Pro Webcam C920 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-6:2 chip ID: 046d:082d 
  serial: <filter> 
  Sound Server: ALSA v: k5.6.12-1-MANJARO 
Network:
  Device-1: Broadcom and subsidiaries vendor: ASUSTeK driver: brcmfmac 
  v: kernel port: N/A bus ID: 25:00.0 chip ID: 14e4:43c3 
  IF: wlp37s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel port: d000 
  bus ID: 27:00.0 chip ID: 10ec:8168 
  IF: enp39s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 2.73 TiB used: 568.77 GiB (20.4%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 2B2QEXE7 scheme: GPT 
  ID-2: /dev/sda vendor: Samsung model: SSD 860 QVO 2TB size: 1.82 TiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 2B6Q scheme: MBR 
Partition:
  ID-1: / raw size: 931.22 GiB size: 915.60 GiB (98.32%) 
  used: 214.84 GiB (23.5%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 44.8 C mobo: N/A gpu: nvidia temp: 38 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 455 Uptime: 8m Memory: 31.37 GiB used: 1.53 GiB (4.9%) 
  Init: systemd v: 245 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  running in: xfce4-terminal inxi: 3.0.37

and, hwinfo --netcard:

18: PCI 2500.0: 0282 WLAN controller                            
  [Created at pci.386]
  Unique ID: QEsn.cMwjzx6vheE
  Parent ID: KYAc.Bi8_aVsHuA4
  SysFS ID: /devices/pci0000:00/0000:00:01.2/0000:20:00.0/0000:21:03.0/0000:25:00.0
  SysFS BusID: 0000:25:00.0
  Hardware Class: network
  Model: "Broadcom WLAN controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x43c3 
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x86fb 
  Revision: 0x04
  Driver: "brcmfmac"
  Driver Modules: "brcmfmac", "brcmfmac", "brcmfmac"
  Device File: wlp37s0
  Features: WLAN
  Memory Range: 0xf7000000-0xf7007fff (rw,non-prefetchable)
  Memory Range: 0xf6800000-0xf6ffffff (rw,non-prefetchable)
  Memory Range: 0xf2400000-0xf27fffff (ro,non-prefetchable)
  IRQ: 112 (12807 events)
  HW Address: 2c:fd:a1:ce:dc:68
  Permanent HW Address: 2c:fd:a1:ce:dc:68
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 36 40 44 48 52 56 60 64 100 104 108 112 116 132 136 140
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.66 5.68 5.7
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d000043C3sv00001043sd000086FBbc02sc80i00"
  Driver Info #0:
    Driver Status: brcmfmac is active
    Driver Activation Cmd: "modprobe brcmfmac"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #56 (PCI bridge)

53: PCI 2700.0: 0200 Ethernet controller
  [Created at pci.386]
  Unique ID: 8v_F.HkEyQa33Hb2
  Parent ID: TmGY.Bi8_aVsHuA4
  SysFS ID: /devices/pci0000:00/0000:00:01.2/0000:20:00.0/0000:21:05.0/0000:27:00.0
  SysFS BusID: 0000:27:00.0
  Hardware Class: network
  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8168 "RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"
  SubDevice: pci 0x7c37 "X570-A PRO motherboard"
  Revision: 0x15
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: enp39s0
  I/O Ports: 0xd000-0xd0ff (rw)
  Memory Range: 0xf7604000-0xf7604fff (rw,non-prefetchable)
  Memory Range: 0xf7600000-0xf7603fff (rw,non-prefetchable)
  IRQ: 39 (no events)
  HW Address: 2c:f0:5d:08:61:8c
  Permanent HW Address: 2c:f0:5d:08:61:8c
  Link detected: no
  Module Alias: "pci:v000010ECd00008168sv00001462sd00007C37bc02sc00i00"
  Driver Info #0:
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #27 (PCI bridge)

Thank you for your time

Whenever you lose connectivity you should always reboot both your router and computer. Sometimes putting a timer on your router to reboot at say 4am helps with routers that have this issue.

Try this:

Disable MAC Address Randomization in NetworkManager.

Disable MAC Address Randomization with the following command:

echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf

After creating the new conf file, reboot both your router and your computer.

If you find there is no improvement and would like to retain MAC randomization then you can return to using it with this command:

sudo rm /etc/NetworkManager/conf.d/disable-random-mac.conf

Question:

When this happens to your wifi is your Ethernet unable to connect as well.

When this happens to your wifi is your Ethernet unable to connect as well.

I should clarify that when this happens, first the internet goes out and if I try to disconnect and reconnect, I can no longer connect to wifi. However, all my other devices (laptop, phone, etc) can connect to the wifi and ethernet.

I'll try what you said, may take a while to tell if it works or not. Thanks.

Some routers require regular reboots or they will lose connectivity over time. A cheap garden timer is the easiest solution. Install it on the routers power line and set the timer to turn off daily for 15 minutes at a time rarely used for internet.

I suppose this could also be a DNS issue.

Please post your system specs:

inxi -Fxxxza

Maybe it's the router, honestly I was figuring it was probably a driver or something. I've only switched to linux recently, but I never had this issue before I switched, and of course other devices aren't effected. I posted my system specs in the original post though.

Sorry about that, I was reading another help thread at the same time where they hadn't and got them mixed up.

When you find you've lost your internet connection on your Ethernet, is this after starting up the computer, or does the connection just drop.

It just drops on the middle of whatever I'm doing.

Have you replaced the cable with a cable rated cat6 or better.

Have you switched the cable to a different port on the back of the router.

Do you have a spare router you could test out?

The computer is connected through wifi, so there is no cable to the computer.

And no I don't have a spare router. It will take a while anyway to check it your MAC address suggestion works, since it doesn't happen everyday.

I'm afraid you are contradicting yourself. You really need to explain better what your setup normally is. Are you normally using wifi, if so why do you state the Ethernet usually goes out first.

Do you normally have both wifi and Ethernet active at the same time. If so, that can cause problems. On a desktop computer there is no need to have both active. Use one or the other.

Keep the Ethernet disconnected if using wifi, but if you have Ethernet access why would you want to use your flakey problem prone Broadcom wifi adapter.

I have seen cases where the Broadcom firmware for that adapter was at fault:

Word to the wise, on a desktop computer using Linux never purchase a Broadcom based wifi adapter. Generally they are filled with nothing but problems when using Linux.

oh, I meant to be saying internet not Ethernet, I don't why i was typing that, I will edit the posts, so other people reading will not be confused.

Your dhcp lease time may simply be expiring when your internet goes out. You might want to check your lease time in your router settings.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by