Wifi randomly disconnects on kde.

Hello. I have a issue where on multiple devices, my wifi keeps randomly disconnecting. I'm using manjaro kde on the latest update. It seems to have been caused by a linux-firmware update. Any opinions on how to fix?

Wifi cards that drop wifi
- Intel ax200NGW
-Bcm43143
-Intel 622anhmw
Wifi cards that don't drop wifi
-Intel 7265ngw
-Atheros Ar5b22

dmesg from ax200
[16138.791838] iwlwifi 0000:03:00.0: reached 10 old SN frames from 26:ff:ee:ef:e1:a0 on queue 4, stopping BA session on TID 0
[16141.256062] audit: type=1130 audit(1585750992.783:172): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=pamac-daemon comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[16164.405645] audit: type=1100 audit(1585751015.936:173): pid=25344 uid=1000 auid=1000 ses=2 subj==unconfined msg='op=PAM:authentication grantors=pam_unix,pam_permit acct="jecks-thinkcentre" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'
[16164.405779] audit: type=1101 audit(1585751015.936:174): pid=25344 uid=1000 auid=1000 ses=2 subj==unconfined msg='op=PAM:accounting grantors=pam_unix,pam_permit,pam_time acct="jecks-thinkcentre" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'
[16689.462901] wlp3s0: deauthenticating from 26:ff:ee:ef:e1:a0 by local choice (Reason: 3=DEAUTH_LEAVING)
[16689.484273] audit: type=1130 audit(1585751541.013:175): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[16693.376100] wlp3s0: authenticate with 26:ff:ee:ef:e1:a0
[16693.379040] wlp3s0: send auth to 26:ff:ee:ef:e1:a0 (try 1/3)
[16693.403193] wlp3s0: authenticated
[16693.404017] wlp3s0: associate with 26:ff:ee:ef:e1:a0 (try 1/3)
[16693.405379] wlp3s0: RX AssocResp from 26:ff:ee:ef:e1:a0 (capab=0x1011 status=0 aid=10)
[16693.407872] wlp3s0: associated
[16693.412750] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
[16693.434053] wlp3s0: Limiting TX power to 30 (30 - 0) dBm as advertised by 26:ff:ee:ef:e1:a0
[16699.465107] audit: type=1131 audit(1585751550.990:176): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[17389.173512] audit: type=1100 audit(1585752240.694:177): pid=30840 uid=1000 auid=1000 ses=2 subj==unconfined msg='op=PAM:authentication grantors=pam_unix,pam_permit acct="jecks-thinkcentre" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'
[17389.173663] audit: type=1101 audit(1585752240.694:178): pid=30840 uid=1000 auid=1000 ses=2 subj==unconfined msg='op=PAM:accounting grantors=pam_unix,pam_permit,pam_time acct="jecks-thinkcentre" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'
[17394.064034] iwlwifi 0000:03:00.0: reached 10 old SN frames from 26:ff:ee:ef:e1:a0 on queue 7, stopping BA session on TID 0

The cause might be the reached 10 old SN frames?

Related to this patch? https://www.spinics.net/lists/linux-wireless/msg189740.html

Happened again. Note that it refs "frames" again

20480.843617] wlp3s0: authenticate with 26:fe:ee:ef:e1:a0
[20480.845934] wlp3s0: send auth to 26:fe:ee:ef:e1:a0 (try 1/3)
[20480.870934] wlp3s0: authenticated
[20480.871672] wlp3s0: associate with 26:fe:ee:ef:e1:a0 (try 1/3)
[20480.875796] wlp3s0: RX AssocResp from 26:fe:ee:ef:e1:a0 (capab=0x1411 status=0 aid=18)
[20480.880871] wlp3s0: associated
[20480.893861] wlp3s0: Limiting TX power to 30 (30 - 0) dBm as advertised by 26:fe:ee:ef:e1:a0
[20481.013189] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
[20482.663201] wlp3s0: disconnect from AP 26:fe:ee:ef:e1:a0 for new auth to 26:ff:ee:ef:e1:a0
[20482.669326] iwlwifi 0000:03:00.0: expected hw-decrypted unicast frame for station
[20482.669329] iwlwifi 0000:03:00.0: expected hw-decrypted unicast frame for station
[20482.674985] wlp3s0: authenticate with 26:ff:ee:ef:e1:a0
[20482.676930] wlp3s0: send auth to 26:ff:ee:ef:e1:a0 (try 1/3)
[20482.702317] wlp3s0: authenticated
[20482.705053] wlp3s0: associate with 26:ff:ee:ef:e1:a0 (try 1/3)
[20482.712475] wlp3s0: RX ReassocResp from 26:ff:ee:ef:e1:a0 (capab=0x1011 status=0 aid=10)
[20482.715170] wlp3s0: associated
[20482.752317] wlp3s0: Limiting TX power to 30 (30 - 0) dBm as advertised by 26:ff:ee:ef:e1:a0

Which kernel are you using?

I've tried 5.4, 5.5, 5.6rc. Dmesg was taken on 5.4.28

Got to ask (as it affected me), router channel?

How would I check that? I would have to believe 5ghz

I'd been having connectivity issues on kde, connection dropping, slowing to a crawl, and requiring a network manager reset. I've not noticed the issue since the 28th March stable update though.

Will monitor and report back if I notice anything relevant.

I think the issue may be KDE as well, as the second computer isn't giving me any errors in dmesg.

I haven't noticed the issue on either of my xfce systems but those are vms that don't get used as often so it's possible I could have missed it.

I didn't notice the issue on my laptop until I switched to KDE.

1 Like

I use Linssid from the repo:
image

How do you know what this channel is?

Run linssid, look for your router name - in the channel column.

-or-

Log into your router and look at the settings.

If you feel this was caused by the linux-firmware update you could always test downgrading linux-firmware from your package cache.

This service I wrote is a rather hackey workaround, but it keeps a connection running rather well:

1 Like

My networks are set up to use 2.4 and 5ghz.

If there is more than one AP in your vicinity (or you have a dual-band AP with a single SSID) this can result in dropped connections.

Your connection can be lost because of constant scanning by Network Manager, and confusion over which AP to connect with.

To eliminate this possibility you can lock your WiFi connection profile to the BSSID of your favored access point in Network Manager.

You can do this in Network Manager's "Wi-Fi" tab in your connection's properties settings.

There is a "BSSID" drop down field where you can select and lock your Wi-Fi to a single BSSID.



There have also been reports of recent bugs in Network Manager and wpa_supplicant that affect connectivity. Downgrading either or replacing either (or both) might be worth testing.

Thank you so much! I will try your suggestions.

1 Like

Seems to have fixed itself with the latest stable update

1 Like

Forum kindly sponsored by