WIFI speed So Slow...[Broadcom BCM43142 802.11b/g/n]

I Have installed Manjaro kde plasma 20.0.3 on my Laptop I'm connected to the same wifi network with my Laptop & Desktop.

Download speed:

Desktop[Windows 10] :: 5mbps

Laptop[Manjaro 20.0.3] ::300-400Kbps
(Speed Tested on a ftp server)

inxi -Fxz[Laptop]


System:    Host: isifat-hp Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           Desktop: KDE Plasma 5.19.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP Notebook v: Type1ProductConfigId 
           serial: <filter> 
           Mobo: Hewlett-Packard model: 80C3 v: 96.51 serial: <filter> UEFI: Insyde v: F.27 date: 07/05/2018 
Battery:   ID-1: BAT1 charge: 11.4 Wh condition: 27.0/41.4 Wh (65%) model: COMPAL PABAS0241231 
           status: Charging 
CPU:       Topology: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP arch: Haswell rev: 1 
           L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 13574 
           Speed: 799 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 798 2: 798 3: 800 4: 799 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel 
           bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.1.3 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:03.0 
           Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.6.19-2-MANJARO 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 
           v: kernel port: 4000 bus ID: 07:00.0 
           IF: enp7s0 state: down mac: <filter> 
           Device-2: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Hewlett-Packard driver: wl 
           v: kernel port: 4000 bus ID: 0d:00.0 
           IF: wlp13s0 state: up mac: <filter> 
Drives:    Local Storage: total: 960.81 GiB used: 50.01 GiB (5.2%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541010A9E680 size: 931.51 GiB 
           ID-2: /dev/sdb type: USB model: SMI USB DISK size: 29.30 GiB 
Partition: ID-1: / size: 57.42 GiB used: 9.66 GiB (16.8%) fs: ext4 dev: /dev/sda2 
           ID-2: /home size: 248.92 GiB used: 2.40 GiB (1.0%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 7.81 GiB used: 181.2 MiB (2.3%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 213 Uptime: 9h 20m Memory: 3.77 GiB used: 1.74 GiB (46.1%) Init: systemd Compilers: 
           gcc: 10.1.0 Shell: bash v: 5.0.18 inxi: 3.0.37

I Searched on google & tried some tweak on network but it didn't worked.How to fix/Improve network speed??

1 Like

I use same chip with broadcom-wl on my xps 13 works fine.
Following it for further updates on this topic

1 Like

Try disabling IPv6. Be sure to reboot both your router and computer after disabling IPv6. There are numerous ways to accomplish this. Please search the forum for methods.

I would probably also try disabling MAC Address randomization.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by