Wifi Stops working after updating

I installed "manjaro-awesome-18.0-stable-x86_64.iso", and The Wifi worked alright, and connected to both

  1. my personal mobile hot spot
  2. my college provided wifi (wpa2-enterprise).

After install without any tinkering required. (same with the live bootable usb)
but after i updated the system (did not change the kernel Linux 4.19.49-1) the wifi stopped connecting to the college network and keeps disconnecting from the mobile hot spot around every 60s.

I tried to downgrade the networkmanager to the one present in the live usb but it did not work.

I have reinstalled a fresh os and wifi is working again I have yet to update anything please assist on what should i do.

should I update ignoring the network connecting related software ? if yes, then which one should i ignore?

Please post

inxi -Fxxxz

First copy and paste your text/terminal/code into the post
Then select the text/code and click the post edit toolbar button </> .

Show us some journactl info. It should reveal the issue (hopefully):

journalctl -b -p3

EDIT: Ah, just noticed you already reinstalled the system. The command above is helpful if you already have the issue. I guess, @admdb may help.

I think that to really know what went wrong you need to:

  • do a system backup with timeshift
  • update and if the issue is there, you can look for errors, try some solutions, etc. in worst case when you need quickly workable wifi, you can use timeshift to restore old system version.

I would definitely ignore the following packages ■■■■■ dkms-git, ■■■■■ as well as ■■■■■, and whatever you do, don't update ■■■■■.

I'll leave it to you to fill in the blanks as you obviously do not believe that detailed specifics are required. :wink:

1 Like

No need to make fun of the OP @tbg. The question was posted like 4 hours ago, so let him catch up and post the details.

inxi -Fxxxz data as requested
(i downloaded new kernel but old one is still present, have not updated system yet)

System:    Host: Aspire-A7 Kernel: 5.1.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 
           Desktop: Awesome 4.2 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire A717-72G v: V1.19 serial: <filter> 
           Mobo: CFL model: Charizard_CFS v: V1.19 serial: <filter> UEFI: Insyde v: 1.19 
           date: 07/13/2018 
Battery:   ID-1: BAT1 charge: 43.9 Wh condition: 43.9/48.9 Wh (90%) volts: 16.9/15.2 
           model: LG PABAS0241231 type: Li-ion serial: <filter> status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
           arch: Kaby Lake rev: A L2 cache: 9216 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53004 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
           4: 801 5: 800 6: 800 7: 800 8: 801 9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Acer Incorporated ALI 
           driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1c20 
           Display: x11 server: X.org 1.20.3 driver: intel,modesetting 
           alternate: fbdev,vesa compositor: compton resolution: <xdpyinfo missing> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI 
           driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
           Sound Server: ALSA v: k5.1.8-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Acer Incorporated ALI driver: r8168 v: 8.047.01-NAPI port: 3000 
           bus ID: 07:00.1 chip ID: 10ec:8168 
           IF: enp7s0f1 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
           vendor: Lite-On driver: ath10k_pci v: kernel port: 3000 bus ID: 08:00.0 
           chip ID: 168c:003e 
           IF: wlp8s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 6.26 GiB (0.5%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKW256G7 size: 238.47 GiB 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: PSF109C scheme: GPT 
           ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS541010A9E680 size: 931.51 GiB 
           speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: A710 scheme: GPT 
Partition: ID-1: / size: 98.74 GiB used: 6.19 GiB (6.3%) fs: ext4 dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A gpu: nouveau temp: 44 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 232 Uptime: 16m Memory: 15.51 GiB used: 1.13 GiB (7.3%) 
           Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: zsh v: 5.6.2 
           running in: lxterminal inxi: 3.0.27 

1 Like

I apologize for the late reply, I was out of town and unable to access my laptop.

Your supplied solution solved most of the problems but I am still unable to connect to the college network (WPA2-enterprise). Even when all the details supplied are correct, it was functioning properly before.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by