Win 10 *** up my beloved Linux Manjaro


Please I am so frustrated I beg you for help.
I have been using linux since I remember but I had to install linux because of this game I wanted to play with my son. (game wont run on linux) and I was not able to install Win 7. I spend days and I was not able to do it. Then, I made my biggest mistake in my life, which, I before decided not to do under any circumstances. I failed and I regret it instantly. I installed Windows 10.

I honestly HATE windows (especially 8,10 and any newer version which will come).

I did following:
Created 100gb partition NTFS on my ssd for windows 7, but was not able to install on it, so I left it.

I get another HDD (not ssd) and I swap my ssd with this HDD just to install this crap win 10. (my intention was to swap disks back after win 10 install, and connect Win 10 HDD with SATA to USB cable ONLY when I need to run win.)

Installation successfull (they didn't change a thing since win 7 install, just a background color).

I swap disks back, meaning I put SDD with manjaro inside and connect HDD with Win10 with cable (usb to sata) and tried to run win. Win started but failed to boot, (forgot to tell I start Manjaro using UEFI but Win 10 using legacy) and windows started his repair ■■■■■ Which never repaired anything since windows 95.
ofc there is no ■■■■■■■ option to stop that crap so I was basically watching my dear beloved Manjaro and all my files being ■■■■■■ in da ass. (didn't know that yet, but I soon discovered when I tried to boot manjaro back)
Now I can run Windows only when I put HDD with Win10 inside my PC, it won't run using sata to usb cable, its shouting errors and is trying to fix it but its just a loop of restarts. Now I am on Windows 10 and its driving me mental.

Please for the love of god, help me get back to my manjaro. Or at least- help me get my files back!

I installed this ext2 volume manager to access linux filesystems from windows but it only shows RAW label over my linux partitions.

here are my disks, note that disk with linux system is the smaller one.

can you tell me if my data are ■■■■■■ or they are still sitting there?

PS: I am going to make anti windows protest group, in fact I have always been thinking to make one, also anti VEVO group, I think I will merge those two.

If you very hate to see F words around here, please just shout at me and I will fix that straight away. I am very upset and I honestly believe those words must be used when talking windows.

Thanks for any kind of help/info. I know I didn't even ask proper question, I just don't know which direction to go. :frowning:

ANother thing: HOW THE ■■■■ CAN WINDOWS TOUCH ANY DISK HE WANT? I didn't really think it would try to repair disk where is obviously no windows installed. I can't believe it can't even detect correct disk nor give me choice to actually do something about it. I dont know whats going on but I want to murder those bastards. I won't sleep next couple of days for sure!

Not a windows fault but your own.

Just reinstall Windows, using UEFI, install Manjaro and use your backup. Everything will be back and windows will not touch your secound system.

If you dont have a backup (wich would make it another time your fault!) try booting a live Image and look around if there is is everything erased from your linux installation. Usually windows "rapairs" only the MBR so it can boot again, but leaves everything else there, if its another disk. so there is a chance that your data is still there.

Thanks for reply.

I can't install windows using UEFI, because usb won't boot unless in legacy. Also, its totaly different disk, I didn't do a backup as we are talking about another disk! :frowning:

This is why its wise t install windows first, back up Linux and give linux its own boot partition

Get a 64bit image from microsoft, burn it to a usb stick via the tool microsoft provides. Now disable CSM/legacy support in your UEFI-Setup (also disable secure boot).

Now it should work.

Boot from a Manjaro installer image, check your data is still on the local disk, then restore GRUB.


Connect both hdd and sdd inside your pc. There should be at least 2 sata connectors for your system.
To get back your Manjaro,
Boot up Manjaro livecd in UEFI.
Do not boot up livecd OS but just to the install menu.
And there are 2 ways to boot up Manjaro.
There is an entry where it says "Detect EFI bootloaders"
Use that to boot Manjaro.
Another way is to use this.
Whatever way, when booted up to Manjaro Installed OS in the ssd,

sudo grub-install
sudo update-grub.

You will now get back your working Manjaro. cannot boot windows from your Manjaro boot menu.
Because your Manjaro is in uefi and windows is in bios-legacy.
To boot your windows, you will need to go to your boot setup function key (usually one of F8 ~ F12), and select the hdd boot and you can boot up your windows.

Of course the better way is to make both uefi or both bios-legacy, and that means a reinstall and reconfiguration of a disk (losing all data in that disk) to the right partitioning. And that's up to you to decide.

ps: AFAIK, you cannot boot windows from a usb without a 'WintoUSB' program and I not sure if that is even reliable or doable.

1 Like

You are using the ext2fs utility in Windows and the problem is you aren't using it correctly to mount your Linux partition(s). That's why they are doing the disappearing act.

They're still there unless you panic and do something really stupid.

1 Like

Thank you very very much for all replies. If you would think I gave up on this, you would be very wrong. I appreciate every single answer and I will go through this this saturday. I am very busy to deal with this during weekdays. At saturday, I will try everything you mentioned, I honestly wish updating grub would solve this issue.

May I ask, Isn't it an issue to boot from HDD connected using SATA to USB cable? I installed windows on HDD "inside" pc, my wish was to disconnect that HDD afterwards and only boot windows using external cable, but Windows would run repair and screw up. Would it be possible to run at least manjaro this way? (SSD connected via external cable. bios would detect this as a USB memory stick this way)

It certainly should. Depends on the boot order in your BIOS if you're using a BIOS and not EFI. I think it should still boot your preferred way in EFI but I have never tested it other than in a true-BIOS machine, or using BIOS emulation in an EFI machine.

It is okay to run linux OS from an external usb (not windows).
However...there are a few points to watch out.

In bios-legacy, you need to watch out where you 'set your mbr'; in which disk and boot accordingly from that disk.

In uefi, if the external disk needs to be occasionally removed, you will need to set a '--removable' parameter when doing 'grub-install' and when needed to boot external disk after being removed, you will need to boot it through the 'boot setup key (F8~F12)'. But if the external disk is permanently connected, you don't need to worry about this.

You have an extra issue where Manjaro is uefi and windows is bios-legacy. Personally, a bad setup. I can work with this setup but I do not recommend it. We also need to watch out while upgrading that the right mode is booted up else things can get awry.

So it is easier to make both disks 'inside' the pc and connected to the sata ports (use sata0 and sata1) whichever bios-legacy or uefi is used. After all, sata connections are much faster than usb speeds.


Thank you very much for all this help. I had little issues to mount my filesystem as it is encrypted with luks but I managed through.

"Detect EFI bootloaders" didn't work, I had to boot live USB. (probably because I connected SDD after computer booted into live usb. If connected earlier, I could not run into live USB, but to broken man install as both boot devices are considered as USB external drives in this case )

I have used manjaro-chroot -a (in live manjaro instance) which worked great and I reinstalled grup, (with errors) but it still worked and Now I can boot into my dear Manjaro using this external SATA to USB 3.0 cable.
At first, I wanted to use Windows disk with this method, but windows would not run from external device.
Im gonna buy longer cable so It can basically be connected all the time.

jonathon Thanks for link, it didn't work step by step for me, but it pointed me to the right direction!

gohlip, Thanks for everything, one more thing: I forgot to use --removable parameter when I did gtub-install. Does it really needs to be done? I plan to disconnect my manjaro SSD when on windows due to USB ports being occupied. (1 power connector, 2. actual disk)

Thanks others as well, I was worried about my files very much. Thank you

1 Like

This link may help explain further.

Oh, you can redo your grub-install command with the '--removable' parameter. Before disconnecting it.

You're welcome.

thanks for link! Manjaro would not boot after disconnecting SDD and reconnecting. Thus I reinstalled grub with --removable parameter and grub installed with no errors whatsoever.
Thank you very much again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by