Win-Manjaro dualboot -> Grub completely gone after windows update

I just installed manjaro and windows 10 as dualboot. (Because i need adobe lightroom).
Everything worked just fine, grub, choosing booting system etc.

But after windows update (also Firmware of my Lenovo laptop was also updated) the grub is gone.
It's actually there but it won't appear on the boot. I boot straigt into windows.

Now i'm booting into manjaro like this:
I boot my laptop from manjaro usb live image, and choose "detect bootloader" after that choosing manjaro works.

But how can i restore grub so that i can choose windows and manjaro on the boot. thanks

1 Like

This wiki article can help you:

1 Like

i think Win only remove EFI entry boot , check if other option is also modified ( fastboot , etc )

1 Like


$ sudo grub-install
$ sudo update-grub

This are actually the last steps when you installed manjaro from the stick and it should restore your system.

Edith: It is also possible that win10 put itself on top of the bootlist in your firmware.

Depending what you actually mean, it might be easier or less easy to repair your boot.
Have you tried re-installing grub?
It may just be a lost UEFI entry and you may create one from UEFI or Manjaro or WinOS.
Or this

but my bet goes to UEFI reset after firmware update..
There are a couple of tutorials and myriads of similar topics. Since you can actually boot Manjaro, you should not "panic" and do some R&R (Research and Reading, I have to explain, since not everyone knows my invented arctic :joy: )

Are you communicating in Inuit now @AgentS. :smile:

1 Like

Maybe. That depends on the firmware developer. Mine just got updated too and nothing happened. But who knows, I got that little nasty BCD thingy in my setup :stuck_out_tongue_winking_eye:

1 Like

Have you tried searching the forum for similar issues?

Hint ... there are a lot of them ... :slight_smile: .

I apologize for my over-greekiness. Since lots of greek words are international, I thought arktikolexo would also be one, meaning acronym. :disappointed::crazy_face:

1 Like

If you hadn't explained it I would have mistaken it for "Ratz&Ruebe" :crazy_face::rofl:

1 Like

First, Remove "Enable Quick Start" in windows after the update.
Then, if you still have difficulty booting to Manjaro, use this first post to help you. Read completely.

Ignore the rest of the gang here. They are 'old world' :smile: and is normal behaviour with old timers.
I'm worse than them but only to them. :smirk:
You'll get used to us. We mean no harm. Just rascally friendly.


1 Like

Thank you very much.
This solved the problem:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck


sudo update-grub

I had to do this today again, because my lenovo just applied the BIOS Update

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by