Window not displaying properly

Hi everyone! :upside_down_face:
I recently installed Manjaro OS and I have a problem with some windows not showing properly.

This problem first occurs when I installed Visual Studio Code on Snapcraft. Then it occurs with Atom, Steam and now with Insomnia, always via Snapcraft.

I installed Insomnia without any errors, but when I opened it:

  • The window was open in reduced mode. (minimize - reduced - maximized, I dont know the exact terminology of window management :sweat_smile:)
  • The inside of the window was totally blank, I click on Application > Preferences, but nothing happened, it looked "inactive", i.e. when I click on a button, nothing changed.
  • But then I maximized it, I could see the interface with the preferences opened, but freezing, and not maximized.
    (Sorry for the link but as a new users I cannot put more than 1 screen...)

What could be the problem here?


Graphic : Intel® UHD Graphics (Comet Lake 3x8 GT2)
Processor : Intel® Core™ i5-10210U CPU @ 1.60GHz × 8
DE : GNOME 3.34.2


PS: This is my first post, so if there is something I can add to be clearer, do not hesitate to give feedback :innocent:

I'm not in any way, shape, or form an expert regarding this kinds of stuff but have you tried updating to the newest version? Because that's the first thing that will get suggested.

Have a read here: How to provide good information in your posts

I'm far from an expert user myself, but as Karl515 suggests run sudo pacman -Syu in a terminal and see if that helps.

Personally, I stay away from Snaps preferring to use the in built pamac(I think it's in-built, I may have added it). All the Snaps you have listed are already available either in the Community repository or AUR, so would suggest you remove them and install directly from there, especially Steam as it has a Manjaro build.

EDIT: BTW, welcome to Manjaro!

Thanks for your answer :slight_smile:

Ok, I did a
sudo pacman -Syu
sudo pacman -Syyu

following to this tutorial

So now my configuration is updated to the newest.

Configuration update:
GNOME 3.34.4
Insomnia : latest/stable 7.1.1

But the problem persists...

I can only suggest removing the Snap package for Insomnia and installing the version from the AUR, unfortunately that is the limit of my knowledge on this problem. Hopefully a far more knowledgeable person will be able to offer better assistance.

Have you tried reinstalling Insomnia? I think when you update the system the kernel also gets updated, so the new kernel might not be compatible to the version that you have. And also try downloading it in the built in software downloader in your DE. Just search the forums on how to enable AUR in your software downloader.

Can you give me the output of ls -la /etc/X11 ; cat /etc/X11/*.conf

Thanks for your tips!

What I tried, after updating all:

Still the same bug...

ls -la /etc/X11

cat /etc/X11/*.conf

Can you also give me the output of:

inxi -G
mhwd -li
inxi -G

Device-1: Intel UHD Graphics driver: i915 v: kernel
Display: x11 server: X.Org 1.20.7 driver: intel unloaded: modesetting
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics (Comet Lake 3x8 GT2)
v: 4.6 Mesa 19.3.4

mhwd -li

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

If you have the time and you really need your device to work then maybe you should update your copy of Manjaro Gnome. Also try switching to another DE.

Until now I don't see where is the problem coming from. Can you post the output of sudo X -configure, and remember to remove the produced /root/ file.

@Karl515 I would like to avoid this, I really like Gnome ... But it will be a solution if there is no other, indeed :wink:

sudo X -configure

X.Org X Server 1.20.7
X Protocol Version 11, Revision 0
Build Operating System: Linux Manjaro Linux
Current Operating System: Linux brandon-pc 5.5.6-1-MANJARO #1 SMP Mon Feb 24 09:24:51 UTC 2020 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.5-x86_64 root=UUID=bc8279d4-5697-411d-b162-71c5edb2128a rw quiet apparmor=1 security=apparmor udev.log_priority=3
Build Date: 14 January 2020 01:27:33PM

Current version of pixman: 0.38.4
Before reporting problems, check
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 2 18:46:15 2020
List of video drivers:
(++) Using config file: "/root/"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Your xorg.conf file is /root/

To test the server, run 'X -config /root/'

(EE) Server terminated with error (2). Closing log file.

OK guys, I solved my problem, now it is displaying properly.

What I did:

  • Check my Manjaro Settings Manager > Hardware, and see "Unknown device name"
  • I searched about that message and found this topic:
    Intel 620 integrated graphics tearing / flashing
  • I did:
    Create a file /etc/X11/xorg.conf.d/20-intel.conf
    and write this in it:
#this is to use the modesetting driver
#for the intel iGPU instead of the intel driver

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0:2:0"

Then reboot and Insomnia, VSCode, Steam and Atom works perfectly fine now :partying_face: :partying_face: :partying_face:

Thank you all for your help and see you maybe later! :wink:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by